LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-20-2008, 02:24 PM   #1
ddales
LQ Newbie
 
Registered: Jan 2006
Posts: 23

Rep: Reputation: 15
Ubuntu Host Virtualbox guest Networking weirdness


Hi all,

I have a bit of a strange problem with my network interfaces setup to use Virtualbox guests on an Ubuntu 7.10 host. I've adjusted my /etc/network/interfaces to allow for bridging to a static IP on my internal network and bind the tap interfaces to my eth0 through the br0 bridge interface.

auto br0
iface br0 inet static
address 192.168.178.100
netmask 255.255.255.0
gateway 192.168.178.1
bridge_ports eth0 tap0 tap1 tap2

auto tap0
iface tap0 inet static
tunctl_user ddales
address 192.168.178.18
netmask 255.255.255.0
gateway 192.168.178.1

auto tap1
iface tap1 inet static
tunctl_user ddales
address 192.168.178.17
netmask 255.255.255.0
gateway 192.168.178.1

auto tap2
iface tap2 inet static
tunctl_user ddales
address 192.168.178.16
netmask 255.255.255.0
gateway 192.168.178.1

auto eth0
iface eth0 inet static
address 192.168.178.5
netmask 255.255.255.0
gateway 192.16

However, sometimes, not always (maybe every third or fourth reboot of my Ubuntu host), my eth0 main host interface doesn't pull it's IP address. This obviously renders any bridge or tap interfaces lame even though they are assigned the intended IP.

Any suggestions are obviously greatly appreciated!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 7.04 guest on VMPLAYER under WINXP-SP2 Host KrishnaMurthy Linux - Networking 0 07-12-2007 01:22 AM
Copying files from Host (Ubuntu) to Guest (XP) OS with VMWare lebabyg Linux - Software 5 04-10-2007 11:57 AM
problems with Networking with SUSE 9.1 guest on VMWARE on W2K host blackbirddh Linux - Networking 1 08-04-2004 05:56 PM
VMWare on Win XP Host, Mandrake 10 Guest having networking issues inquirer7982 Linux - Software 16 05-27-2004 07:27 AM
Networking - Host hangs during transfer to Guest linuxfond Linux - Networking 1 03-30-2004 05:36 AM


All times are GMT -5. The time now is 04:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration