LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-15-2004, 10:14 PM   #1
inquirer7982
LQ Newbie
 
Registered: Apr 2004
Location: Downingtown, PA
Distribution: Mandrake 10
Posts: 6

Rep: Reputation: 0
VMWare on Win XP Host, Mandrake 10 Guest having networking issues


OK, here's my situation. I have my laptop has a wireless card and built in ethernet. XP is my Host and Mandrake 10 is my Guest using VMWare. All I really care about is allowing these two systems to share files, but Mandrake is not getting an ethernet device. When I load in Verbose mode, eth0 comes up as FAILED. I'm thinking this is because nothing is plugged into the ethernet port, so my question is how do I get an IP address on any Mandrake eth device. Right now my VMWare is set up as NIC 1 - NAT. Any help is appreciated.
 
Old 04-16-2004, 08:59 AM   #2
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
Hi

What version of VMware are you using?

Is there a particular reason that you are using NAT, I tend to use 'bridging' unless I Have a particular need to exclude my VM's from directly accessing my network.

I assume that you have successfully loaded Vmware Tools!

What do you get if you run: ifconfig -a in a console?

What do you get if you run: ipconfig /all in a command line prompt in WinXP?

Are you using Gnome, Kde or another GUI?
 
Old 04-17-2004, 12:58 AM   #3
inquirer7982
LQ Newbie
 
Registered: Apr 2004
Location: Downingtown, PA
Distribution: Mandrake 10
Posts: 6

Original Poster
Rep: Reputation: 0
More info...

I'm using VMware 4.0.5, and VMWare tools are installed.

The reason I'm using NAT is because that's what VMware says to use for the guest networking when using a wireless adapter.

ifconfig -a produces the following..
eth0 Link encap: Ethernet HWaddr 00:0C:29:BBC:F5
inet6 addr: fe80::20c:29ff:febb:dcf5/64 Scoope: Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:14...
TX packets:5...
collision:0....
RX bytes:1721
Interupt:18
eth1 Link encap: Ethernet HWaddr 00:0C:29:BBC:F5
BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0...
TX packets:0...
collision:0....
RX bytes:0
Interupt:19
lo
................................................
sit0
................................................


ipconfig /all produces the following..
Windows IP Configuration
Host Name . . . . . . . . . . . . : c610
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter VMware Network Adapter VMnet8:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet8
Physical Address. . . . . . . . . : 00-50-56-C0-00-08
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.152.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

Ethernet adapter VMware Network Adapter VMnet1:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet1
Physical Address. . . . . . . . . : 00-50-56-C0-00-01
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.36.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection:
Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : 3Com 3C920 Integrated Fast Ethernet Controller (3C905C-TX Compatible)
Physical Address. . . . . . . . . : 00-06-5B-E5-A4-C0

Ethernet adapter Wireless Network Connection:
Connection-specific DNS Suffix . : coatsv01.pa.comcast.net
Description . . . . . . . . . . . : Dell TrueMobile 1300 WLAN Mini-PCI Card
Physical Address. . . . . . . . . : 00-90-4B-66-41-4D
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.100
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 68.82.0.5
68.82.0.6
Lease Obtained. . . . . . . . . . : Friday, April 16, 2004 10:05:11 PM
Lease Expires . . . . . . . . . . : Saturday, April 17, 2004 10:05:11 PM

I'm currently using Gnome w/ Linux Kernel 2.6.3

So... any suggestions? I'm new to this and really lost.
 
Old 04-17-2004, 04:33 AM   #4
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
You do not have an IP address set in your guest. I am in the process of loading Mandrake 10 into a new virtual machine, and I intend to use my centrino wireless connection since it seems to work transparently in both Suse and Redhat, even though in both cases I started them using the Built-in NIC.

I have also chosen NAT networking, even though both Suse and Redhat work fine wirelessly using bridged networking.

I will post here as soon as I am able the process of setting up the network inside Mandrake using Gnome, since I tend to use KDE, and Suse uses YAST for set-up.
 
Old 04-17-2004, 08:45 AM   #5
inquirer7982
LQ Newbie
 
Registered: Apr 2004
Location: Downingtown, PA
Distribution: Mandrake 10
Posts: 6

Original Poster
Rep: Reputation: 0
Cool

Thanks, let me know how that goes. By the way, I dont know what I was thinking saying I use Gnome; I use KDE. Sorry about the confusion.
 
Old 04-17-2004, 12:35 PM   #6
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
okay, after a little trouble loading VMware tools, I mistakenly tried making custom settings under
System ->
Configuraton ->
Configure your computer ->(enter root password) ->
Network & Internet ->
New Connection chose LAN connection (next)
chose eth0: AMD...[PCnet LANCE] (next)
keep Auto IP selection (next) it appears that you don't need a DCHP host name and I turned off -Track network card and Network Hotplugging- (next)
I then entered my linux host name as "Man10" (next)
same for ZeroConf (next)
yes (next)
Yes (next) (finish) Close Mandrake Control center
open a console and as root check ifconfig -a and you should have IP addresses for eth0 in secondline as follows:
inet addr:192.168.0.128 Bcast:192.168.0.255 Mask:255.255.255.0

your konqueror Browser should now work

if so you won
if not leave a further message here

Good luck
 
Old 04-18-2004, 08:48 AM   #7
inquirer7982
LQ Newbie
 
Registered: Apr 2004
Location: Downingtown, PA
Distribution: Mandrake 10
Posts: 6

Original Poster
Rep: Reputation: 0
Not quite...

I thought that may have worked since it needed the install discs, but not quite. It still brings up that I have no ip address. When I type in ifup eth0,

I get this message...
Determining IP information for eth0... failed; no link present. Check cable?

Now you got it to work on your, which is telling me something else is screwed up. If you know how to fix this error let me know, but I think it must be another setting.
 
Old 04-18-2004, 12:56 PM   #8
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
I am assuming here that, after exiting Mandrake Control Center, you did not get the IP addresses shown in my last posting (in Second line of eth0 output of ifconfig -a). I assume also that you created a new connection, rather than 'manage connections' and if so that you were prompted to restart X ??? I achieve this by, as root: init 3 and then: startx. I am not sure this is the right way but it works for me.

If that doesn't work I would suggest that you check the VMware settings under Edit: Virtual Network Settings: [Tab] Host Virtual Network Mapping then click on the ... box on the VMnet8 line. You should then see 3 choices: Subnet..., DHCP..., and NAT... I believe mine are set as 'default' as follows:

Subnet... shows: IP address :192.168.0.0 and Subnet Mask: 255.255.255.0

DHCP... shows: Start IP address: 192.168.0.128 and End IP address: 192.168.0.254

NAT... shows: Gateway IP address: 192.168.0.2 and Active FTP box is checked (port forwarding is balnk) and DNS shows policy as Order and the Auto Dectect box is checked.


If the above doesn't work, please ensure that you have no firewall functioning in WinXP - I actually have Norton Personal Firewall BUT I set it to accept 192,168.0.0 thru 192.168.0.255 (so that my network which runs on a 172.XXX.XXX.XXX IP set actually sees the vmware NAT IP's. I don't use the built-in WinXP firewall.

Once again: Good Luck

Richard
 
Old 04-18-2004, 11:50 PM   #9
inquirer7982
LQ Newbie
 
Registered: Apr 2004
Location: Downingtown, PA
Distribution: Mandrake 10
Posts: 6

Original Poster
Rep: Reputation: 0
Progress

OK, so after a few hours, I got it to work a little. Currently, I have to assign an IP address and have to ifup eth0 as root when I first log on. After that, I have limited access, which is to say an IP address and network access to the master computer. No internet, but thats OK since the host OS has internet. This isn't quite where I want to be, but progress is good. So let's see if anyone can help with this.

I'd like to be able to get a IP Dynamically, access the internet, and view all shares instead of just the master the master OS's. My biggest issue is that I keep getting the 'cable plugged in?' message with a Dynamic IP. If anyone wants to take a shot at this please do; If not I'll eventually figure it out.

Also, thank you minrich for letting me know what I wanted to do was possible, I'd probably have quit if you couldn't get yours working.
 
Old 04-19-2004, 06:56 AM   #10
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
Okay, sorry that didn't work.

I am going to try on last thing here - disable my centrino wireless connection and plug in my netgear Wireless PC Card (32-bit CardBus WG511), to see if I can duplicate your error.

I will post back, if and when I get it to work, together with the steps taken to achieve same.

Don't expect an instant response.
 
Old 04-19-2004, 07:45 AM   #11
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
Well, after a small wait, XP found the PC card network, I then opened VMware and resumed my Mandrake10 VM, and hey presto, clicked on konqueror and am happily surfing the net!! fearless!!

Okay so then I opened Mandrake Contol Center,
Clicked on Network & Internet
Clicked on Internet Access, which shows:
Connection type: lan
Status: testing your connection...
Gateway: 192.168.0.2
Clicked [OK]
Clicked on Proxy, which shows
HTTP Proxy:
FTP Proxy:
Clicked [OK]
Clicked on Manage connections, which shows:
eth0: Advanced Micro devices|79c790 [PCnetLANCE]
TCP/IP (tab) shows:
DHCP
IP address: 192.168.0.128
Netmask: 255.255.255.0
Gateway: 192.168.0.2
DNS servers: 127.0.0.1
192.168.0.2
Search domain: localdomain
Options (tab) [x] start at boot
[ ] Track network card id (useful for laptops)
[ ] Network hotplug
Information (tab)
Vendor: Advanced Micro devices
Description: 79c970 [PCnetLANCE]
Media Class: NETWORK ETHERNET
Module name: pcnet32
MAC address: 00:0c:29:46:60:f3
Bus: PCI
Location on the bus:-

Post if yours says any different.

By the way did you load any firewall package in your original drake10 install? I didn't.
 
Old 04-19-2004, 07:48 AM   #12
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
Sorry but my formatting got lost so it (my last post) ain't too easy to read.
 
Old 04-19-2004, 02:49 PM   #13
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
One last thought (stolen from another post):

if you open Konqueror - click on Location->Open Location and type in:
file:/etc/sysconfig/network-scripts/

double click on ifcfg-eth0

ensure that it has the line: MII_NOT_SUPPORTED=yes

if not add it

log out and try again
 
Old 04-22-2004, 04:38 PM   #14
RabidJackal
LQ Newbie
 
Registered: Apr 2004
Distribution: Mandrake 10.0 | Debian 3.0 | Elx 1.0 | Gentoo (soon)
Posts: 9

Rep: Reputation: 0
Disable Network Hotplugging

I dont know if this will help, but i had hours of trouble trying to get mandrake to connect. I found that the easiest way to go was to disable network hotplugging. Seemed to work first time after that

Hope that helps

RabidJackal
 
Old 04-22-2004, 09:55 PM   #15
inquirer7982
LQ Newbie
 
Registered: Apr 2004
Location: Downingtown, PA
Distribution: Mandrake 10
Posts: 6

Original Poster
Rep: Reputation: 0
OK, I was just about to write a post about how I still cant get it to work, but then I got it to work. So my configuration is like this...

ipconfig for VMnet8...
---------------------
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet8
Physical Address. . . . . . . . . : 00-50-56-C0-00-08
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.116.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

file /etc/sysconfig/network-scripts/ifcfg-eth0
---------------------
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes
HWADDR=00:0c:29:bb:dc:f5
MII_NOT_SUPPORTED=yes
NEEDHOSTNAME=no

ifconfig eth0
---------------------
eth0
Link encap:Ethernet HWaddr 00:0C:29:BBC:F5
inet addr:192.168.116.128 Bcast:192.168.116.255 Mask:255.255.255.0
inet6 addr: fe80::20c:29ff:febb:dcf5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:181 errors:0 dropped:0 overruns:0 frame:0
TX packets:238 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:50676 (49.4 Kb) TX bytes:32691 (31.9 Kb)
Interrupt:18 Base address:0x1080

With this exact configuration, I have everything working. This was a big learning experience for me though, so it was worth it. I'd like to thank both minrich and RabidJackal; your assistance was extremely valuable.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with Networking with SUSE 9.1 guest on VMWARE on W2K host blackbirddh Linux - Networking 1 08-04-2004 05:56 PM
Slow MIDI Playback in VMWARE: Mandrake 10 host, Win 2000 guest Guitarist88 Linux - Software 0 05-17-2004 01:55 PM
No network on Mandrake 9.2 installed has guest on vmware ( host is gentoo ) ikaro Linux - General 1 02-26-2004 06:18 AM
VMWare Linux Guest On XP Host PlatinumRik Linux - Networking 2 02-09-2004 08:05 PM
win xp host rh9 guest on vmware Rh9troublesme Linux - Newbie 1 08-19-2003 06:46 PM


All times are GMT -5. The time now is 06:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration