LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 11-14-2002, 01:37 PM   #1
Guinney
LQ Newbie
 
Registered: Nov 2002
Location: SEMO
Distribution: Gentoo/RH8
Posts: 8

Rep: Reputation: 0
Tulip module name


Trying to migrate from Redhat to Gentoo. I have a linksys network card installed, I have changed my /etc/modules.autoload to include tulip... when the system boots it trys to load tulip and fails. Am I using the right name for the module ? Or do I need to change something else also ?
 
Old 11-14-2002, 02:20 PM   #2
KevinJ
Member
 
Registered: Feb 2001
Location: Colorado Springs, CO
Distribution: Redhat v8.0 (soon to be Fedora? or maybe I will just go back to Slackware)
Posts: 857

Rep: Reputation: 30
What model of Linksys network card is this?

Did it use 'tulip.o' in Redhat?

Can you load the module manually?

-K.
 
Old 11-15-2002, 12:31 PM   #3
Guinney
LQ Newbie
 
Registered: Nov 2002
Location: SEMO
Distribution: Gentoo/RH8
Posts: 8

Original Poster
Rep: Reputation: 0
Its a Linksys etherfast 10/100 card, Not sure if it used tulip in RH or not . I cannot load it manually... looked a bit further and there is no module for tulip in the lib/modules/'uname-r'/kernel/drivers/net .... going to try making changes when I get to the menuconfig option on the install.
 
Old 11-15-2002, 12:40 PM   #4
KevinJ
Member
 
Registered: Feb 2001
Location: Colorado Springs, CO
Distribution: Redhat v8.0 (soon to be Fedora? or maybe I will just go back to Slackware)
Posts: 857

Rep: Reputation: 30
try this:

modprobe -t net *

and it will attempt all of the network card drivers on the system

-K.
 
Old 11-15-2002, 10:25 PM   #5
Guinney
LQ Newbie
 
Registered: Nov 2002
Location: SEMO
Distribution: Gentoo/RH8
Posts: 8

Original Poster
Rep: Reputation: 0
My proctologist just called and informed me of the location of my head. When I made menuconfig I did not include support for tulip in the kernel or as a module... That's what I get for working nights and trying to do the install.... today was my day off and I felt really stupid when I saw where my error was..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
loading tulip module on 2.6.3 alcattle Linux - Software 4 03-09-2004 02:34 AM
tulip module need or the source files. qs_tahmeed Linux - General 1 11-08-2003 11:50 PM
Compile tulip.c to tulip.o? WKoepp Linux - General 10 11-06-2003 09:15 AM
NIC Installation: Cannot load Tulip module jadugarr Slackware 9 07-21-2003 04:10 AM
tulip and netcard dai Linux - Networking 2 02-19-2003 12:41 PM


All times are GMT -5. The time now is 01:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration