LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-25-2007, 07:10 AM   #1
vega2k
LQ Newbie
 
Registered: Oct 2007
Location: 127.0.0.1
Distribution: Ubuntu 7.10, Debian 4.0
Posts: 13

Rep: Reputation: 0
Samba doesn't work with users


Hello, I have tried to configure samba but I get this error "session setup failed: NT_STATUS_LOGON_FAILURE" when I try to connect to the server then I have "security=user" option on but then I set "security=share" I can connect to the server but only public folders.
I have added the user I try to logon to in the smb user/password file and added the user to the main Unix system.
I hope someone can help me with this because it's the first time I'm setting up Linux almost myself. ^.~
My system is running, Ubuntu 7.10.

smb.conf
Code:
[global]
    # General server settings
    netbios name = server
    server string =
    workgroup = homenetwork.com
;    wins support = yes
    dns proxy = no

    panic action = /usr/share/samba/panic-action %d
    log file = /var/log/samba/log.%m
    max log size = 1000
    syslog = 1

;    security = share
    security = user
    username map = /etc/samba/smbusers
    encrypt passwords = true
    passdb backend = tdbsam
    obey pam restrictions = yes
    invalid users = root

;   unix password sync = no
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *passwd:*password\supdated\ssuccessfully$

    announce version = 5.0
    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192

[shared]
    comment = winshare
    path = /samba/
    public = yes
    writable = yes
    public = yes
    writable = yes
    public = yes
    writable = yes 
    valid users = vega2k
    create mask = 0744 
    directory mask = 0755
    admin users = admin
    force user = nobody
    force group = nogroup
 
Old 10-26-2007, 04:10 AM   #2
DiBosco
Member
 
Registered: Nov 2001
Location: Manchester, UK
Distribution: Mandriva, Mandriva, Mandriva. (Three different releases depending on the computer)
Posts: 710

Rep: Reputation: 35
When you say you've added the user, have you added both the Linux account user on the server and the smbuser too? You have to do something like:

smbpasswd -a username

Where username is the name of the person for whom you have set-up a Linux account for on the server.

Please double check that syntax if it's not working!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba doesn't work with users vega2k Linux - Server 3 10-25-2007 02:28 PM
Active directory users to Samba users alexpacio Linux - Networking 0 05-19-2006 08:44 AM
I can't add users to "samba users" in control center g_jakes Linux - Security 3 05-20-2005 02:10 PM
can't add users to "samba users" in control center g_jakes Linux - Networking 1 05-20-2005 01:28 PM
can't add users to "samba users" in control center g_jakes Linux - Wireless Networking 1 05-20-2005 01:27 PM


All times are GMT -5. The time now is 12:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration