LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-13-2004, 03:52 PM   #1
GGSpike
LQ Newbie
 
Registered: May 2004
Location: Montreal
Distribution: Fedora Core 1
Posts: 10

Rep: Reputation: 0
Unhappy RH9 on VMWare Eth0 "No Link Present"




I am not able to setup my eth0 on RH linux 9 installed on a vmware GSX server 3.

I recieve the error message : Determining IP information for eth0... Failed! no link present. Check Cable.

- I use Bridged networking
- Card detected : AMD PCnet 32 Lance
- Driver : AMD PCnet 32


Can someone help???



GG
 
Old 05-13-2004, 04:06 PM   #2
TheOther1
Member
 
Registered: Feb 2003
Location: Atlanta, GA
Distribution: RHAS 2.1, RHEL3, RHEL4, SLES 8.3, SLES 9, SLES9_64, SuSE 9.3 Pro, Ubuntu, Gentoo
Posts: 335

Rep: Reputation: 32
When you ran vmware-config.pl, (you did run that didn't you?) did you go through the networking section and answer no to NAT and no to Host-only? Also it looks as if RH9 is trying to get a DHCP address...
 
Old 05-14-2004, 10:33 AM   #3
GGSpike
LQ Newbie
 
Registered: May 2004
Location: Montreal
Distribution: Fedora Core 1
Posts: 10

Original Poster
Rep: Reputation: 0
I did run the vmware-config-tools.pl but i didn't see the NAT part! but i can say that it is configured to get the IP adress with DHCP.

Is there an option to the script to force the config to pass by the networking section?
 
Old 05-14-2004, 10:48 AM   #4
TheOther1
Member
 
Registered: Feb 2003
Location: Atlanta, GA
Distribution: RHAS 2.1, RHEL3, RHEL4, SLES 8.3, SLES 9, SLES9_64, SuSE 9.3 Pro, Ubuntu, Gentoo
Posts: 335

Rep: Reputation: 32
Not that I am aware.

You can run the script again and when prompted about skipping over networking and keep existing settings, answer NO and then use wizard, answer no to NAT and NO to Host-Only and you should be all set for Bridged mode.

I'm not sure how bridged mode would get an IP through DHCP unless the host was providing that service. I'm not sure it could get outside the host for that. Sorry, I have all ststic IPs configured here so I can't even test since I don't have a DHCP server.
 
Old 05-14-2004, 11:40 AM   #5
GGSpike
LQ Newbie
 
Registered: May 2004
Location: Montreal
Distribution: Fedora Core 1
Posts: 10

Original Poster
Rep: Reputation: 0
When I run the script it doesn't ask me for networking, it just asking about the screen resolution!

Thanks for your help so far!

GG
 
Old 05-14-2004, 03:18 PM   #6
TheOther1
Member
 
Registered: Feb 2003
Location: Atlanta, GA
Distribution: RHAS 2.1, RHEL3, RHEL4, SLES 8.3, SLES 9, SLES9_64, SuSE 9.3 Pro, Ubuntu, Gentoo
Posts: 335

Rep: Reputation: 32
I'm talking about the script on the host, where GSX is running, not on the guest where your RH9 is running without an IP... There are no resolution settings in the vmware-config.pl file, only networking, remote ports, location of vmware machines, serial number, etc.
 
Old 05-14-2004, 03:29 PM   #7
GGSpike
LQ Newbie
 
Registered: May 2004
Location: Montreal
Distribution: Fedora Core 1
Posts: 10

Original Poster
Rep: Reputation: 0
The host is a win2k machine and i don't see a vmware-config.pl file???
 
Old 05-14-2004, 03:50 PM   #8
TheOther1
Member
 
Registered: Feb 2003
Location: Atlanta, GA
Distribution: RHAS 2.1, RHEL3, RHEL4, SLES 8.3, SLES 9, SLES9_64, SuSE 9.3 Pro, Ubuntu, Gentoo
Posts: 335

Rep: Reputation: 32
Oh! Sorry, I was assuming your host was Linux.

I found this on VMware's site:

Getting a DHCP Address in a Red Hat Linux 9.0 Virtual Machine

When a Red Hat Linux 9.0 guest operating system tries to get a DHCP address, the attempt may fail with an error message that states the link is down. On ESX Server, this happens only if you are using the vlance driver for your network connection.

To work around this problem, become root (su -) and use a text editor to edit the following files in the guest operating system. If only one of these files exist, make the change for that file only.

/etc/sysconfig/network-scripts/ifcfg-eth[n]

/etc/sysconfig/networking/devices/ifcfg-eth[n]

In both cases, [n] is the number of the Ethernet adapter for example, eth0.

Add the following section to each of these two files:

check_link_down () {

return 1;

}

Then run the command ifup eth[n] (where [n] is the number of the Ethernet adapter) or restart the guest operating system.
 
Old 05-14-2004, 04:36 PM   #9
GGSpike
LQ Newbie
 
Registered: May 2004
Location: Montreal
Distribution: Fedora Core 1
Posts: 10

Original Poster
Rep: Reputation: 0
Good! I was able to activate my eth0

I'm now fighting to get the internet working!!!!

Thanks for your help, GG!
 
Old 12-17-2004, 01:39 PM   #10
JordanH
Member
 
Registered: Oct 2003
Location: Toronto, Canada
Distribution: Ubuntu, FC3, RHEL 3-4 AS Retired: SuSE 9.1 Pro, RedHat 6-9, FC1-2
Posts: 360

Rep: Reputation: 30
Thanks, TheOther1.

For future reference for the next guy that runs into this problem,

Running:
Host: WinXP Pro with VMWare 4.5.2
VM: RHEL3

Error message when bringing up ethernet adapter contained the phrase, "no link present... check cable?"

The solution is/was as above.
 
Old 12-28-2007, 10:22 AM   #11
aks_k1
LQ Newbie
 
Registered: Dec 2007
Posts: 1

Rep: Reputation: 0
Good solution

Folk,

thanks a lot for this solution.. it helped me get out of the same error as above..

I've got RHL9.0 on WinXP using VMware server 1.0.4.

Cheers,

Aks
 
Old 04-01-2008, 08:32 AM   #12
thekillerbean
Member
 
Registered: Jan 2002
Distribution: Ubuntu 12.04.2 (Precise)
Posts: 89

Rep: Reputation: 16
Interestingly enough, I too was able to resolve this issue by following above solution. Was getting the same error on a RHEL3 AS Guest on Windows Vista Ultimate and VMware Server 1.0.4

Kudos...

Last edited by thekillerbean; 04-01-2008 at 08:33 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"creating symbolic link" "operation not permitted" wheni Linux - Newbie 3 05-08-2011 02:36 AM
echo "blabla" in a script present present in /etc/rc.d/rc5.d/S96dinesh murugesan Linux - Newbie 3 04-14-2009 11:53 PM
eth0 "not present" according to Redhat 9 briankb713 Linux - Networking 7 01-25-2005 04:45 AM
wireless drivers installed, card on lspci, "hardware NOT present" colindownes Linux - Wireless Networking 1 12-21-2004 07:27 PM
"3C509XX not present on eth0, deferring configuration" pcardout Linux - Newbie 0 07-11-2004 05:36 AM


All times are GMT -5. The time now is 09:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration