LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 02-21-2003, 11:56 PM   #1
Grim Reaper
Member
 
Registered: Apr 2002
Distribution: Gentoo 2006.0 AMD64
Posts: 399

Rep: Reputation: 30
Problem with adding default route...


Just having a bit of trouble...I'm trying to issue this command to add a default route: route add default gw 192.168.0.1 metric 1
now, i issue that command and it executes fine, but then when i go 'route' to check if it was added to the routing table, it displays the first two routes that were already in there (localnet and loopback routes) then hangs for about 20 seconds then im droppde back to the console, it doesn't even display the newly added default route...any idea's?
 
Old 02-22-2003, 08:29 AM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Not sure if this will work or not but try dropping off the metric 1 your trying to set. It isn't necessarily needed. Or you can try with a metric M. But I never use the metric option when setting a default route.
If that doesn't work and you have maybe two NIC's, try specifying the nic like:

route add default gw 192.168.0.1 dev eth0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dhcpcd not adding default route cpsully69 Linux - Networking 2 09-07-2004 10:09 PM
Route to subnet exists but I get "Network unreachable" when adding default route fciuffani Linux - Networking 4 08-18-2004 03:11 PM
Adding default route breaks ping howlie Linux - Networking 4 07-29-2003 11:18 PM
Default route problem.. (typical) unmada Linux - Networking 1 02-20-2003 07:46 AM
Adding default route on startup? WeNdeL Linux - Newbie 2 01-08-2003 02:00 PM


All times are GMT -5. The time now is 03:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration