LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-30-2005, 02:38 PM   #16
Avatar
Member
 
Registered: May 2001
Location: Canada
Distribution: old ones
Posts: 532

Rep: Reputation: 30

named:

"service named status" or "service named start"
 
Old 03-30-2005, 02:59 PM   #17
br_sriram
Member
 
Registered: Sep 2004
Posts: 30

Original Poster
Rep: Reputation: 15
Avatar,
The 'named' service was down and I restarted it. But, there is no improvement. I have tried the iptables -L INPUT and Output commands. The following are the results.

------
#iptables -L INPUT
Chain INPUT (policy DROP)
target prot opt source destination
ACCEPT all -- anywhere anywhere
DROP !icmp -- anywhere anywhere state INVALID
common all -- anywhere anywhere
LOG all -- anywhere anywhere LOG level info prefix 'Shorewall:INPUT:REJECT:'
reject all -- anywhere anywhere


#iptables -L OUTPUT
Chain INPUT (policy DROP)
target prot opt source destination
ACCEPT all -- anywhere anywhere
DROP !icmp -- anywhere anywhere state INVALID
common all -- anywhere anywhere
LOG all -- anywhere anywhere LOG level info prefix 'Shorewall:INPUT:REJECT:'
reject all -- anywhere anywhere



------

Thanks,
Sriram.
 
Old 03-30-2005, 03:14 PM   #18
br_sriram
Member
 
Registered: Sep 2004
Posts: 30

Original Poster
Rep: Reputation: 15
Thumbs up

Avatar,

Thanks for all your helps...!!! The firewall Shorewell was enabled and I stopped it and immediately I could ping both ways.

Thank you very much and I appreciate.

Thanks.
Sriram.
 
Old 03-30-2005, 03:22 PM   #19
br_sriram
Member
 
Registered: Sep 2004
Posts: 30

Original Poster
Rep: Reputation: 15
Avatar,

I am going to physically connect the second LAN card now on the machine. What are the issues I have to take care? I want both of the LAN cards work in tandem and the second one should be our Internet Gateway. Please throw some light.

TIA,
Sriram.
 
Old 03-30-2005, 03:48 PM   #20
Avatar
Member
 
Registered: May 2001
Location: Canada
Distribution: old ones
Posts: 532

Rep: Reputation: 30
Glad you got your problem solved! I can't believe I didn't think of that as I also had to disable shorewall on my server.

For your 2 network cards I have the same setup, with eth1 connected to the LAN and eth0 connected to the ADSL modem (Internet.)

Eth1 static IP address is be on the same subnet, and your clients' gateway should be the IP address on the LAN side.

Eth0 is connected via ppp0 and has a dynamic, public IP address assigned by the ISP. (so don't give it a static IP address).

Internet -- eth0 (ppp0) -- server -- eth1 -- LAN

Here's my ifconfig, in case it helps.

Code:
[root@localhost etc]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:09:6B:63:15:4E
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9892005 errors:28924 dropped:0 overruns:0 frame:0
          TX packets:9277365 errors:0 dropped:0 overruns:0 carrier:0
          collisions:28924 txqueuelen:100
          RX bytes:221140017 (210.8 Mb)  TX bytes:1556996141 (1484.8 Mb)
          Interrupt:24 Memory:fbff0000-fc000000

eth1      Link encap:Ethernet  HWaddr 00:09:6B:63:15:4F
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9001890 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10775050 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:1644557709 (1568.3 Mb)  TX bytes:1519710749 (1449.3 Mb)
          Interrupt:25 Memory:fbfe0000-fbff0000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4497506 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4497506 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:446697552 (426.0 Mb)  TX bytes:446697552 (426.0 Mb)

ppp0      Link encap:Point-to-Point Protocol
          inet addr:64.231.100.148  P-t-P:64.230.254.76  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:567950 errors:0 dropped:0 overruns:0 frame:0
          TX packets:548420 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:497050156 (474.0 Mb)  TX bytes:81051346 (77.2 Mb)
 
Old 03-31-2005, 08:56 PM   #21
br_sriram
Member
 
Registered: Sep 2004
Posts: 30

Original Poster
Rep: Reputation: 15
Hi Avatar,

Thanks for your reply. In my ifconfig, pppo is not listed. How can i get it listed?

TIA,
Sriram.
 
Old 04-04-2006, 07:36 PM   #22
pfrancav
LQ Newbie
 
Registered: Feb 2004
Posts: 13

Rep: Reputation: 0
Hi, I've a similar problem to br_sriram
When I ping any ip address, I receive the same message
operation not permitted

I've Fedora 4, and it was working until I update the kernel to 2.6-1.16
I update the kernel via a rpm downloaded from de fedora web page.

I try to disable iptables, but this don't work for me ..

any help ??
 
Old 04-03-2007, 05:40 AM   #23
feitingen
LQ Newbie
 
Registered: Apr 2007
Location: Norway
Distribution: debian
Posts: 2

Rep: Reputation: 0
I have the same problem me too, except it's only for one of two nic's. I have currently flushed and rebuilt my routing tables, and iptables is empty with default INPUT, OUTPUT, FORWARD set to ACCEPT.
I can ping with my first nic, and get reasonable responses, but with my second nic i get
ping: sendmsg: Operation not permitted.
and that goes not only for ping, it seems to be something blocking the damn thing, and i can't figure out what
 
Old 05-18-2007, 10:28 AM   #24
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Rep: Reputation: 47
The title of the thread is such and the content good so it comes on google easy.

I just thought it was worth adding to all this that quite often on a LAN the ping error
is due to the firewall not letting anything out, and as shorewall is used by many,
worth saying "have a look in /etc/shorewall/policy or rules and be sure to have"
ACCEPT fw net all
(that is accept all outgoing traffic from the fw to the net.
It is better than stopping shorewall all together. To restart, as root
service shorewall restart (once rules or policy are edited)
But you might want to be more granulous than that...
 
Old 04-03-2011, 11:12 AM   #25
Pentti Poytakangas
LQ Newbie
 
Registered: Mar 2011
Location: House
Distribution: S64-14.1/multilib
Posts: 18

Rep: Reputation: 1
ping not allowed

hi
I have belkin g router and there's in settings is yes/not allow wan pinging...that's why i'we get that message too.Everything else work's.
Check this setting.

good luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't ping localhost (ping: sendto: Operation not permitted) mentor99us Linux - Networking 7 09-05-2012 02:11 PM
Operation not permitted jakkals Linux - General 3 09-26-2005 07:30 PM
su - operation not permitted jrtayloriv Linux - Newbie 2 06-09-2005 09:27 PM
operation not permitted jamaso Slackware 2 05-08-2004 05:55 AM
Operation not permitted FrozenShadow23 Linux - Newbie 6 10-05-2003 05:13 PM


All times are GMT -5. The time now is 07:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration