LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-21-2004, 10:09 AM   #1
psikatana
LQ Newbie
 
Registered: Mar 2004
Location: The Netherlands
Distribution: Debian GNU/Linux (Sarge)
Posts: 6

Rep: Reputation: 0
Question No internet on Mandrake, eth0 fail. please help.


Hello everyone!

I have the following problem under Mandrake Linux 9.2 / 10.0

I can't connect to the Internet, because eth0 and also eth1 won't initialize on boot-up.
Both NIC's have a Realtek 8139 chip.

I have tried the following to solve the problem:
-The alias for both cards in modules.conf are 8139too, I replaced them with 8139cp, no result.
-I put 8139too and 8139cp in modprobe.preload, no result.
-Since I obtain a dynamic IP from my ISP, I tried to use DHCPCD, again without succes.
-ifconfig does seem to recognize my NIC, but it does not report any traffic whatsoever.

Since I'm relatively new to Linux,so I'm actually without a clue on how to solve my problem. I have
looked up similar problems on different websites and forums, but nothing seems to work.

(PS. I have no problems in connecting to the Internet under SuSE 9.0)


If anyone could help me solve this issue, I would be very gratefull.
Should you require any additional information, please let me know.

I thank you for reading my post.
---------------------------------------------
AMD Athlon XP 2600+
768 MB RAM
Nvidia Geforce MX440
NIC RTL8139 PCI (eth1)
NIC RTL8139 in Mainboard.(eth0)
ECS K7VTA3 5.0 Mainboard
 
Old 03-21-2004, 10:21 AM   #2
dushkinup
Member
 
Registered: Feb 2004
Location: Alpha Quadrant, sol system, earth, asia, Israel.
Distribution: Computer I : Slackware 9.1 ; Computer II : Windows XP
Posts: 144

Rep: Reputation: 15
You mentioned that it works under SuSE 9.0 . That's why it's a software problem.
Get rid of Mandrake. It's not a very friendly distro as it says it is (maybe friendly to itself).

I recommand you stay with SuSE 9.0 for a while and then switch to something more advance when you think you are ready.
 
Old 03-21-2004, 10:23 AM   #3
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 46
Can you post the contents of these three files please.
/etc/sysconfig/network
/etc/sysconfig/network-scripts/ifcfg.eth0
/etc/sysconfig/network-scripts/ifcfg.eth1

If you type modprobe 8139too do you get any errors?
If you type lsmod do you see the 8139too module is loaded?

<edit>These are the correct files.
/etc/sysconfig/network-scripts/ifcfg-eth0
/etc/sysconfig/network-scripts/ifcfg-eth1

Last edited by /bin/bash; 03-21-2004 at 10:27 AM.
 
Old 03-22-2004, 09:28 AM   #4
psikatana
LQ Newbie
 
Registered: Mar 2004
Location: The Netherlands
Distribution: Debian GNU/Linux (Sarge)
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks for adressing to my issue, both of you.
Maybe I will stick to SuSE 9.0, but for now I really want to check-out Mandrake 10.0

As for the following:

-When I type modprobe 8139too I get the same effect as when I press the <enter> key. It doesn't report anything.

-When I type lsmod I get the following things for 8139too:

8139too, used by 0
mii, used by 1, 8139too

------------------------------
/etc/sysconfig/network:

NETWORKING=yes
------------------------------
/etc/sysconfig/network-scripts/ifcfg-eth0:

DEVICE=eth0
BOOTPRO=dhcp
ONBOOT=yes
MII_NOT_SUPPORTED=no
NEEDHOSTNAME=yes
-------------------------------

as for ifcfg-eth1, it is not an existing file. I only have ifcfg-eth0 in my /etc/sysconfig/network-scripts/ directory.
------------------------------------

Thanks!

Last edited by psikatana; 03-22-2004 at 09:30 AM.
 
Old 03-22-2004, 11:51 AM   #5
dushkinup
Member
 
Registered: Feb 2004
Location: Alpha Quadrant, sol system, earth, asia, Israel.
Distribution: Computer I : Slackware 9.1 ; Computer II : Windows XP
Posts: 144

Rep: Reputation: 15
SuSE is a very good start. Stick with it.
 
Old 03-22-2004, 03:18 PM   #6
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 46
OK modprobe is very noisy when it has errors but very quiet when it works, so no output is good.

So now what you need to do is restart the network and type ifconfig and see if you got an IP.

Post the results of these commands:
service network restart
ifconfig
route

Last edited by /bin/bash; 03-22-2004 at 03:19 PM.
 
Old 03-23-2004, 11:57 AM   #7
psikatana
LQ Newbie
 
Registered: Mar 2004
Location: The Netherlands
Distribution: Debian GNU/Linux (Sarge)
Posts: 6

Original Poster
Rep: Reputation: 0
Ok, here you go

<service network restart> gives:

Shutting down loopback interface [OK]
Setting network parameters [OK]
Bringing up loopback interface [OK]
Bringing up interface eth0 [FAILED]
--------------------------------------------------

<ifconfig> then gives:

lo Link encap: local loopback
inet addr: 127.0.0.1 Mask: 255.0.0.0
inet6 addr: ::1/128 Scope: Host
UP LOOPBACK running MTU: 16436 METRIC: 1
RX packets: 206, errors: 0, dropped: 0, overruns: 0, frame: 0
TX packets: 206, errors: 0, dropped: 0, overruns: 0, carrier: 0, collisions: 0, txqueuelen: 0
RX bytes: 15434 (15,0 Kb) TX bytes 15434 (15,0 Kb)
-------------------------------------------------------------------

<route> gives no output
-------------------------------
 
Old 03-23-2004, 04:27 PM   #8
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 46
OK I got a few more questions.

Where are you getting your IP from? Is it a cable modem or DSL router? Do you know the IP of the device your computer connects to? What do the 2 files look like in Suse? Or did you overwrite the suse install? Why do you have 2 NIC cards?

Try adding this line to /etc/sysconfig/network then restart the network and see what happens.
GATEWAYDEV=eth0
 
Old 03-24-2004, 06:04 AM   #9
psikatana
LQ Newbie
 
Registered: Mar 2004
Location: The Netherlands
Distribution: Debian GNU/Linux (Sarge)
Posts: 6

Original Poster
Rep: Reputation: 0
Hi,

I recieve my dynamic IP from a Motorola Cable Modem. I don't know the IP of the device I connect to.

I have 2 NIC's because I used to route internet from my Window$ computer, to another computer. But since I have developed some sort of grudge against the forementioned "OS", I wanted to use an alternative OS.

However, I plan to remove the second NIC, because I'm planning to get an ADSL connection with a Multi-PC modem. As for SuSE, it stopped connecting to the internet, since I put the second NIC in my computer. (I found out yesterday).

The strange thing is however, that even without the second NIC, Mandrake 9.2 and Mandrake 10.0 still failed to initialize eth0.

I will post the output in the network files under SuSE later on this day, as well as the results of adding the line. (I'm not behind my own computer right now.)


Bye!

PS: I always install an OS, after removing all the partitions on my harddisk. (except when I make it a dual-boot system)



Last edited by psikatana; 03-24-2004 at 06:10 AM.
 
Old 03-24-2004, 11:45 AM   #10
psikatana
LQ Newbie
 
Registered: Mar 2004
Location: The Netherlands
Distribution: Debian GNU/Linux (Sarge)
Posts: 6

Original Poster
Rep: Reputation: 0
Talking

Well, I got rid of the connection problem in SuSE.
The second NIC caused some sort of problem, I guess. I removed it and now Internet is working fine again under SuSE. As a matter of fact, I'm viewing this using Konqueror. I also got rid of my USB problem under SuSE, by loading several USB modules before YAST initialized. Sorry...I'm little off-topic.
 
Old 04-18-2004, 01:47 PM   #11
geniarse
Member
 
Registered: May 2003
Location: UK
Distribution: Gentoo
Posts: 141

Rep: Reputation: 15
I'm also having problems with my NIC on boot with mandrake 10, interface initilisation fails on boot but works if enter "ifup eth0" (try that psikatana). But its a pain on every boot.
 
Old 04-18-2004, 01:58 PM   #12
geniarse
Member
 
Registered: May 2003
Location: UK
Distribution: Gentoo
Posts: 141

Rep: Reputation: 15
I've solved it disable network hotplugging on the interface using mandrake control centre => network/internet => manage connections => Options Tab. Not sure which config file it is doesn't seem to appear in eth0 cfg file
 
Old 04-19-2004, 05:37 AM   #13
ch_music
Member
 
Registered: Apr 2004
Location: Singapore
Distribution: Debian Sarge/Sid
Posts: 52

Rep: Reputation: 15
hmm.. with regard to the initial problem, u may try installing pump (another dhcp client).. then try su-ing n type:

# ifconfig lo mtu 1500
# ifconfig eth0 mtu 1500
# pump

if successful, " pump -i eth0 -s " should return ur IP address with some other required information.. Now, you just need to implement them to ur startup script
 
Old 04-19-2004, 06:09 AM   #14
dushkinup
Member
 
Registered: Feb 2004
Location: Alpha Quadrant, sol system, earth, asia, Israel.
Distribution: Computer I : Slackware 9.1 ; Computer II : Windows XP
Posts: 144

Rep: Reputation: 15
It could be a bug in Mandrake (yeah, another one). Try reporting it to them if you don't have to be in the Mandrake Club to do so.

But I still think you'd be better off with SuSE rather than Mandrake.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 and eth1 fail c0c0deuz Linux - Networking 3 06-18-2008 12:35 PM
eth0 fail and no internect connection on mandrake 10.1 Marcoreg Linux - Networking 16 03-22-2005 05:15 PM
mandrake 10.1 no internet connection eth0 fail meezike Linux - Newbie 6 12-29-2004 04:29 PM
lo and eth0 fail on boot dsiguy Linux - Networking 1 03-14-2003 12:35 PM
eth0 initiallisation fail again c0c0deuz Linux - Newbie 1 08-25-2001 12:26 PM


All times are GMT -5. The time now is 03:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration