LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-27-2007, 05:28 AM   #1
noisebleed
Member
 
Registered: Feb 2007
Location: Porto, Portugal
Distribution: Gentoo
Posts: 41

Rep: Reputation: 15
Multicast over PPPoE


Hi.

I made a router based on Gentoo Linux and now I'm trying to do multicast between LAN users.

Each user is connected through pppoe to the router. LAN IP is 10.17.1.1 and LAN addresses are 172.16.3.x.

LAN user1 (myself) issues a multicast stream starting the server this way:
Code:
vlc --intf ncurses -vvv  --sout '#standard{access=udp,url=239.239.239.239:1234,sap=true,name="Test Stream}' --ttl 5 --loop file.wmv
But with pppoe other LAN users can't see the movie i'm streaming. Data seems to get there (watched traffic with wireshark) but nothing happens on vlc.

Then I used a DHCP server instead of PPPoE and it worked! What's may be the problem with PPPoE?

This is a log I got from tcpdump (on the router) while using PPPoE:
Code:
18:13:38.382659 IP 10.17.1.1 > DVMRP.MCAST.NET: igmp dvmrp Probe
18:13:44.891659 PPPoE  [ses 0x28] IP 172.16.3.1 > IGMP.MCAST.NET: igmp v3 report, 1 group record(s)
18:13:48.381141 IP 10.17.1.1 > DVMRP.MCAST.NET: igmp dvmrp Probe
18:13:49.851081 PPPoE  [ses 0x28] IP 172.16.3.1 > IGMP.MCAST.NET: igmp v3 report, 1 group record(s)
18:13:52.706032 PPPoE  [ses 0x29] IP 172.16.3.200 > IGMP.MCAST.NET: igmp v3 report, 1 group record(s)
18:13:57.923705 PPPoE  [ses 0x28] IP 172.16.3.1 > IGMP.MCAST.NET: igmp v3 report, 1 group record(s)
18:13:58.379621 IP 10.17.1.1 > DVMRP.MCAST.NET: igmp dvmrp Probe
18:13:59.913901 PPPoE  [ses 0x28] IP 172.16.3.1 > IGMP.MCAST.NET: igmp v3 report, 1 group record(s)
18:14:01.747991 PPPoE  [ses 0x29] IP 172.16.3.200 > IGMP.MCAST.NET: igmp v3 report, 1 group record(s)
18:14:08.378099 IP 10.17.1.1 > DVMRP.MCAST.NET: igmp dvmrp Probe
18:14:09.038934 PPPoE  [ses 0x28] IP 172.16.3.1 > IGMP.MCAST.NET: igmp v3 report, 1 group record(s)
18:14:12.541926 PPPoE  [ses 0x29] IP 172.16.3.200 > IGMP.MCAST.NET: igmp v3 report, 1 group record(s)
18:14:14.634080 PPPoE  [ses 0x28] IP 172.16.3.1 > IGMP.MCAST.NET: igmp v3 report, 1 group record(s)
18:14:15.476154 PPPoE  [ses 0x28] IP 172.16.3.1 > IGMP.MCAST.NET: igmp v3 report, 1
And this is a log using DHCP:
Code:
18:10:08.398602 IP 10.17.1.1 > DVMRP.MCAST.NET: igmp dvmrp Probe
18:10:18.397117 IP 10.17.1.1 > ALL-SYSTEMS.MCAST.NET: igmp query v2
18:10:18.397163 IP 10.17.1.1 > DVMRP.MCAST.NET: igmp dvmrp Probe
18:10:19.234799 IP 10.17.1.19 > 239.239.239.239: igmp v2 report 239.239.239.239
18:10:19.552902 IP 10.17.1.19 > 224.0.0.251: igmp v2 report 224.0.0.251
18:10:23.201249 IP 10.17.1.1 > DVMRP.MCAST.NET: igmp v2 report DVMRP.MCAST.NET
18:10:25.651875 IP 10.17.1.1 > ALL-ROUTERS.MCAST.NET: igmp v2 report ALL-ROUTERS.MCAST.NET
18:10:27.651654 IP 10.17.1.1 > DVMRP.MCAST.NET: igmp dvmrp Probe
18:10:28.355606 IP 10.17.1.19 > 239.239.239.239: igmp v2 report 239.239.239.239
18:10:31.247038 IP 10.17.1.18 > 239.239.239.239: igmp v2 report 239.239.239.239
18:10:32.888018 IP 10.17.1.18 > 239.239.239.239: igmp v2 report 239.239.239.239
18:10:37.674996 IP 10.17.1.18 > 239.239.239.239: igmp v2 report 239.239.239.239
18:10:37.675135 IP 10.17.1.1 > DVMRP.MCAST.NET: igmp dvmrp Probe
18:10:42.171661 IP 10.17.1.19 > 239.239.239.239: igmp v2 report 239.239.239.239
18:10:47.784640 IP 10.17.1.19 > ALL-ROUTERS.MCAST.NET: igmp leave 239.239.239.239
18:10:47.784726 IP 10.17.1.1 > 239.239.239.239: igmp query v2 [max resp time 10] [gaddr 239.239.239.239]
18:10:47.784796 IP 10.17.1.1 > DVMRP.MCAST.NET: igmp dvmrp Probe
18:10:47.784826 IP 10.17.1.1 > 239.239.239.239: igmp query v2 [max resp time 10] [gaddr 239.239.239.239]
18:10:48.383977 IP 10.17.1.18 > 239.239.239.239: igmp v2 report 239.239.239.239
18:10:55.492142 IP 10.17.1.18 > ALL-ROUTERS.MCAST.NET: igmp leave 239.239.239.239
Suggestions?

Last edited by noisebleed; 03-27-2007 at 05:37 AM.
 
  


Reply

Tags
multicast, pppoe, vlc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pppoe/rp-pppoe on Debian DaveQB Linux - Networking 12 08-20-2007 05:14 PM
PPPOE/xDSL any alternatives for rp-pppoe package.. deepclutch Linux - Software 2 02-04-2006 09:59 PM
pppoe & pppoe-server warning (solved) ggalvan Slackware 0 02-04-2006 05:58 AM
adsl-status can't read pppoe PID file with rp-pppoe program setup Smarvy Linux - Newbie 2 03-13-2004 11:35 PM
Multicast mistkhan Linux - Networking 0 06-12-2001 02:26 PM


All times are GMT -5. The time now is 12:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration