LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-24-2006, 04:53 AM   #1
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Rep: Reputation: 30
How can I connect to the Proxy server at work?


Hi there

I'm running Suse 10.0 (loving it!) on a Compaq presario R3000 laptop and my wireless connection at home works fine. I boot up the laptop, it connects, I'm on the net!
I've recently learnt to turn on the laptop connection using:
/sbin/ifup
if I've had to turn the network off and want to restart it, and all is well.....

However, at work we have a wireless network which I access all the time in Windows. To switch from home to work in Windows I just change mozilla Firefox's settings to 'Proxy server' under preferences>connections and with the correct settings I'm up and running.
I'd like to be able to use Linux to do the same, but changing the settings in Firefox in Linux doesn't work the same way as I'm used to in windows. What am I doing wrong folks, or more likely, what else do I need to know??

Here are some relevent settings:



linux:/home/adrian # /sbin/ifup wlan0
wlan0 device: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
wlan0 configuration: wlan-wlan0
DHCP client is already running on wlan0
linux:/home/adrian # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11g ESSIDff/any Nickname:"linux"
Mode:Managed Frequency:2.462 GHz Access Point: 00:00:00:00:00:00
Bit Rate=54 Mb/s Tx-Power:25 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption key:A1D3-838A-1D Security modepen
Power Managementff
Link Quality:100/100 Signal level:-61 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:1125 Missed beacon:0

sit0 no wireless extensions.




linux:/home/adrian # iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:60:1D:F1:65:AA
ESSID:"WAVELANNET"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.422 GHz (Channel 3)
Quality:0/100 Signal level:-58 dBm Noise level:-256 dBm
Encryption keyff
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Extra:bcn_int=100
Extra:atim=0
(Unknown Wireless Token 0x8C05)
Cell 02 - Address: 00:60:1D:F1:656
ESSID:"WAVELANNET"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.422 GHz (Channel 3)
Quality:0/100 Signal level:-75 dBm Noise level:-256 dBm
Encryption keyff
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Extra:bcn_int=100
Extra:atim=0
(Unknown Wireless Token 0x8C05)
Cell 03 - Address: 00:60:1D:F1:65:BB
ESSID:"WAVELANNET"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.422 GHz (Channel 3)
Quality:0/100 Signal level:-86 dBm Noise level:-256 dBm
Encryption keyff
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Extra:bcn_int=100
Extra:atim=0
(Unknown Wireless Token 0x8C05)
Cell 04 - Address: 00:0F:B5:B3:E1:6B
ESSID:"WAVELANNET"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:0/100 Signal level:-88 dBm Noise level:-256 dBm
Encryption keyff
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Bit Rate:6 Mb/s
Bit Rate:12 Mb/s
Bit Rate:24 Mb/s
Bit Rate:36 Mb/s
Bit Rate:9 Mb/s
Bit Rate:18 Mb/s
Bit Rate:48 Mb/s
Bit Rate:54 Mb/s
Extra:bcn_int=100
Extra:atim=0
(Unknown Wireless Token 0x8C05)


As you can see, Linux finds 'WAVELANNET' - the proxy server but I can't connect to it.

I don't want to have to change all my seetings for home with Yast, so how do I connect?

I'm a relative newbie but am learning my way around...
 
Old 05-24-2006, 05:17 AM   #2
prozac
Member
 
Registered: Oct 2005
Location: Australia
Distribution: slackware 12.1
Posts: 753

Rep: Reputation: 32
your mozilla proxy settings should be enough for you to use a different proxy i do it all the time.
 
Old 05-24-2006, 05:30 AM   #3
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
I hoped so.... but it just says 'proxy server not found'. If I boot my laptop in Windows and use exactly the same settings. it connects straight away!

I'm puzzled.....
 
Old 05-24-2006, 05:44 AM   #4
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
Is my 'port' setting correct? In Windows I specify port 8080 Is this a windows thing or a server thing??
 
Old 05-24-2006, 05:49 AM   #5
prozac
Member
 
Registered: Oct 2005
Location: Australia
Distribution: slackware 12.1
Posts: 753

Rep: Reputation: 32
everything there is related to the server. the IP and PORT is same for any machine. What kind of error does your browser report?
 
Old 05-24-2006, 08:02 AM   #6
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
The message is:

"Firefox is configured to use a Proxy server that can't be found"

With exactly the same settings in windows, it connects, asks me my password and user name and lets me connect.


Interestingly, if I replace server name with the IP address 198. . etc I get a different message:

"Firefox is configured to use a Proxy server that is refusing connections"

????

Last edited by Adrian Baker; 05-24-2006 at 08:05 AM.
 
Old 05-25-2006, 02:53 AM   #7
prozac
Member
 
Registered: Oct 2005
Location: Australia
Distribution: slackware 12.1
Posts: 753

Rep: Reputation: 32
Quote:
"Firefox is configured to use a Proxy server that can't be found"
because your local DNS is not resolving the name

Quote:
"Firefox is configured to use a Proxy server that is refusing connections"
check your firewall first.try some other proxies and see if you get the same problem. there are hosts of free proxies swarming the net.search.
 
Old 05-25-2006, 06:52 AM   #8
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
Thanks for answering

Quote:
Originally Posted by prozac
because your local DNS is not resolving the name
So how do I remedy this? (I am still a relative newbie)


Quote:
Originally Posted by prozac
check your firewall first.try some other proxies and see if you get the same problem. there are hosts of free proxies swarming the net.search.

My firewall is turned off. Regarding other proxies, that isn't really relevant. My employers run a very fast and useful wireless network around the workplace which I use via windows to access the 'net. I want to connect to this wireless network. In windows all I do is change my Firefox settings to 'Manual proxy configuration', with the settings 'wireless2' and port '8080' and Firefox connects, asks me for username and password and I'm up and surfing...

I can't do this with my laptop running Suse. I have little knowledge on all the different protocols regarding networks, but I can't see why Firefox in Linux can't connect, whilst Firefox in Windows can?

As you can see from my iwconfig listing above, my wireless card works and the network 'WAVELANNET' has been found. My wireless card works perfectly at home (I set this up with Yast).

I'd love a solution as this is one of the final steps I need to move almost exclusively from XP over to Linux.
 
Old 05-25-2006, 07:06 AM   #9
prozac
Member
 
Registered: Oct 2005
Location: Australia
Distribution: slackware 12.1
Posts: 753

Rep: Reputation: 32
if there is a /etc/resolv.conf file in suse thats where you enter this
ip hostname
below is an example.
192.168.0.1 hostname.domainname

set the ip to the proxy server ip and the hostname to its FQDN (Fully Qualified Domain Name)

do a netstat -nat whilst you connect thru' firefox to see whats happening. see for any connection thats made to your proxy server at port 8080 and check its state. if you find such, post it here.
 
Old 05-25-2006, 07:16 AM   #10
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
Thanks so much for the quick reply.

I will edit the /etc/resolv.conf file as you say, but please bare with my lack of knowledge here...

I know the ip number 192.168... etc, but I'm not sure what values to use for hostname.domainname

Our network is called 'WAVELANNET' and I use the connection 'wireless2' in Firefox in windows. Are these the values I need? I really don't understand network and proxy protocols at all.... sorry
 
Old 05-25-2006, 07:18 AM   #11
prozac
Member
 
Registered: Oct 2005
Location: Australia
Distribution: slackware 12.1
Posts: 753

Rep: Reputation: 32
Quote:
nterestingly, if I replace server name with the IP address 198. . etc I get a different message:
what were you talking about here?
 
Old 05-25-2006, 07:29 AM   #12
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by prozac
what were you talking about here?
If I go to Firefox's connection settings and type 'wireless2' in the 'HTTP Proxy:' setting then try to visit a web page I get the message: "Firefox is configured to use a Proxy server that can't be found"

whereas if I replace 'wireless2' with 192.168.0.56 I get: "Firefox is configured to use a Proxy server that is refusing connections"

The ip number above is the correct one and the 'wireless2' is also correct.

Here is my netstat -nat print out:



linux:/home/adrian # netstat -nat
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:631 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN
tcp 0 0 :::22 :::* LISTEN
tcp 0 0 ::1:25 :::* LISTEN
linux:/home/adrian #

Incidentally, I have tried to use Konquerer's proxy settings too and if I type in the ip number and then click verify, it changes it to 'wireless2' and says 'verified ok.

Once again, thank you so much for taking an interest.
 
Old 05-25-2006, 12:02 PM   #13
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
As requested - moved to Networking.
 
Old 05-25-2006, 05:24 PM   #14
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
Any ideas anyone?
 
Old 05-27-2006, 12:41 PM   #15
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
I'm still trying to figure this out but I wonder if the fact that the Network at work Uses Windows XP professional is the problem? Can Firefox in Linux work on a windows network? I'm only using the internet connection though, not loging on as part of the network.

Alternatively, can I fiddle with some settings in my about:config file in Firefox to get this to work?
 
  


Reply

Tags
network, proxy, server


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can I connect my linux to internet via ms proxy server ? rangga_k Linux - General 4 05-08-2007 10:14 AM
How to connect to wireless proxy server myfokkinnick@yahoo.i Suse/Novell 1 02-12-2006 04:20 PM
Need help to connect a squid proxy to connect to another squid proxy server bellerophon Linux - Newbie 1 02-07-2006 07:52 AM
Can't Connect To Proxy Server RySk8er30 Linux - Networking 3 06-05-2005 10:07 AM
Connect to Internet Thru Proxy server on Work lan bhangie Mandriva 1 04-07-2004 10:14 AM


All times are GMT -5. The time now is 10:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration