LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-18-2003, 10:47 PM   #1
reichhorn
LQ Newbie
 
Registered: Jan 2003
Location: Tennessee
Distribution: Redhat 8.0
Posts: 16

Rep: Reputation: 0
Unhappy eth0 hangs on startup


I am running Redhat 8.0. I connect to the internet through a hub connected to a separate router via a cable modem.
When the system startsup, the system stalls on "Bringing up Eth0".
To remedy the situation, I go to another computer on my network , connect to the router, and reboot it. The system starts normally afer that.
This is a pain in the butt, and all network traffic to other computers on the network is reset because of this.

I am sure that there is some initialization or startup file that needs to be reconfigured, but I am still learning Linux and I have no idea where to look.

can anyone help me?

Thanks

--ryan
 
Old 06-19-2003, 03:25 AM   #2
Neorio
Member
 
Registered: Jun 2003
Distribution: Debian
Posts: 110

Rep: Reputation: 15
Eth0 usually won't start up unless it has it's own IP address to use (without that, it can't work). When you connect to the router (and I'm assuming here) the router is using DHCP and giving your eth0 an IP address to use.

Hence it won't start up eth0 unless your router is connected to your PC.

The way around it is to assign your PC an IP address by yourself. I think one of the Red Hat Tools will do that for you, or from the prompt you can use the ifconfig tool.

Last edited by Neorio; 06-19-2003 at 03:30 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hangs on Bringing up eth0 JamesT. Linux - Networking 6 07-31-2005 11:52 PM
Porblems with eth0... Hangs on Boot wardialer Mandriva 13 02-02-2005 01:50 AM
FC3 hangs at bringing up interface eth0 Equisilus Fedora 4 11-14-2004 04:29 PM
Suse loading hangs at eth0 jimscafe Linux - Networking 3 08-29-2003 09:27 PM
ip link setup eth0 up hangs thomasb Linux - Networking 0 01-12-2003 08:24 AM


All times are GMT -5. The time now is 06:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration