LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-17-2005, 12:09 PM   #1
jgrady
LQ Newbie
 
Registered: Mar 2005
Location: Alexandria, VA
Distribution: Suse 9.2 & Fedora Core 2
Posts: 2

Rep: Reputation: 0
Post cannot SFTP to SUSE 9.2 box, port 22 open, can putty in though using same port.


OK.

I am am still pretty new to adminstering Linux boxes. I run two local boxes, one running Fedora core 2, and one running SUSE 9.2. I just setup the SUSE 9.2 box to run and server eGroupware on.

My problem is. I cannot get WS_FTP to connect to this box! I have port 22 open, am able to putty into the box, but cannot connect with WS_FTP. I am still becoming familiar with YAST, maybe there is a setting somewhere that I missed. I have not had this issue with Fedora core 2. I have checked all settings in WS_FTP and they seem to be setup correctly. Have also tried making a new user account on the SUSE box to connect with, still can't connect, but again, can with Putty.

This box is now on an internal network with an internal IP assigned to it, am using that IP to try to connect using WS_FTP. The box that is running WS_FTP is a win2k box.

Thanks,

-- Justin
 
Old 03-17-2005, 01:04 PM   #2
Mathijs
Member
 
Registered: Jan 2003
Distribution: Gentoo 2006.1 @ linux 2.6.18-g-r6
Posts: 50

Rep: Reputation: 15
You are very sure of the fact that WS_FTP is running? If you can PUTTY to it, then it isn't a firewall related subject, (since the port is open or you have a veru advanced protocol filter set up) so the only option left is WS_FTP...

Mathijs
 
Old 03-17-2005, 01:11 PM   #3
jgrady
LQ Newbie
 
Registered: Mar 2005
Location: Alexandria, VA
Distribution: Suse 9.2 & Fedora Core 2
Posts: 2

Original Poster
Rep: Reputation: 0
Yes.....am certain WS_FTP is running.

When I try to connect to the SUSE box with WS_FTP it seems like it is trying to connect by then tells me:

"The server rejected your login credentials. Retype your username and password and click OK to retry."

Seems like pretty basic 'duh' stuff, it just does not seem to like my username and password, but how come I can use the same username and password while directly on the box, or through putty? I have tried several times making sure caps lock is off and checking my syntax.
 
Old 03-17-2005, 01:39 PM   #4
Mathijs
Member
 
Registered: Jan 2003
Distribution: Gentoo 2006.1 @ linux 2.6.18-g-r6
Posts: 50

Rep: Reputation: 15
Maybe I know nothing about it, but WS_FTP might need another un-pw?
Some configuration thingy on the WinBox perhaps?
 
Old 03-28-2005, 09:21 PM   #5
casualzen
LQ Newbie
 
Registered: Jan 2004
Posts: 3

Rep: Reputation: 0
Angry Me too... (ws_ftp & suse 9.2 fails)

I've got the exact same issue... Suse 9.2 system trying to access it from an XP Sp2 box on the same LAN segment (heck, only 1 switch port away >grin<)

It works fine via putty, and psftp works fine for file upload/download.. However ws_ftp Pro v9 fails to connect with the exact same error you get.

I'm still looking as to W.T.F. is going on... will post if I find out anything... (also going to go try out some other SFTP clients... maybe they don't have a bug...)

(Oh, yea... sent the following as a bug report to Ipswitch as well...)

==== cut & paste =====
Connecting to 10.10.10.10:22
Connected to 10.10.10.10:22 in 0.000000 seconds, Waiting for Server Response
Server Welcome: SSH-1.99-OpenSSH_3.9p1
Client Version: SSH-2.0-WS_FTP-9.01-2004.08.18
DSS Signature Verified
Session Keys Created
Ciphers Created
New Client->Server ciphers in place.
New Client->Server ciphers in place.
Completed SSH Key Exchange. New Keys in place.
Server has disconnected for reason 2 (SSH_DISCONNECT_PROTOCOL_ERROR)
"Too many authentication failures for root"
Failed SSH User Authentication
SSH Transport closed.
===== end cut & paste ===

Here are the perfectly working Putty & Psftp links to the same box...

====== Begin cut & paste 2 (putty)=====
login as: root
Password:
Last login: Mon Mar 28 13:09:41 2005 from 10.10.10.66
Have a lot of fun...
ns1:~ #
====== End cut & paste 2 =====

====== Begin cut&paste 3 (psftp) ====
psftp: no hostname specified; use "open host.name" to connect
psftp> open 10.10.10.10
login as: root
Using username "root".
Password:
Remote working directory is /root
psftp> ls /var/opt
Listing directory /var/opt
drwxr-xr-x 3 root root 72 Jan 13 11:14 .
drwxr-xr-x 15 root root 384 Jan 13 12:36 ..
drwxr-xr-x 3 root root 72 Jan 13 11:14 gnome
psftp>
======= End 3 =====================

Last edited by casualzen; 03-28-2005 at 09:25 PM.
 
Old 03-29-2005, 09:27 AM   #6
Mathijs
Member
 
Registered: Jan 2003
Distribution: Gentoo 2006.1 @ linux 2.6.18-g-r6
Posts: 50

Rep: Reputation: 15
Maybe, again I'm way of track, but I had issues conecting to XP machines before on LAN-networks. The main reason was protocol issues, we didn't find any solutions though, exept for installing Win2K... (we all had win2K machine...)

Mathijs
 
Old 03-29-2005, 09:44 AM   #7
casualzen
LQ Newbie
 
Registered: Jan 2004
Posts: 3

Rep: Reputation: 0
Oh... is a connection FROM: WinXP (ws_ftp pro 9) --> TO: SuSE Linux 9.2

FWIW: "TurboFTP" works fine as a WinXP SFTP client for that senario. (Looking for another shareware / freeware WinDoze Client still that has the ease of use features [like directory recursion]))

Ahh... the Not So Subtle Joys of a Mixed OS Enviroment. Wheeeee.

(FWIW #2 - SuSE 9.2 install worked perfectly on my company IBM ThinkPad A31p. found everything, even the WiFi and the Bluetooth .. then I had to put back the corporate XP image. Oh well. maybe I'll get it dual booting after I upgrade it to a 100G HD)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to use different port for sftp? cefs99 Linux - Security 5 11-13-2012 10:08 PM
how to make azureus (or any port forwarding) works in my suse 9.3 box and squid proxy efm Linux - Newbie 0 10-31-2005 02:22 AM
SuSE 9.2 - FTP Port open with no FTP service?!?! don_wombat Linux - Security 12 12-01-2004 04:14 PM
VNC with Putty Tunnel port ziggie216 Linux - Software 10 12-02-2003 09:32 PM
firewall.rc.config says :"open port 8080" but nmap says port is closed saavik Linux - Security 2 02-14-2002 01:16 PM


All times are GMT -5. The time now is 06:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration