LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-11-2004, 01:51 AM   #1
Wynand1
Member
 
Registered: Mar 2004
Posts: 121

Rep: Reputation: 15
Arrow Cannot ping self ??? eth0 not active ???


Hi , I'm running Slackware 9.1 and I'm using webmin 1.150 . I found that I cannot ping my ip address (192.168.0.1) or my host name. Then I opened webmin in mozilla and saw that under networking/network configuration/network interfaces that only lo (loopback) was active although Under "interfaces activated at boot time" it says eth0 (Ethernet) and lo (loopback)

This PC isn't connected to a network.

How do I test if my network card works? , Why isn't eth0 active ? How can I fix this problem?

Thanks
 
Old 06-11-2004, 04:39 AM   #2
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 47
can you post the output of

#/sbin/ifconfig -a

#dmesg|grep eth
 
Old 06-29-2006, 12:11 AM   #3
sonajiso
Member
 
Registered: Oct 2003
Posts: 34

Rep: Reputation: 15
Slackware 10.2 uses dhcpcd during boot to resolve network configurations, I don't know if this is the case with 9.1.

The thing with dhcpcd is that if it cannot aquire the configurations from the DHCP server within a time period (if it times out), it will bring the interface down for which it was ran. This is why you do not see eth0 up after boot, given that its not connected to a network.

Why is the loopback device not enough if you are not connected to a network?
Having an extra, essentially useless driver loaded will only waste memory.

But if you must have eth0 up, run:
modprobe <DRIVER_MODULE_FOR_YOUR_CARD> # Usually this step can be skipped
ifconfig eth0 up
ifconfig eth0 inet 10.0.0.1

eth0 now has the IP of 10.0.0.1 and should respond at that address (given that no firewalls running and route was automatically added - usually the case)

To bring eth0 down, run:
ifconfig eth0 down

/etc/rc.d/rc.inet1.conf (in Slackware 10.2 at least) has the boot-time configuration settings for eth0. You may modify it to make the start up script assign a static IP.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
interface eth0 is not (yet?) active jorcas Suse/Novell 1 11-22-2004 06:53 PM
Active Shorewall => Can't ping Mandrake ?? anp66 Mandriva 10 04-15-2004 02:06 PM
nic active, but can't ping beyond loopback pvl Linux - Networking 4 04-01-2004 09:14 AM
eth0 not active on startup rocket84 Linux - Networking 6 07-21-2003 01:09 AM
no www name resolution when eth0 active vance Linux - Networking 8 12-08-2002 05:11 PM


All times are GMT -5. The time now is 01:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration