LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
Search this Thread
Old 07-22-2012, 04:53 AM   #1
kidgrave
LQ Newbie
 
Registered: Dec 2004
Posts: 27

Rep: Reputation: 0
Mint keeps booting into Grub!!! I need help.


Yesturday when I was online on my lap top in which I have Linux Mint 13 installed it froze on me. So what I did was that I unplugged the battery and than restarted the computer. Every time that I keep starting my computer it keeps taking me to a screen that looks like this:

http://oi49.tinypic.com/6ql6bp.jpg

When ever I click on memory test it shows me this screen:
http://oi48.tinypic.com/r9lisj.jpg

I would like to be able to boot normally. I would really appreciate it if someone can help me. thanks.
 
Old 07-22-2012, 05:00 AM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728
Quote:
unplugged the battery
I would not do that---if you need to do a "hard shutdown", just hold the power button down for a few seconds.

In your screen shot, grub is giving you a choice of what to boot. I take it that nothing happens if you just wait. But what is you click on one of the other entries? (or move up/down with the arrow keys and then hit "enter")
 
Old 07-22-2012, 05:06 AM   #3
kidgrave
LQ Newbie
 
Registered: Dec 2004
Posts: 27

Original Poster
Rep: Reputation: 0
Next time I will do a hard shut down. Usually lap tops have a button to press down but mines is one of those that you have to slide a switch to the left. I have tried waiting and nothing happends

The options that I get are:

LinuxMint, with Linux 3.2.0-23-generic
LinuxMint, with Linux 3.2.0-23 generic (recovery mode)
Memory test (memtest86+)
Memory test (memtest86+, serial console 115200)

If I just click on any of the entries i gives me some information in which I do not understand. Is there any menus that I should click or any information from there that I should provide you with?
 
Old 07-22-2012, 05:18 AM   #4
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728
Can you recall if you saw this same screen before your issue started? I'm not familiar with GRUB-2, but in GRUB-1, you'd see a screen like this and then the default would boot after a few seconds. (Also, in grub-1, you could not click on the entries)

If you select the first entry, what exactly do you see?

The easy way out of this may be to boot up from your installation CD and re-install GRUB. Here are some instructions:
http://community.linuxmint.com/tutorial/view/245
 
Old 07-22-2012, 05:27 AM   #5
kidgrave
LQ Newbie
 
Registered: Dec 2004
Posts: 27

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by pixellany View Post
Can you recall if you saw this same screen before your issue started? I'm not familiar with GRUB-2, but in GRUB-1, you'd see a screen like this and then the default would boot after a few seconds. (Also, in grub-1, you could not click on the entries)

If you select the first entry, what exactly do you see?

The easy way out of this may be to boot up from your installation CD and re-install GRUB. Here are some instructions:
http://community.linuxmint.com/tutorial/view/245
I have seen this problem before but only with my previous hard drive. My older hard drive which I just replaced 5 days ago with a new one had bad sectors.

I would like to try re-installing Grub but would you advice to first back up all my files? I have an external hard drive so I am planning on booting from the live CD and backing up my files.

I clicked on the first entry and all I see is a black screen with an underscore _ on the top left of my screen. I click enter and the _ keeps moving to the bottom but nothing else happends.

Last edited by kidgrave; 07-22-2012 at 05:31 AM.
 
Old 07-22-2012, 05:29 AM   #6
kidgrave
LQ Newbie
 
Registered: Dec 2004
Posts: 27

Original Poster
Rep: Reputation: 0
For the live CD do you know what's the password for root? or user name?
 
Old 07-22-2012, 06:16 AM   #7
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728
I'm assuming that you are using the live CD that was used for the original install. Either it has no need for a password---or they tell you somewhere.

The last time I installed Mint or Ubuntu, the LiveCD mode did not require any login or password
 
Old 07-22-2012, 06:22 AM   #8
kidgrave
LQ Newbie
 
Registered: Dec 2004
Posts: 27

Original Poster
Rep: Reputation: 0
Smile

pixellany I just finished trying the tutorial link that you send me and my computer is working perfectly fine now Thank you so much for helping me solve the problem. I really appreciate it
 
Old 07-22-2012, 06:24 AM   #9
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728
You are welcome!!---we like happy endings
 
Old 07-22-2012, 07:11 AM   #10
kidgrave
LQ Newbie
 
Registered: Dec 2004
Posts: 27

Original Poster
Rep: Reputation: 0
I love happy endings and once again thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Booting Linux Mint dmchess Linux - Laptop and Netbook 18 09-17-2011 07:15 AM
GRUB GRUB GRUB.... all over the display while booting with USB. kapsikum Linux - General 5 01-08-2010 04:29 AM
Error 15 booting Linux Mint DaveStott Linux - Newbie 8 03-10-2009 02:22 PM
re installation of grub in Linux mint after installing xp over mint sampad.sarangi General 1 01-15-2008 05:37 PM
Booting my new ubuntu install = "GRUB GRUB GRUB GRUB GRUB" etc. dissolved soul Ubuntu 2 01-13-2007 12:55 PM


All times are GMT -5. The time now is 05:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration