LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 07-19-2010, 12:27 PM   #1
focusbob
LQ Newbie
 
Registered: Feb 2010
Posts: 7

Rep: Reputation: 0
wpa_supplicant not working in CentOS on dell latitude x200


Hi forum,

Just installed CentOS 5.5 on my dell latitude x200 and am trying to configure my wifi. I believe wpa_supplicant was installed by defualt; I also installed a package with a name like "wpa_supplicant gui" from add/remove programs.

I can get on to unsecured wireless networks, but unfortunately, my home network is WPA protected. When I start up CentOS, I get the message "wpa_supplicant failed to initialize". However, when the desktop boots, and I check which services are running, wpa_supplicant is listed as running. When I open networkmanager, there is no option to connect to wireless networks via wpa (wep only)- the wpa networks are listed, I just can't connect to them.

Can anyone help me connect to WPA networks with CentOS? Before you suggest "switch distros" or "CentOS is not ideal for laptops"; I need to learn RHEL, and I am using this installation towards that goal.

Thanks,
Jim
 
Old 07-20-2010, 04:29 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,297

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
Have you run wpa_passphrase? Favourite error & best kept secret.
See the man page. typical example

bash-3.1$ wpa_passphrase my_essid somesillynonsense
network={
ssid="my_essid"
#psk="somesillynonsense"
psk=f5f3f4b79c012c5ae783fec8e793894688a6d2cfb08a1a9ee8e89c69cf34a5ec
}
Put that lot in wpa_supplicant.conf. You see that the passphrase uses your ssid and your psk.
 
Old 07-25-2010, 10:06 AM   #3
focusbob
LQ Newbie
 
Registered: Feb 2010
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks for your reply,

Not sure if I'm doing this correctly, but after following your advice, I ran the command:
wpa_supplicant -Dwext -ieth1 -c/etc/wpa_supplicant/wpa_supplicant.conf

I had been taking the advice of this walkthrough (I've switched to Scientific Linux since my last post):
http://www.ippp.dur.ac.uk/old/Comput...roubleshooting

Anyway, my output was:
(wext) Device eth1 kernel driver name: orinoco_cs.
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 7 value 0x1 - Device eth1 kernel driver name: orinoco_cs.
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Invalid argument
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/eth1' manually if it is not used anymore
Failed to initialize control interface '/var/run/wpa_supplicant'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 7 value 0x0 - Failed to disable WPA in the driver.
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - [root@localhost ~]#

Which is a far cry from what the walkthrough said it should be.

When I run iwconfig:

eth1 IEEE 802.11b ESSID:"LimeHorse-guest" Nickname:"localhost.localdomain"
Mode:Managed Frequency:2.462 GHz Access Point: 68:7F:74:53:E1:E5
Bit Rate:11 Mb/s Sensitivity:1/3
Retry limit:4 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality=33/92 Signal level=-64 dBm Noise level=-97 dBm
Rx invalid nwid:0 Rx invalid crypt:72 Rx invalid frag:78
Tx excessive retries:8 Invalid misc:0 Missed beacon:0

And, I'm able to connect to the internet via unsecured networks (so my driver and everything is working).

Any thoughts?

Thanks,
Jim
 
Old 07-26-2010, 03:14 AM   #4
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,297

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
This line
Quote:
Mode:Managed Frequency:2.462 GHz Access Point: 68:7F:74:53:E1:E5
tells you that you are connected, and that the AP you are connected to has a mac address of 68:7F:74:53:E1:E5. So I would check they are not running first
pgrep dhc
should return nothing.Then if you run dhcpcd or dhclient
dhclient eth1
You should get an ip and a network connection, and start surfing. Scientific linux is a slow RHEL based recompile(Well, I found it slow), so you may have networkmanager playing games in the background, and you have their obtuse and byzantine network rc script relying on data in /etc/sysconfig/. Have fun there. You also have the system-config-network utility, which pretends to know what it is doing.

I would reboot at some point and see how much is actually set up from there.
 
Old 07-27-2010, 07:14 AM   #5
focusbob
LQ Newbie
 
Registered: Feb 2010
Posts: 7

Original Poster
Rep: Reputation: 0
Right, the problem is that I'm connected to an unsecured WAP; my router has a guest mode.

The problem started (before I started messing with wpa_supplicant) when I attempted to connect to my wpa network using network manager, it would spin its wheels for a while then ask for a password. Problem was, there was no option for wpa, only wep. Then I tried messing with wpa_supplicant, and got the message I posted above (where wpa_supplicant replies operation not supported and so on). I also tried uninstalling networkmanager and installing wicd, and that didn't even start.

Could it be my orinoco hardware that is causing the problem/is unsupported for wpa in linux (works fine in windows for wpa)? That seems to be what the wpa_supplicant message is suggesting.

...back to CentOs...

Thanks,
Jim
 
Old 07-28-2010, 03:37 AM   #6
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,297

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
http://www.linuxwireless.org
Find out about the driver there. I have never heard of a driver not being supported by wpa_supplicant.

As for your problem, it is useful to stop the network, before you try to start it. I presume you have the section in /etc/wpa_supplicant/wpa_supplicant.conf that I gave you above. Stop the NetworkManager service, and make sure it doesn't start again, if you want to learn Centos.

So you want to learn RHEL: This can be done from init without ever going to runlevel 5. IIRC, The relevant stuff is /etc/rc.d/init.d/network, /etc/sysconfig/networking, & /etc/sysconfig/network-scripts. There's some little half-assed file, ifcfg-wlan0 or the like for each interface, and configuration stuff goes into a similar file for setting up. It's all explained in some well hidden docs in /usr/share. Go to it!

If you want to test the principle at any time, stop everything - dhclient, network manager, wpa_supplicant. I trust you have man pages installed.
As root, the process is
ifconfig wlan0 up
iwlist wlan0 scan |less # and run a mouse over your chosen access point's mac address
wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dwext && iwconfig wlan0 essid your_essid ap <mac address>
dhclient wlan0

use no <> brackets in the lines above.
 
Old 07-28-2010, 03:53 AM   #7
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Quote:
Originally Posted by business_kid View Post
wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dwext && iwconfig wlan0 essid your_essid ap
dhclient wlan0
Is "iwconfig" really necessary in that line? I think the only things I've ever needed were wpa_supplicant.conf, information from wpa_passphrase, wpa_supplicant itself (similar to the above quote) and then dhcpcd/dhclient -- no iwconfig unless unencrypted/WEP encryption was enough.

Last edited by b0uncer; 07-28-2010 at 04:54 AM.
 
Old 07-29-2010, 03:38 AM   #8
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,297

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
Yes, you need the iwconfig stuff. iwconfig wlan0 ap <your mac address> tells it to associate with that access point.
 
  


Reply

Tags
centos, laptop, wifi, wireless, wpa


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ndiswrapper, wpa_supplicant, and RSN / WPA2 on a Dell Latitude D630 RSKueffner Slackware 8 01-14-2009 02:28 PM
Bluetooth Dell Latitude D600 PCLOS 2008 MiniMe not working AndrzejL Linux - Hardware 0 07-17-2008 05:01 PM
Slackware 11 kernel 2.6.20.6 on Dell Notebook Latitude 120l - ACPI not working jmhal Slackware 11 06-23-2007 10:33 PM
sensors not working on Dell Latitude L400 running kernel 2.6.15 Kuroyume Linux - Laptop and Netbook 1 07-16-2006 02:14 PM
problem install mandrake 10.0 with dell latitude x200 babar67 Mandriva 0 06-15-2004 01:14 AM


All times are GMT -5. The time now is 12:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration