LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 09-04-2005, 02:31 PM   #1
JKoder
Member
 
Registered: Sep 2005
Distribution: Slackware 11
Posts: 61
Blog Entries: 1

Rep: Reputation: 15
Via S3 Unichrome Pro on SuSE 9.3


Hi .
Can anyone help me please with one problem ?
I have a laptop with a Via S3 Unichrome Pro graphic card. So the problem is :
when i try to use the via driver... my screen goes blank and i can only see something on S-Video and thats it. On laptop monitor i cannot see anything.

i will paste here my xorg.conf if any one can help me please i appriciate it
And one more thing ... if #d acceleration will work to it will be great !!
I tryed a lot of things but none o them helped me


so please HELP ME !!!
# /.../
# SaX generated X11 config file
# Created on: 2005-09-04T17:38:19+0300.
#
# Version: 4.8
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [SaX2] (4.8)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[1]"
Option "AccelFactor" "0.04"
Option "BottomEdge" "650"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "2"
Option "CircularScrolling" "1"
Option "Device" "/dev/input/mice"
Option "EdgeMotionMaxSpeed" "15"
Option "EdgeMotionMinSpeed" "15"
Option "Emulate3Buttons" "on"
Option "EmulateMidButtonTime" "75"
Option "FingerHigh" "15"
Option "FingerLow" "14"
Option "HorizScrollDelta" "20"
Option "InputFashion" "Mouse"
Option "LeftEdge" "120"
Option "MaxSpeed" "0.5"
Option "MaxTapMove" "110"
Option "MaxTapTime" "180"
Option "MinSpeed" "0.2"
Option "Name" "ALPS;Touchpad"
Option "Protocol" "auto-dev"
Option "RightEdge" "830"
Option "SHMConfig" "on"
Option "TopEdge" "120"
Option "UpDownScrolling" "1"
Option "Vendor" "Sysp"
Option "VertScrollDelta" "20"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
HorizSync 31-48
Identifier "Monitor[0]"
ModelName "1024X768@60HZ"
Option "DPMS"
VendorName "--> VESA"
VertRefresh 50-60
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1024x768" 62.35 1024 1056 1184 1312 768 772 776 792 -HSync -VSync
EndSection


Section "Device"
BoardName "Framebuffer Graphics"
BusID "1:0:0"
Driver "fbdev"
Identifier "Device[0]"
VendorName "VESA"
EndSection

#Section "Device"
# BoardName "VIA CLE 3122"
# BusID "1:0:0"
# Driver "via"
# Identifier "Device[0]"
# Screen 0
# Option "Rotate" "off"
# VendorName "VIA Technologies, Inc."
#EndSection


Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "default"
EndSubSection
SubSection "Display"
Depth 16
Modes "default"
EndSubSection
SubSection "Display"
Depth 24
Modes "default"
EndSubSection
SubSection "Display"
Depth 32
Modes "default"
EndSubSection
SubSection "Display"
Depth 8
Modes "default"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection
 
Old 04-21-2006, 11:18 AM   #2
djuhl30
Member
 
Registered: Dec 2005
Location: IRAQ (BACK @ FT HOOD NOW)
Distribution: GENTOO now
Posts: 98

Rep: Reputation: 15
Good Luck. I've been googling this for months

Dave
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
3D Acceleration on S3 UniChrome Pro sw67 Linux - Laptop and Netbook 4 01-09-2007 09:11 PM
cant load KDE on Veratec AV3270. via s3g unichrome pro IGP card DragonTool Linux - Laptop and Netbook 2 03-19-2006 02:45 AM
S3 Unichrome Pro problems TravisMo Linux - Newbie 3 07-17-2005 02:40 PM
Duel Boot,XP Pro+Suse 9.1 pro wont work. jonny.k Linux - Laptop and Netbook 6 11-28-2004 07:37 AM
Installing VIA Unichrome Graphics Driver in SUSE 9.1 anupamsr Suse/Novell 1 10-15-2004 09:12 AM


All times are GMT -5. The time now is 03:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration