LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
LinkBack Search this Thread
Old 11-15-2007, 03:42 PM   #1
serafimg
Member
 
Registered: Jan 2006
Distribution: Ubuntu 10.10 64-bit
Posts: 60

Rep: Reputation: 15
ubuntu headphone


Hallo!
My laptop is Fujitsu-Siemens AMILO Pa 2510 with an 64-bit processor.
My operating system is Ubuntu 7.10
My problem is that I can't make my headphones to work. When I boot to windows everything is ok.
 
Old 11-15-2007, 10:02 PM   #2
Kenarkies
Member
 
Registered: Nov 2007
Location: South Australia
Distribution: Ubuntu 11.10
Posts: 77

Rep: Reputation: 23
A major problem with Linux is that new equipment can come with unsupported hardware, and sound and wireless are the top problem areas. If your laptop has a reasonably new sound chip, then it is likely that the ALSA developers have not yet been able to provide support for it. It can take up to 12 months from the time of first appearance of a new sound chip until the distros have support for it. As chip manufacturers normally only support Windows, us Linux users are left in the ***. I have just been through dealing with this problem on a new motherboard. It sounds however that you have sound working but just not with the headphones. In such a case it may be that you need to set suitable options in your /etc/modprobe.conf file.

You need to determine the sound chip being used. This should be somewhere in the output of dmesg. Alternatively run alsamixer and you should see what Linux detected as the sound card. It will also show the various volume controls and settings (gnome volume applet is a nicer looking alternative). You may note simply that headphones have been muted.

Then look for the Alsa documentation to see what options are available for the particular chip you have. Try some of the different options.

With Ubuntu it is actually quite easy to install the latest ALSA drivers which may contain additional support. Ubuntu currently has version 1.0.14 while the latest release is 1.0.15. My sound chip was supported therein. However try to avoid this as it can hose your installation if not done correctly.

Ken
 
Old 11-16-2007, 03:06 PM   #3
serafimg
Member
 
Registered: Jan 2006
Distribution: Ubuntu 10.10 64-bit
Posts: 60

Original Poster
Rep: Reputation: 15
Yes! That's my exact problem. My sound is working perfectly but not with the headphones. Although I plug in the headphones, it continuous playing the sound from the speakers.

The alsamixer command gave me this:
Card: HDA ATI SB
Chip: Realtek ALC883
Item: Headphone [dB gain=0.00, 0.00]

I don't know if this sound chip is a new one. The AlsaMixer shows me that the volume of the headphones are set to 100%.
The file modprode.conf doesn't excist. In the /etc directory there is only a subfolder with this name and specially it is called modprobe.d

How can I update the current version (1.0.14) to the latest release (1.0.15.)??

Thanks for your help!!
 
Old 11-17-2007, 02:27 AM   #4
Kenarkies
Member
 
Registered: Nov 2007
Location: South Australia
Distribution: Ubuntu 11.10
Posts: 77

Rep: Reputation: 23
Quote:
Originally Posted by serafimg View Post
The alsamixer command gave me this:
Card: HDA ATI SB
Chip: Realtek ALC883
Item: Headphone [dB gain=0.00, 0.00]
Great! The information needed should be given in [http://www.mjmwired.net/kernel/Docum...iguration.txt], however this does not mention your chip. It is out of date, so I will talk more about a recent version below. The change log for alsa-1.0.15 [http://www.alsa-project.org/main/ind....0.14_v1.0.15] mentions the chip a number of times, so there is support for it in this latest release.

There is a bug filed under https://bugs.launchpad.net/ubuntu/+s...er/+bug/114053. It appears that a number of people have your problem and have not been able to fix it yet.

Quote:
Originally Posted by serafimg View Post
How can I update the current version (1.0.14) to the latest release (1.0.15.)??

Thanks for your help!!
Given the lack of success shown in the above bug discussion, you may prefer to wait before doing this. However there is quite a bit of support for the ALC883 under alsa-1.0.15. To install it, see the thread:

[http://www.linuxquestions.org/questi...oblem-596862/]

You'll see we had a little trouble initially but eventually got it to work OK, so you should look towards the end of that discussion.

If the problem is not overcome after a reboot, then you can try some options. Without the options statement, Alsa tries to get information from the BIOS, which may not always work properly. In the process of installation you will have untarred the file alsa-driver-1.0.15.tar.bz2. Go to the directory alsa-driver-1.0.15/alsa-kernel/Documentation/ and open the file ALSA-Configuration.txt. Look for the section mentioning the ALC883. You will find all the options listed there, which refer to different configurations for various machines and cards.

The module options file needed under Ubuntu is /etc/modprobe.d/alsa-base (modprobe.conf is a RedHat file, I'm still weaning myself away from Fedora). At the end of this file, try adding:

options snd-hda-intel model=3stack-dig

and reboot. Then see what you get in alsamixer. If it doesn't work, try other options mentioned in above ALSA-configuration.txt.

Ken

Last edited by Kenarkies; 11-17-2007 at 04:03 AM.
 
Old 02-04-2008, 03:35 PM   #5
oreja
LQ Newbie
 
Registered: Feb 2008
Posts: 1

Rep: Reputation: 0
I found solution that works with Amilo Pro (Fujitsu - Siemens).

You have to add 2 lines to your /etc/modprobe.d/alsa-base file

#add this lines
options snd-hda-intel model=3stack enable=yes
options snd-hda-intel model=auto position_fix=1 enable=yes


and restart laptop. I hope it helps.
 
Old 02-15-2008, 04:38 AM   #6
serafimg
Member
 
Registered: Jan 2006
Distribution: Ubuntu 10.10 64-bit
Posts: 60

Original Poster
Rep: Reputation: 15
Oreja thanks for the help. You are close enough. With this two lines I managed to hear sound from headphones. But the problem is still there. The sound is coming from the speakers too. I would like to mute the speakers when I plug-in the headphones and enable them back when I unplug them.

Thanks and sorry for my english level.
 
Old 05-03-2008, 05:39 AM   #7
serafimg
Member
 
Registered: Jan 2006
Distribution: Ubuntu 10.10 64-bit
Posts: 60

Original Poster
Rep: Reputation: 15
I upgraded to Ubuntu 8.04 and now the alsa-base is version 1.0.16.
I added again the lines that oreja gave me but the problem haven't been solved yet.
 
Old 05-04-2008, 12:19 AM   #8
Kenarkies
Member
 
Registered: Nov 2007
Location: South Australia
Distribution: Ubuntu 11.10
Posts: 77

Rep: Reputation: 23
Quote:
Originally Posted by serafimg View Post
I upgraded to Ubuntu 8.04 and now the alsa-base is version 1.0.16.
I added again the lines that oreja gave me but the problem haven't been solved yet.
According to the bug report https://bugs.launchpad.net/ubuntu/+s...er/+bug/114053, the problem hasn't yet been solved. A bit disappointing.
 
Old 08-22-2008, 05:39 PM   #9
beanbox
LQ Newbie
 
Registered: Apr 2006
Posts: 6

Rep: Reputation: 0
Talking Thanks oreja

my sound setup is
Card: HDA VIA VT82xx │Chip: Analog Devices AD1986A │View: [Playback] Capture All │Item: Headphone [dB gain=-21.00, -21.00]

#add this lines
options snd-hda-intel model=3stack enable=yes
options snd-hda-intel model=auto position_fix=1 enable=yes

added alot of sound support to my box.

Thanks again
 
Old 10-12-2008, 07:20 AM   #10
serafimg
Member
 
Registered: Jan 2006
Distribution: Ubuntu 10.10 64-bit
Posts: 60

Original Poster
Rep: Reputation: 15
The problem is still there...
Any solution?
 
Old 10-12-2008, 03:58 PM   #11
pinballwizard66
Member
 
Registered: Oct 2008
Posts: 42

Rep: Reputation: 15
well i've heard that on some machines with linux headphones only work if they are connected before the system boots. try doing that.

Debian Development

Last edited by pinballwizard66; 10-22-2008 at 12:36 PM.
 
Old 05-16-2009, 10:16 AM   #12
serafimg
Member
 
Registered: Jan 2006
Distribution: Ubuntu 10.10 64-bit
Posts: 60

Original Poster
Rep: Reputation: 15
I have upgraded to ubuntu 9.04 and the problem is still there after so many years!

A solution is to add the line:
options snd-hda-intel model=acer

at the end of the file /etc/modprobe.d/alsa-base.conf

This can mute the laptop speakers at all. It's a little bit better but not a clean solution.

Last edited by serafimg; 05-16-2009 at 10:18 AM.
 
Old 06-26-2009, 12:25 PM   #13
ledenjes
LQ Newbie
 
Registered: Jun 2009
Posts: 1

Rep: Reputation: 0
I added the line "options snd-hda-intel model=targa-2ch-dig" to the file "/etc/modprobe.d/alsa-base.conf".

Now, headphones and speakers share the same volume control.
You get a separate separate window called "Switches" (in Dutch: "Schakelaars") in which you can enable/disable the headphones output. Only now, (in my case) the speakers are muted and cannot be unmuted/enabled, anymore.
I don't care about that, because I don't use sound unless I'm watching a movie or listening to a song, which I only intend to do by using the headphones.

My stuff:
Operating System: Ubuntu Jaunty Jackalope 9.04 AMD64
Computer: Fujitsu-Siemens Amilo Pa1510 (AMD64 processor)
Audio device: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller (Realtek ALC883)

p.s.:

- you might wanna have a look at: https://bugs.launchpad.net/ubuntu/+s...2?comments=all
- In my case the following lines did not resolve anything:
options snd-hda-intel model=3stack enable=yes
options snd-hda-intel model=auto position_fix=1 enable=yes
 
Old 10-14-2010, 04:30 AM   #14
serafimg
Member
 
Registered: Jan 2006
Distribution: Ubuntu 10.10 64-bit
Posts: 60

Original Poster
Rep: Reputation: 15
This problem fixed by newer versions of Ubuntu Linux.
 
Old 01-23-2011, 11:49 AM   #15
Rig'dzin Dorje
LQ Newbie
 
Registered: Jan 2011
Posts: 1

Rep: Reputation: 0
ubuntu headphone problem - partially solved

I had this problem (Fujitsu Siemens Amilo laptop, Ubuntu 10.10). SERAFIMG: I wonder if this will help you, as we are each using an Amilo.
Thanks for the reference to ALSAMIXER (I'm on my second Ubuntu distro but I'm still very new).
What I found in ALSAMIXER was that the MASTER and HEADPHONE controls seemed to be the wrong way round. If I reduced the MASTER setting it affected the headphones, whereas the HEADPHONE setting affected the laptop speakers. The laptop hardware Fn keys for audio, and the Ubuntu volume control indicator widget, both move the MASTER control - but it's the headphones that respond.
To use the headphones and cut out the laptop speakers I have to zero the HEADPHONE setting, and if I ever want to use the laptop speakers I have to go back into ALSAMIXER and increase the HEADPHONE setting again.
What I still can't do is insert and withdraw the headphones and have the laptop speakers cut out and in automatically.

Last edited by Rig'dzin Dorje; 01-23-2011 at 11:51 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
speakers and headphone both play together divine18e Ubuntu 13 10-14-2010 04:28 AM
Some issues on my notebook(headphone.....) darkslack Slackware 9 09-22-2007 10:32 AM
amarok and usb headphone siyaco Linux - Hardware 5 01-11-2007 02:21 AM
no sound --headphone Sherulinux Linux - Newbie 7 08-10-2005 03:39 PM
No sound from headphone jack jefferai Linux - Laptop and Netbook 0 08-21-2004 04:05 PM


All times are GMT -5. The time now is 03:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration