LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 02-03-2004, 01:52 PM   #1
lamedavis
Member
 
Registered: Jan 2004
Location: Ashland, Oregon
Distribution: Fedora Core 1 & 2
Posts: 51

Rep: Reputation: 15
text mode in full screen?


Hi I am running fedora core on my laptop. everything is working great. The only question that I have is can I get text mode to run in full screen? right now its about the size of a post card. When I start the x server the screen goes to full. any ideas?

thanks,
Jeremy
 
Old 02-03-2004, 01:58 PM   #2
Pcghost
Senior Member
 
Registered: Feb 2003
Location: The Real Washington
Distribution: Ubuntu, Debian, SuSE, UnSlung, Android
Posts: 1,819

Rep: Reputation: 46
If you want the command line to encompas the entire screen press

Ctrl-Alt-F2

This changes your run-level to the command line. Press

Ctrl-Alt-F7

To return to the X-server.
 
Old 02-03-2004, 03:22 PM   #3
lamedavis
Member
 
Registered: Jan 2004
Location: Ashland, Oregon
Distribution: Fedora Core 1 & 2
Posts: 51

Original Poster
Rep: Reputation: 15
If I do that the command line in text mode is still only fills a post card sized screen, when I startx it fills the screen....I dont spend alot of time in windows so having text mode in full screen would be helpful......does it have something to do with video card drivers? do they not load until I startx?
 
Old 02-04-2004, 11:18 AM   #4
lamedavis
Member
 
Registered: Jan 2004
Location: Ashland, Oregon
Distribution: Fedora Core 1 & 2
Posts: 51

Original Poster
Rep: Reputation: 15
anyone else have any ideas?
 
Old 02-04-2004, 11:44 AM   #5
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,077

Rep: Reputation: 368Reputation: 368Reputation: 368Reputation: 368
sure there's a way. you have to compile framebuffer support into your kernel then add
'vga=XXX' to the end of your /etc/lilo.conf where XXX is the vga mode i use 791 for 1024x768 16bit depth but i'm not sure what the other modes are.
 
Old 02-04-2004, 12:05 PM   #6
lamedavis
Member
 
Registered: Jan 2004
Location: Ashland, Oregon
Distribution: Fedora Core 1 & 2
Posts: 51

Original Poster
Rep: Reputation: 15
how do I go about compiling frambuffer support into the kernel? im using fedora core, also I use grub as my boot loader

 
Old 02-04-2004, 05:56 PM   #7
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,077

Rep: Reputation: 368Reputation: 368Reputation: 368Reputation: 368
well, look in /usr/src and if there is a directory (linux-X.XX ) then you have the kernel source installed, otherwise look on your install cds, or better yet http://www.kernel.org and make sure you have the kernel source... assuming you get from www.kernel.org, unpack the archive with a tar -xjf kernel-x.x.xx.tar.bz1 (currently 2.4.24 is my reccomendation) switch to the directory linux-2.4.xx and at the prompt (as root) 'make menuconfig' , or if you prefer, make xconfig (in X of course), go through ALL and i mean all the options to make sure you select what is needed for your machine, you may have to refer to the internet, the docs that came with your machine if you still have them, etc... hint... the 'lspci' command helps alot as well as it lists what devices are attached to your pci bus... as for the frame buffer, make sure you have the 'prompt for development and/or incomplte code/drivers' under 'code maturity level options' set to yes, the under 'console drivers' > 'frame buffer support enable the following:
support for framebuffer devices (experimental), or you won't see any of the following options

vesa vga graphics console
vga 16-color graphics console
*any lines that apply to your video card*
advanced low level driver options
*all the bpp packed pixels support lines*
vga 16-color planar support
support only 8 pixels wide fonts
select compiled-in fonts
vga 8x8 font
vga 8x16 font
the rest is up to you and what you need, i cannot stress enough the need for thouroughess in going through all the options and making sure you have what you need checked... leving unessescary stuff checked will only waste space, but nessescary stuff left unchecked will hamper the performance of the machine, that said good luck
 
Old 02-04-2004, 06:08 PM   #8
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,077

Rep: Reputation: 368Reputation: 368Reputation: 368Reputation: 368
oops, almost forgot, after you are finished, run
'make dep clean bzImage modules'
followed by make install modules_install
then mkinitrd /boot/initrd-2.4.24.img 2.4.24
unless you are doing a 2.6.xx install, which i don't reccomend for a noob and don't know how to do yet...
as for the grub bootloader, if you added a new kenrel version (i would reccomend getting 2.4.24, the you will have to add an entry for the new kenrel, duplicate everything underneth the 'splashimage=' line, but not including that line with the new version appending 'vga=791' after the initrd /initrd-2.4.24.img
 
Old 02-04-2004, 06:23 PM   #9
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
On my HP laptop, I updated the bios. A 1/4 sized screen would be displayed during the install program for example. After updating the bios, I hadn't seen the probem again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox in full screen mode mikedeatworld Linux - Software 2 03-31-2009 11:01 AM
full screen mode aRm1983 Linux - Software 1 10-24-2005 04:31 PM
cannot enter full screen mode in vmware maenho Linux - Software 0 01-07-2005 03:50 AM
Full screen text? Wynd Linux - General 2 06-15-2003 01:47 AM
help!!!! how to exit full screen mode in xine littlecap Linux - Software 7 03-10-2003 07:54 AM


All times are GMT -5. The time now is 08:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration