LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 08-08-2006, 06:32 AM   #1
tim_programer
LQ Newbie
 
Registered: Aug 2006
Location: Poole, UK
Posts: 3

Rep: Reputation: 0
Unhappy Soundcard output set to headphones upon boot rather than laptop speakers


Hi Everyone

my problem is this.

ive just dug out my old laptop (older compaq evo n600c)and turned it into a nice little ubuntu box. ive pretty much ironed out all my issues but one bugs me quite a lot...i know exactly what is wrong, but not how to fix it.
the onboard soundcard (ess allegro ess1988) works fine but has issues outputting sound (everything is playing etc just no sound). i discovered if i plugged in headphones they would have sound output and then unplugging them would switch the sound to the laptop speakers...so the problem seems to be that the soundcard is defaulting to the headphone output state upon boot. now i have looked in alsa mixer for any switches (nothing there made a difference) and i dont particularly want to have to keep plugging and unplugging headphones.

my question is: is there a config file i can edit to change the default output state or is there something in /proc i can echo a value to fix this and then just pop it in a boot script?

any and all input is much appreciated guys

Tim
 
Old 08-09-2006, 05:02 PM   #2
chrisortiz
Member
 
Registered: Nov 2005
Distribution: Slackware, and of course the super delux uber knoppix universal live recovery cd
Posts: 429

Rep: Reputation: 30
try running "alsaconf", then "alsactl store"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Laptop speakers off when plug in headphones garyozzy Linux - Hardware 8 02-04-2006 02:44 PM
USB headphones / Speakers ShuttleAU Linux - Hardware 1 04-18-2005 01:48 AM
No sound to headphones - Slack 10, Santa Cruz soundcard booyabazooka Linux - Hardware 1 06-27-2004 03:10 AM
Can get sound from laptop speakers but not from headphones thetremorchrist Linux - Hardware 4 02-14-2004 03:43 AM
soundcard with 4 speakers zeky Linux - General 0 10-27-2002 12:57 PM


All times are GMT -5. The time now is 04:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration