LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 03-27-2012, 01:24 PM   #1
funky_uncle
LQ Newbie
 
Registered: Mar 2012
Posts: 3

Rep: Reputation: Disabled
No backlight with the latest distros, Asus Eee and HP G72


I've been running Kubuntu 10 and Mint 11 on my laptops (an Asus Eee 900 and an HP G72), and it mostly works (save the battery monitor, suspend/resume, fn keys and the usual annoyances). With some distros I have no backlight during the installation, but it works after that. But not with the latest distros, like OpenSUSE, Mint 12, Kubuntu etc. I guess they've got a newer kernel and that something is changed there for some reason. I get no backlight at all on any of the laptops, and I'm dying to check out Mint with Cinnamon. Is there anything I can do?
 
Old 03-29-2012, 02:00 PM   #2
Z0K4
Member
 
Registered: Sep 2011
Location: Split, Croatia
Distribution: Slackware, Fedora
Posts: 86

Rep: Reputation: 4
Have you tried to add acpi_osi=Linux as a kernel parameter and use fn keys to change brightness?
You probably have Intel's integrated graphics, wright?
 
Old 03-29-2012, 02:42 PM   #3
rokytnji
Senior Member
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 13 , MacPup,Linux-Lite 2.0, SaliX
Posts: 2,718
Blog Entries: 18

Rep: Reputation: 870Reputation: 870Reputation: 870Reputation: 870Reputation: 870Reputation: 870Reputation: 870
Don't know about the HP.

http://community.linuxmint.com/hardware/view/3933

http://community.linuxmint.com/software/view/eee-applet

http://musante.i.ph/blogs/musante/20...lation-issues/

I can't really help you as I run AntiX 11 on mine. My mic fix also.
 
Old 04-04-2012, 03:57 PM   #4
funky_uncle
LQ Newbie
 
Registered: Mar 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Z0K4 View Post
Have you tried to add acpi_osi=Linux as a kernel parameter and use fn keys to change brightness?
You probably have Intel's integrated graphics, wright?
I'd love to try that if I knew how. I can press TAB or something in the grub menu, do I just type "acpi_osi" there?
I think it's Intel graphics on both PCs.
 
Old 04-05-2012, 01:46 AM   #5
Z0K4
Member
 
Registered: Sep 2011
Location: Split, Croatia
Distribution: Slackware, Fedora
Posts: 86

Rep: Reputation: 4
Start your system and wait for the GRUB menu to show. Now highlight the kernel you want to use, and press the 'c' key. You should be able to see and edit the commands associated with the highlighted kernel. Go down to the line starting with linux and add your parameter acpi_osi=Linux to its end. Now press Ctrl + x to boot. When your screen goes black again press fn keys for changing the brightness (try both of them, increasing and decreasing brightness, multiple times). If that worked this is how you permanently add that parameter to the kernel so you don't need to go trough the same procedure every time you boot:
Go to terminal and run this:
Code:
sudo nano /etc/default/grub
Find the line starting with GRUB_CMDLINE_LINUX_DEFAULT and append acpi_osi=Linux to its end. For example:
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"
To save the file press 'Ctrl+X' and then 'y'. Now, in order to changes take effect you need to update grub:
Code:
sudo update-grub
That is it. Enjoy it!
Good luck.
 
Old 04-05-2012, 07:34 AM   #6
funky_uncle
LQ Newbie
 
Registered: Mar 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
Trying it on the HP G72.
Pressing 'c' gave me a command line, pressing 'e' brought up a list of commands, I assume that's what you meant. Anyway, the parameter you suggested didn't make a difference. But I found another suggestion (http://blogs.pcworld.co.nz/pcworld/t...ing_the_b.html) and I added "acpi_backlight=vendor" at the end as well, and that worked

The fn keys still don't work but I can adjust brightness and volume manually.

I'll try the same fix on the Eee, with a live USB stick. Fn keys work there in Mint 11, I guess they'll work in Mint 12 too. I think Asus in general plays better with Linux than HP.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My asus Eee PC 4G bradrussellrees Linux - Laptop and Netbook 2 03-11-2011 04:12 AM
Asus eee 4g BrianOlson Linux - Newbie 1 11-08-2010 12:18 AM
Asus EEE PC 900 the regular distro vs an eee distro dv502 Linux - General 8 07-28-2008 10:32 AM
LXer: New Asus Eee PC 901 with Atom due late June, but where is the Eee 1000H? LXer Syndicated Linux News 0 06-20-2008 04:20 AM
Asus Eee reactiv8 Linux - Newbie 3 03-17-2008 06:59 PM


All times are GMT -5. The time now is 12:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration