LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 10-08-2005, 06:26 AM   #1
glittle
LQ Newbie
 
Registered: Oct 2005
Posts: 1

Rep: Reputation: 0
Microphone not working


Hi,

I have just got a new Fujitsu Siemens Amilo M 3438G.

I have managed to install Suse 10.0 (dual boot with WindowsXP) on it with most things now working. However I cannot get either of the microphones to work (built in or external mic through the input jack). Sound output works fine but just not the mic inputs. This is really annoying as I use VoIP a lot and without it I will end up having to switch back to Windows (not what I want). By the way the mic works fine on Windows XP.

Spec of my machine is:
Pentium M 760 2Ghz
RAM: 2Gb
Sound card: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)

Here is the output from lspci:
linux:~ # lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 04)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root Port (rev 04)
00:1b.0 Class 0403: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 04)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 04)
01:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG (rev 05)
01:04.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
01:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
01:07.0 RAID bus controller: VIA Technologies, Inc. VT6421 IDE RAID Controller (rev 50)
03:00.0 VGA compatible controller: nVidia Corporation NV41.8 [GeForce Go 6800] (rev a2)

And from lsmod
linux:~ # lsmod | grep snd
snd_pcm_oss 59168 0
snd_mixer_oss 18944 2 snd_pcm_oss
snd_hda_intel 17792 2
snd_hda_codec 87552 1 snd_hda_intel
snd_pcm 93064 3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer 24452 1 snd_pcm
snd_page_alloc 10632 2 snd_hda_intel,snd_pcm
snd 60420 8 snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
soundcore 9184 2 snd


I have also adjusted the volumes (both input and output) as well as changing the input sources all to no avail.

I have tried using the drivers that come with Suse Linux 10.0 as well as downloading those from Realtek (for the ALC880(D)) all produce the sam result.

Does anybody have any ideas as to what the problem may be?

Thanks in advance.

Grant
 
Old 10-16-2005, 04:44 AM   #2
CWizard
Member
 
Registered: Dec 2004
Location: Sweden
Distribution: Slackware
Posts: 30

Rep: Reputation: 15
Re: Microphone not working

Quote:
Originally posted by glittle
Does anybody have any ideas as to what the problem may be?
Sorry, no. I think I'm having the same problem. The box is an Dell Dimension 5100 with integrated Intel High Definition Audio, similar to yours. I have no problem with playback, but I cannot get the microphone to work.

One thing that worries me a bit, is this bit from amixer:
Code:
Simple mixer control 'Input Source',0
  Capabilities:
  Mono:
However, in alsamixer I can toggle Input source as "Mic", "Front Mic" or "Line", but the bit above doesn't change.
 
Old 12-31-2007, 05:48 AM   #3
Werdel
LQ Newbie
 
Registered: Dec 2006
Location: Budapest, Hungary
Distribution: UHU-Linux (a hungarian distribution)
Posts: 3

Rep: Reputation: 0
Hi,

have any of you found the solution since then? I have the same promblem with a Fujitsu Amilo 1450G.

Werdel
 
Old 01-02-2008, 01:34 PM   #4
roshaph
LQ Newbie
 
Registered: Jul 2003
Distribution: Slackware
Posts: 11

Rep: Reputation: 0
I have the exact same problem, I run slackware12 on HP 530, Microphone works fine in Windows.
 
Old 01-05-2008, 11:14 AM   #5
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Rep: Reputation: 89
Same problem here... Running Slackware 12 on an ASUS P5V800 board.
Soundcard is on-board, AD1986A.

Sound works fine, only problem is the microphone.
Tried arecord / aplay and it just records noise...

Any help?
 
Old 03-05-2008, 01:57 PM   #6
roshaph
LQ Newbie
 
Registered: Jul 2003
Distribution: Slackware
Posts: 11

Rep: Reputation: 0
Issue resolved for HP 530

Apparantly the ALSA developers fixed the problem in the latest driver's snapshot. You can download it from here:
ftp://ftp.suse.com/pub/projects/alsa/snapshot/driver/
The issue is fixed for the HP 530 model for sure, because that's what I use and it works like a charm. I hope it works on other machines too. Here's the steps I followed in order to compile it:
Code:
./configure --with-debug=detect
make
make install
alsasound stop
alsasound start
One more thing, if you use HP 530, when you configure the mixer settings (kmix or whatever), choose the Int Mic instead of Ext Mic. That's the only way it works on my machine despite the fact that it has no internal microphone, only an input jack for an external one.
 
Old 01-07-2009, 09:28 AM   #7
tiedyedsoul
LQ Newbie
 
Registered: Jul 2008
Posts: 3

Rep: Reputation: 0
Did the Above post help?

Hey all, I know this is an old thread, but as I am having the same problem, I was wondering if the above post's alsa snapshot fixed the problem...

I'm gonna try it at home, anyway, but curiosity got the better of me...
^_^

-TDS

//Edit --

I tried the latest version of the above snapshot as soon as I got home, and found no change in my problem...

As above, the main problem I'm having is being unable to input any sound to the system, while the sound output works fine, both with the integrated speakers and the line out connections.

There is an integrated microphone, and I have a dynamic microphone with a 1/4" jack, with a 1/4" to 1/8" converter. I've also borrowed a standard computer microphone from a friend, in case the dynamic microphone isn't working, but i think it is a driver issue.

I'm running Slackware 12.2 on a Dell XPS M1530, with what I believe is an Intel HDA Integrated Soundcard. I mostly use the CLI, but when I do use a GUI I use KDE 4. The outputs for lspci, lsusb, and amixer are below. Any Help would be much appreciated! =)

Code:
root@Aeris:/home/chris/Pkgs/alsa-driver# lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8400M GS (rev a1)
03:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
03:09.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
03:09.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
03:09.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)
09:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller (rev 12)
0b:00.0 Network controller: Broadcom Corporation BCM4310 USB Controller (rev 01)


root@Aeris:/home/chris/Pkgs/alsa-driver# lsusb
Bus 002 Device 001: ID 0000:0000
Bus 007 Device 005: ID 0a5c:4503 Broadcom Corp.
Bus 007 Device 004: ID 0a5c:4502 Broadcom Corp.
Bus 007 Device 003: ID 413c:8126 Dell Computer Corp. Wireless 355 Bluetooth
Bus 007 Device 002: ID 0a5c:4500 Broadcom Corp.
Bus 007 Device 001: ID 0000:0000
Bus 006 Device 004: ID 046d:c00c Logitech, Inc. Optical Wheel Mouse
Bus 006 Device 001: ID 0000:0000
Bus 005 Device 001: ID 0000:0000
Bus 001 Device 002: ID 05a9:2640 OmniVision Technologies, Inc.
Bus 001 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 002: ID 0483:2016 SGS Thomson Microelectronics Fingerprint Reader
Bus 003 Device 001: ID 0000:0000


root@Aeris:/home/chris/Pkgs/alsa-driver# amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Mono:
  Front Left: Playback 111 [87%] [-12.00dB] [on]
  Front Right: Playback 111 [87%] [-12.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Mono:
  Front Left: Playback 111 [87%] [-12.00dB] [on]
  Front Right: Playback 111 [87%] [-12.00dB] [on]
Simple mixer control 'Mic as Output',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 14
  Front Left: Capture 0 [0%] [0.00dB] [off]
  Front Right: Capture 0 [0%] [0.00dB] [off]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 14
  Front Left: Capture 0 [0%] [0.00dB] [off]
  Front Right: Capture 0 [0%] [0.00dB] [off]
Simple mixer control 'Capture',2
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 14
  Front Left: Capture 0 [0%] [0.00dB] [off]
  Front Right: Capture 0 [0%] [0.00dB] [off]
Simple mixer control 'Analog Loopback',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Digital',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 60 [50%] [0.00dB]
  Front Right: Capture 60 [50%] [0.00dB]
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Front Mic'
  Item0: 'Front Mic'
Simple mixer control 'Input Source',1
  Capabilities: cenum
  Items: 'Front Mic'
  Item0: 'Front Mic'
Simple mixer control 'Input Source',2
  Capabilities: cenum
  Items: 'Front Mic'
  Item0: 'Front Mic'
Simple mixer control 'Mux',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 4
  Front Left: Capture 0 [0%] [0.00dB]
  Front Right: Capture 0 [0%] [0.00dB]
Simple mixer control 'Mux',1
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 4
  Front Left: Capture 0 [0%] [0.00dB]
  Front Right: Capture 0 [0%] [0.00dB]
Simple mixer control 'Mux',2
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 4
  Front Left: Capture 0 [0%] [0.00dB]
  Front Right: Capture 0 [0%] [0.00dB]
root@Aeris:/home/chris/Pkgs/alsa-driver#

Last edited by tiedyedsoul; 01-07-2009 at 05:03 PM.
 
Old 03-26-2012, 07:30 PM   #8
jmlm_1970
Member
 
Registered: Nov 2010
Location: Aveiro, Portugal, Europe
Posts: 38
Blog Entries: 1

Rep: Reputation: 1
How to make microphone work!

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Microphone not working arnott Linux - Hardware 3 12-01-2005 04:22 PM
Microphone Not Working RySk8er30 Mandriva 0 11-12-2005 12:16 PM
Microphone not working with oss linuxmandrake Linux - Hardware 0 11-08-2005 11:06 AM
Microphone Not Working in 10.1 Community? mac57 Mandriva 1 01-01-2005 11:38 AM
microphone not working Abrocadabro Debian 1 12-03-2004 12:37 AM


All times are GMT -5. The time now is 09:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration