LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 03-29-2004, 08:27 AM   #1
jimbo
LQ Newbie
 
Registered: Feb 2004
Distribution: RH9
Posts: 10

Rep: Reputation: 0
How to disable touchpad?


Hi,

I have RH9 on a Compaq Presario 1245. No problems, however I would like to be able to turn the touch pad off. I brush my palm on it when typing and cause myself problems. Plugging in a PS/2 mouse doesn't disable the touch pad. I ran lsmod and found the module that seemed appropriate but wasn't allowed to kill it. Any ideas?
 
Old 03-29-2004, 08:39 AM   #2
Ice9
Member
 
Registered: Jun 2002
Location: Belgium
Distribution: Sidux
Posts: 313

Rep: Reputation: 30
You should be able to disable it in your BIOS.
 
Old 03-29-2004, 08:15 PM   #3
jimbo
LQ Newbie
 
Registered: Feb 2004
Distribution: RH9
Posts: 10

Original Poster
Rep: Reputation: 0
OK, thanks,
 
Old 04-04-2004, 09:06 AM   #4
alveric
LQ Newbie
 
Registered: Apr 2004
Posts: 15

Rep: Reputation: 0
de-activating touchpad

You don't need to go tweak the machine's bios, if you only want the touchpad deactivated under X window. I've had the same problem, and solved it by using several X config files:
- one which activates only my usb mouse
- one with touchpad only
- one with both mice

Go in you X configuration directory (it should be /etc/X11), copy the main file (should be named "XF86Config") in, say, "XF86Config-nopad", and edit the copy. There should be a section named "Pointer" referring to the touchpad, and another to the external PS/2 mouse. Just delete the lines corresponding to the touchpad.

When this is done, test the new file. Close X (if not already done), then launch it via this command on the shell prompt:
# startx -- -xf86config XF86Config-nopad

If everything works well, the touchpad now does nothing. To activate it back, you have to close X, and launch it with the default config file, this way:
# startx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to disable touchpad? simanyay Suse/Novell 12 06-26-2007 04:42 AM
disable touchpad in kde? kahn Linux - Hardware 1 05-29-2005 08:21 PM
disable touchpad MicahCarrick Linux - Laptop and Netbook 0 07-18-2004 07:23 PM
disable synaptic touchpad ljpete Linux - Newbie 1 01-31-2004 05:42 AM
disable synaptic touchpad ljpete Linux - Distributions 0 01-30-2004 09:59 PM


All times are GMT -5. The time now is 07:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration