LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   How to disable touchpad? (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/how-to-disable-touchpad-163718/)

jimbo 03-29-2004 08:27 AM

How to disable touchpad?
 
Hi,

I have RH9 on a Compaq Presario 1245. No problems, however I would like to be able to turn the touch pad off. I brush my palm on it when typing and cause myself problems. Plugging in a PS/2 mouse doesn't disable the touch pad. I ran lsmod and found the module that seemed appropriate but wasn't allowed to kill it. Any ideas?

Ice9 03-29-2004 08:39 AM

You should be able to disable it in your BIOS.

jimbo 03-29-2004 08:15 PM

OK, thanks,

alveric 04-04-2004 09:06 AM

de-activating touchpad
 
You don't need to go tweak the machine's bios, if you only want the touchpad deactivated under X window. I've had the same problem, and solved it by using several X config files:
- one which activates only my usb mouse
- one with touchpad only
- one with both mice

Go in you X configuration directory (it should be /etc/X11), copy the main file (should be named "XF86Config") in, say, "XF86Config-nopad", and edit the copy. There should be a section named "Pointer" referring to the touchpad, and another to the external PS/2 mouse. Just delete the lines corresponding to the touchpad.

When this is done, test the new file. Close X (if not already done), then launch it via this command on the shell prompt:
# startx -- -xf86config XF86Config-nopad

If everything works well, the touchpad now does nothing. To activate it back, you have to close X, and launch it with the default config file, this way:
# startx


All times are GMT -5. The time now is 06:52 PM.