LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 03-14-2005, 10:54 AM   #1
jgibz
LQ Newbie
 
Registered: Aug 2003
Distribution: FC3
Posts: 26

Rep: Reputation: 15
ATI Radeon Mobility 7500 drivers?


Hi everyone,
I've been looking around for drivers for my Mobility 7500, and I can't find much of anything. ATI's site tells you to contact your manufacturer, and I'm in the process of doing that.

Does anyone know where I can find drivers for this card?


Code:
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.1)
OpenGL extensions:
 
----------------------------------------------------------------------
0x23 16 tc  0 16  0 r  .  .  5  6  5  0  0 16  0  0  0  0  0  1 0 None
0x24 16 tc  0 16  0 r  .  .  5  6  5  0  0 16  8  0  0  0  0  1 0 Slow
0x25 16 tc  0 16  0 r  .  .  5  6  5  0  0 16  0 16 16 16  0  1 0 Slow
0x26 16 tc  0 16  0 r  .  .  5  6  5  0  0 16  8 16 16 16  0  1 0 Slow
0x27 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  0  0  0  0  0  1 0 None
0x28 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  8  0  0  0  0  1 0 Slow
0x29 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  0 16 16 16  0  1 0 Slow
0x2a 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  8 16 16 16  0  1 0 Slow
0x2b 16 dc  0 16  0 r  .  .  5  6  5  0  0 16  0  0  0  0  0  1 0 None
0x2c 16 dc  0 16  0 r  .  .  5  6  5  0  0 16  8  0  0  0  0  1 0 Slow
0x2d 16 dc  0 16  0 r  .  .  5  6  5  0  0 16  0 16 16 16  0  1 0 Slow
0x2e 16 dc  0 16  0 r  .  .  5  6  5  0  0 16  8 16 16 16  0  1 0 Slow
0x2f 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  0  0  0  0  0  1 0 None
0x30 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  8  0  0  0  0  1 0 Slow
0x31 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  0 16 16 16  0  1 0 Slow
0x32 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  8 16 16 16  0  1 0 Slow
 
Old 03-14-2005, 02:21 PM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Is this a IGP 320 chip? I have tried for years to get 3D running on my ATI Mobility U1 card, but never succeeded. But 2D support is quite OK with the built-in radeon driver of XFree86 or XOrg. Also vesafb works fine.
 
Old 03-14-2005, 08:58 PM   #3
jgibz
LQ Newbie
 
Registered: Aug 2003
Distribution: FC3
Posts: 26

Original Poster
Rep: Reputation: 15
The chip set is RV200 I believe.
 
Old 03-15-2005, 10:15 AM   #4
Hal
Member
 
Registered: Oct 2003
Location: East Anglia, England
Distribution: Dapper Drake / Slackware
Posts: 151

Rep: Reputation: 30
Hmm, coincidental. I have a Mobility Radeon 7500 card in my new Thinkpad. I'll be watching this thread closely, if I get anywhere I'll post up.

Another coincidence:
http://www.linuxquestions.org/questi...35#post1479535
 
Old 03-15-2005, 12:54 PM   #5
jgibz
LQ Newbie
 
Registered: Aug 2003
Distribution: FC3
Posts: 26

Original Poster
Rep: Reputation: 15
"Regarding the incident for your system, we´re not currently supporting the Linux operating system, and there´s no driver download available for the ATI mobility RADEON 7500 at the moment."

Email I got back from Alienware
 
Old 05-06-2005, 11:32 AM   #6
shadowblade4288
LQ Newbie
 
Registered: May 2005
Location: Ma.
Distribution: Linux fedora core 3
Posts: 2

Rep: Reputation: 0
re

Well I haven't figured out how yet but maybe we can help each other I'm having the same problem.

the Knoppix live CD seems to load the ATI Radeon 7500 drivers so theres got to be something out there
to get it to work I'm still researching if I come up any thing I'll let you know and if you have any info it would really
help if you could let me know
 
Old 05-07-2005, 09:02 AM   #7
jgibz
LQ Newbie
 
Registered: Aug 2003
Distribution: FC3
Posts: 26

Original Poster
Rep: Reputation: 15
I haven't found much since the thread began, but I'll be sure to post if I find anyhting.
 
Old 02-19-2007, 02:03 PM   #8
mmatt
Member
 
Registered: Nov 2005
Location: UK
Distribution: archlinux
Posts: 90

Rep: Reputation: 19
Did you find anything?

I know this thread is stagnant, but did you solve the problem? I also have a mobility 7500 M7, on openSuSE 10.2. I never got 3d to work in 10.0 and was hoping that by now someone would have solved this issue. I've got beryl working on this slowly failing Dell 5100, but FPS in many apps is atrocious! Just wondered whether someone found a driver in the end...
 
Old 03-02-2007, 02:55 AM   #9
ultimatenoob
Member
 
Registered: May 2005
Location: Bellingham, WA
Distribution: Suse 10.2
Posts: 77

Rep: Reputation: 15
Yeah, i'm one of the several people that are watching this thread, hoping that something will come up. As things are, i'm too busy to look into anything more lately, but i'd be very grateful if someone found something out and posted about it in here
 
Old 03-08-2007, 11:30 AM   #10
ctt1wbw
Member
 
Registered: Jan 2005
Location: Seaford, VA
Distribution: Fedora 7 and Kubuntu 7.04
Posts: 58

Rep: Reputation: 15
How about checking out this thread in ubuntu forums:

http://www.ubuntuforums.org/showthread.php?t=361136

This guy got it working, but I asked about the procedures and how they would differ under Fedora.
 
Old 03-13-2007, 06:56 AM   #11
ctt1wbw
Member
 
Registered: Jan 2005
Location: Seaford, VA
Distribution: Fedora 7 and Kubuntu 7.04
Posts: 58

Rep: Reputation: 15
Well, I installed Fedora Core 6 on my Thinkpad T30 last night. It was enabled correctly with Direct Rendering and OpenGL works out of the box. I'm trying Beryl this afternoon.
 
Old 03-13-2007, 02:55 PM   #12
ctt1wbw
Member
 
Registered: Jan 2005
Location: Seaford, VA
Distribution: Fedora 7 and Kubuntu 7.04
Posts: 58

Rep: Reputation: 15
Well, I'll be! Beryl works with no mods at all.
 
Old 03-16-2007, 08:33 AM   #13
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 10.04/12.04, Scientific Linux 6.3, Android-x86, Maemo
Posts: 1,658

Rep: Reputation: 138Reputation: 138
Has anyone had any success at running Beryl at a 1500x1040 resolution with an ATI 7500??? That's what I have on my Dell C640... and no joy.
 
Old 03-25-2007, 02:18 AM   #14
dbmk
LQ Newbie
 
Registered: Mar 2007
Posts: 1

Rep: Reputation: 0
Info

Open source drivers should work.
Chipset: ATI RV200 (variant of the R100 core)
The proprietary Linux drivers don't support the R100 chips (Radeon 7000-7500).

www.thinkwiki.org/wiki/ATI_Mobility_Radeon_7500

Last edited by dbmk; 03-25-2007 at 02:19 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mobility Radeon 7500 + ATI drivers 3.7.6 -> X 4.3 down... gio_schenk Linux - Hardware 5 03-21-2007 08:31 AM
ATI Radeon 7500 Mobility + Linux = Problems DaCapn Linux - Laptop and Netbook 2 03-27-2005 09:25 PM
ATI M7 Radeon Mobility 7500 Driver reihat Linux - Laptop and Netbook 6 10-25-2004 02:55 PM
Graphics not diplaying properly on ATI Radeon Mobility 7500 such007 Fedora 1 09-09-2004 05:35 PM
ATI Mobility Radeon 7500 idiotgeneration Linux - Laptop and Netbook 1 01-13-2004 11:51 PM


All times are GMT -5. The time now is 03:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration