LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 08-08-2004, 01:31 AM   #1
MachineH
LQ Newbie
 
Registered: Aug 2004
Distribution: Slackware
Posts: 1

Rep: Reputation: 0
ATI fglrx driver problems on a Sony Vaio (but can be a common problem...)


Hi everybody.

I have a Sony Vaio PCG-K115S, with a ATI Radeon Mobility 9200 inside.
I use slackware 10.0 with a 2.6.7 kernel (the original one).

That's the problem: if I use the fglrx driver (the official ATI driver), X.org doesn't. work. Simply, when i write startx, the screen goes black, and nothing happens. I've tried Ctrl+Alt+F1/F2/.../Del but nothing happens too, and I have to power off the laptop.

Radeon DRI drivers (icluded in Xorg) works fine, instead.

I've tried everything: switch options on or off (like UseInternalAGP, FastWrites...), adding vga=792 at boot, modifing the hex code of fglrx_drv.o (!!) as suggested in a website about an asus laptop...
I have no idea left...

Please help!

Some details:
- sometimes (on some configuration) the Xorg.log doesn't report anything, sometimes only a laconic:
"Caught signal 11"
No errors regarding fglrx.
- Module loads fine, as the agpgart one do.
- /etc/log/messages doesn't report anything interesting.

Thanks in advance
Paolo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Video driver for notebook Sony Vaio FR130. abarriosp1 Red Hat 1 10-05-2005 04:37 PM
blurry screen with nvidia GEforce 6200 driver on sony vaio VGN FS690 abuheider Linux - Hardware 0 09-24-2005 10:56 AM
Problems initialising ´fglrx´ driver for ATI. St00gE Fedora 4 05-28-2005 09:50 PM
Sony Vaio VGN-B1XP / sony driver question kentri9 Linux - Laptop and Netbook 0 12-27-2004 11:00 AM
Sony Vaio video problems SLaCk_KiD Linux - Hardware 3 11-23-2004 05:02 PM


All times are GMT -5. The time now is 03:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration