LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 11-13-2003, 11:42 PM   #1
zero79
Member
 
Registered: Nov 2003
Location: Ohio
Distribution: Debian Unstable
Posts: 460

Rep: Reputation: 30
unable to obtain ip address from dhcp server (Fedora Core 1)


Hello all,

I am trying out Fedora Core 1, but the system seems to be having a little trouble obtaining an ip address from my dhcp server (linksys router). I am able to obtain an ip with the same system if i boot mandrake 9.2 or windows, so this most-likely is not an issue with the physical network. i've been watching /var/log/messages to ascertain the problem, and these are the messages it spits out when attempting to lease the ip:

Nov 12 23:06:34 zero_tux kernel: ip_tables: (C) 2000-2002 Netfilter core team
Nov 12 23:06:38 zero_tux dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
Nov 12 23:06:43 zero_tux dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
Nov 12 23:06:57 zero_tux dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
Nov 12 23:07:08 zero_tux dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 21
Nov 12 23:07:29 zero_tux dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
Nov 12 23:07:29 zero_tux kernel: udf: registering filesystem
Nov 12 23:07:34 zero_tux kernel: UDF-fs: No VRS found
Nov 12 23:07:39 zero_tux dhclient: No DHCPOFFERS received.


first of all, is the is the netmask 255.255.255.255 correct? i would imagine that i want a netmask of 255.255.255.0, so how would i go about changing it so that the dhcp client uses the updated netmask?

i appreciate any help that you all can give
 
Old 11-14-2003, 01:49 AM   #2
funny_harry
LQ Newbie
 
Registered: Oct 2003
Posts: 11

Rep: Reputation: 0
use
#setup
as root user

or you can even edit file

/etc/network/network-scripts/ifcfg-(something mostlinkey eth0 on LAN)

& Change/enter line

NETMASK=255.255.255.0
 
Old 11-14-2003, 02:40 AM   #3
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
I don't think that's a netmask. It think it just sends it to every available address. That would make the netmask 0.0.0.0. Mine sends to 255.255.255.255 and it works fine. Have you tried doing a manual dhclient eth0?
 
Old 11-14-2003, 09:14 AM   #4
carstenson
Member
 
Registered: Oct 2003
Location: Austin, TX
Distribution: RH 7.3, RH 9.0, FC4, Arch
Posts: 36

Rep: Reputation: 15
adz is correct. The dhcp server will define your netmask. This is a broadcast, not assigned to any network, in order to get a response from the server.

Port 67 is listed as the bootp server port.
 
Old 11-14-2003, 07:47 PM   #5
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
It is almost certainly a firewall issue, however maybe you have found a non functioning nic driver.

first I would try to drop the firewal.

service iptables stop

Next if it still fails to work, setup the nic manually and see if it works, this would eliminate the possibility af the nic driver being a problem.

use the correct ip address

ifconfig eth0 192.168.0.5

add the default route, using the correct ip address

route add default gw 192.168.0.1

setup the nameservers in /etc/resolv.conf, again using the correct servers for your network

nameserver 192.168.0.1
nameserver 192.168.0.2



Then check it by using the connection

examples of a configured system..

[root@zeus root]# ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:C0:9F:1F:32:1A
inet addr:192.168.0.3 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::2c0:9fff:fe1f:321a/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:308 (308.0 b)
Interrupt:11 Base address:0x3000

[root@zeus root]# cat /etc/resolv.conf
nameserver 192.168.0.1
nameserver 192.168.0.2

[root@zeus root]# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth0
 
Old 11-15-2003, 02:42 PM   #6
zero79
Member
 
Registered: Nov 2003
Location: Ohio
Distribution: Debian Unstable
Posts: 460

Original Poster
Rep: Reputation: 30
In case anyone else runs into this problem, here is the solution. It seems to be a conflict between Kudzu (hardware autodetector) and the 3com nic driver. I just disable kudzu with the following command issued as root:

chkconfig --level 345 kudzu off

On reboot, eth0 came up right away with an ip leased from my dhcp server.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless card cannot obtain IP address from DHCP server kswitch Linux - Wireless Networking 6 11-06-2005 12:36 PM
unable to obtain socket and address of client David@330 Linux - Newbie 5 06-01-2005 10:23 AM
DHCP Server on Fedora Core 3 bakersman Linux - Networking 1 05-01-2005 05:37 AM
Fedora core 3 - way to obtain flash DrD Fedora 5 11-22-2004 04:50 PM
obtain dns server address automatically mspier Linux - Networking 10 01-11-2004 01:33 AM


All times are GMT -5. The time now is 06:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration