LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 10-31-2005, 06:39 PM   #1
kswitch
LQ Newbie
 
Registered: Aug 2005
Posts: 4

Rep: Reputation: 0
wireless card cannot obtain IP address from DHCP server


slackware 10.1 linux 2.4.29
I cant seem to get an IP address for the at0 interface from the DHCP server on my router. IM running MADWIFI on a D-Link DWL-G510.
i have tried:
Code:
dhcpcd ath0
still everything i do seems hopeless. if anyone is out there who has a helpful hint please reply. much appreciated.
thank you.
 
Old 10-31-2005, 06:54 PM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
I do not know what slackware very well but post your /etc/rc.d/rc.inet1.conf. The command you are using is incorrect. That is to activate a dhcp server daemon on the linux machine. Use ' ifconfig ath0 up '. This would work if the settings in /etc/rc.d/rc.inet1.conf are set to dhcp. Only thing I do not know is how ath0 is defined in slackware. I am sure there is info here about the subject. Try the search feature for more help.

Also you make sure there is no wep, wpa, mac or IP filtering turned-on on the router to eliminate those issues for now. If using those security features enabled them after setting linux machine has them enabled.

Hope this helps
Brian1
 
Old 11-01-2005, 09:34 AM   #3
kswitch
LQ Newbie
 
Registered: Aug 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Smile /etc/rc.d/rc.inet1.conf

ok here it is. hope this helps
Code:
# /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# Config information for ath0 (using dhcp):
IFNAME[1]="ath0"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]="linksys"

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"
 
Old 11-01-2005, 09:51 AM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,257

Rep: Reputation: Disabled
Re: /etc/rc.d/rc.inet1.conf

Quote:
Originally posted by kswitch
ok here it is. hope this helps

# Config information for ath0 (using dhcp):
IFNAME[1]="ath0"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]="linksys"

.......


# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

.........

You see where this fails?The first set of lines are correct for configuring ath0 using DHCP to request an IP address.
But then comes the second set of lines with PARAMETERNAME[1]="...." and now USE_DHCP[1] gets re-defined to an empty value. The result is, that your ath0 will not be configured at all.

This would be enough already:
Code:
 
# /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# Config information for ath0 (using dhcp):
IFNAME[1]="ath0"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]="linksys"

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"
It is not required to have all the other parameters with [0] [2] and [3] etc... you can leave them in, or out if they are empty == unused. But never use any of them twice ...
Another remark: the use of the parameter IFNAME[1]="ath0" is only introduced in Slackware 10.2. For Slackware 10.1 you would first have to download newer rc.inet1 and rc.wireless scripts at http://www.slackware.com/~alien/rc_scripts/ for instance, I do not know if you did that.

Now, this part only covered the TCPIP part of setting up your interface. Are you sure that your wireless configuration is correct, too? Because the command
Code:
dhcpcd -d -t 30 ath0
should give you an IP address even if the configuration in the rc.inet1.conf file was completely wrong. The fact that you did not get an IP address would suggest that you need to do some more configuration, perhaps in rc.wireless.conf? Perhaps the ESSID and/or a WEP key?

Eric
 
Old 11-01-2005, 02:30 PM   #5
kswitch
LQ Newbie
 
Registered: Aug 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Smile /etc/rc.d/rc.inet1.conf

i made the appropriate changes. i still dont get an IP address from the dhcp server
Code:
# /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# Config information for ath0 (using dhcp):
IFNAME[1]="ath0"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]="linksys"

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

Last edited by kswitch; 11-01-2005 at 02:41 PM.
 
Old 11-01-2005, 02:57 PM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,257

Rep: Reputation: Disabled
Time you post the output of the
Code:
iwconfig
Code:
ifconfig -a
and
Code:
cat /etc/rc.d/rc.wireless.conf | grep -v "^$" | grep -v "^[^\w]*#"
commands...

Eric
 
Old 11-06-2005, 11:36 AM   #7
kswitch
LQ Newbie
 
Registered: Aug 2005
Posts: 4

Original Poster
Rep: Reputation: 0
iwconfig, ifconfig -a, and... cat /etc/rc.d/...

Code:
 bash-3.00# iwconfig
lo               no wireless extensions

wifi0          no wireless extensions

ath0          IEEE 802.11g    ESSID:"msg"
                 Mode:Master    Frequency:2.412GHz        Access Point:  00:11:95:F9:51:12
                 Bit Rate:0kb/s      Tx-Power:18 dBm      Sensitivity=0/3
                 Retry:off     RTS thr:off          Fragment thr:off
                 Encryption key: off
                 Power Managment: off
                 Link Quality:0/94       Signal level:-95 dBm    Noise level:-9 dBm
                 Rx invalid nwid:9       Rx invalid crypt:0    Rx invalid frag:0
                 Tx excessive retries:0    Invalid misc:0     Missed beacon:0

bash-3.00# ifconfig -a
\ath0           Link encap:Ethernet   HWaddr  00:11:95:F9:51:12
                 UP BROADCAST MULTICAST    MTU:1500   Metric:1
                 RX packets:0  errors:0 dropped:0 overruns:0 frame:0
                 TX packets:3  errors:0 dropped:0 overruns:0 carrier:0
                 collisions:0
                 RX bytes:0 (0.0 b)    TX bytes 1770 (1.7kb)

lo              Link encap: Local Loopback
                 inet addr:127.0.0.1    Mask:255.0.0.0
                 UP LOOPBACK RUNNING   MTU:16436   Metric:1
                 RX packets:2  errors:0 dropped:0 overruns:0 frame:0
                 TX packets:2  errors:0 dropped:0 overruns:0 carrier:0
                 collisions:0
                 RX bytes:100 (100.0 b)   TX bytes:100 (100.0b)

wifi0         Link encap:Ethernet   HWaddr  00:11:95:F9:51:12
                UP BROADCAST MULTICAST    MTU:1500   Metric:1
                RX packets:57  errors:0 dropped:0 overruns:0 frame:30
                TX packets:48  errors:1 dropped:0 overruns:0 carrier:0
                collisions:0
                RX bytes:3183 (31.0 kb)   TX bytes:4655 (4.5 kb)
Code:
bash-3.00# cat /etc/rc.d/rc.wireless.conf |grep -v "^$" | grep -v "^[^\w]*#"|more
VERBOSE=1
case "$HWADDR" in
*)
       INFO="Any ESSID"
       ESSID="any"
       ;;
00:04:E2:*)
       INFO="SMC2835W  EZ Connect g 2.4GHz  54 Mbps  Wireless Cardbus Adapter"
      ESSID="any"
      NWID=""
      MODE="Managed"
      FREQ=""
      CHANNE="6"
      SENS=""
      RATE="auto"
      KEY=""
      RTS=""
      FRAG=""
      IWCONFIG=""
      IWSPY=""
      IWPRIV=""
      ;;
00:60:1D*100:02:2D:*)
      INFO="Wavelan IEEE example  (Lucent default settings)"
      ESSID="Wavelan Network"
      MODE="Managed"
      KEY="s:secu1"
      ;;
00:40:96:*100:02:8A:*)
      INFO="Cisco/Aironet example (Cisco default settings)"
      ESSID="any"
      MODE="Managed"
      KEY="off"
      ;;
00:00:F0:*100:02:78:*)
      INFO="Samsung MagicLan example (Samsung default settings)"
      ESSID="any"
      MODE="Managed"
      CHANNEL="4"
      RATE="auto
      ;;
00:00:8F:*100:00:F1:*)
     INFO="Raylink/Aviator2.4 example (Aviator default ad=hoc setting)"
     ESSID="ADHOC_ESSID"
     MODE="Ad-Hoc"
     RATE="auto"
     IWPRIV="set_framing 1"
     ;;
08:00:0E:*)
     INFO="Wavelan example (Lucent default settings)"
     NWID="0100"
     MODE="Ad-Hoc"
     FREQ="2.425G"
     KEY="off"
     ;;
00:80:C7:*)
     INFO="Netwave example (Netwave default settings)"
     NWID="100"
     KEY="00"
     ;;
XX:XX:XX:*)
     INFO="Proxim RangeLan2/Symphony example"
     NWID="0"
     MODE="Master"
     CHANNEL="15"
     IWPRIV="setsubchan 1"
     ;;
XX:XX:XX:*)
     INFO="NWN Swallow example"
     ESSID="session"
     KEY="0000-0000-00 open"
     ;;
XX:XX:XX:*)
     INFO="Symbol Spectrum24 example"
     ESSID="Essid string"
     ;;
*)
     INFO="Fill with your own settings..."
     ESSID=""
     NWID=""
     MODE=""
     FREQ=""
     CHANNEL=""
     SENS=""
     RATE=""
     KEY=""
     RTS=""
     FRAG=""
     IWCONFIG=""
     IWSPY=""
     IWPRIV=""
     ;;
esac
bash-3.00#

Last edited by kswitch; 11-06-2005 at 12:50 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't obtain IP address for my wireless card trialanderror Linux - Newbie 17 07-23-2005 03:51 PM
DHCP Server MAC Address found, IP address not assigned wmburke Linux - Wireless Networking 17 11-17-2004 10:33 AM
Wireless Network card DHCP wont get address debugging and troubleshooting help uuplunkeruu Linux - Wireless Networking 2 03-27-2004 04:08 PM
obtain dns server address automatically mspier Linux - Networking 10 01-11-2004 12:33 AM
unable to obtain ip address from dhcp server (Fedora Core 1) zero79 Linux - Hardware 5 11-15-2003 01:42 PM


All times are GMT -5. The time now is 12:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration