LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-25-2008, 11:17 PM   #1
bluehaze
LQ Newbie
 
Registered: Sep 2008
Posts: 7

Rep: Reputation: 0
t3400 sound card issue debian etch 2.6.18-486


I am running Debian Etch 2.6.18-486. My soundcard is not recognized. Anyone know where to get this driver and how to install using dpkg? A second question. Why are all of my hardware unknown? This is a dell t3400 system. How do i update files to reflect what these hardware are.

thank you for your help.

lspci output below
00:00.0 Host bridge: Intel Corporation Unknown device 29e0

00:01.0 PCI bridge: Intel Corporation Unknown device 29e1

00:06.0 PCI bridge: Intel Corporation Unknown device 29e9

00:1a.0 USB Controller: Intel Corporation Unknown device 2937 (rev 02)

00:1a.1 USB Controller: Intel Corporation Unknown device 2938 (rev 02)

00:1a.2 USB Controller: Intel Corporation Unknown device 2939 (rev 02)

00:1a.7 USB Controller: Intel Corporation Unknown device 293c (rev 02)

00:1b.0 Audio device: Intel Corporation Unknown device 293e (rev 02)

00:1c.0 PCI bridge: Intel Corporation Unknown device 2940 (rev 02)

00:1c.5 PCI bridge: Intel Corporation Unknown device 294a (rev 02)

00:1d.0 USB Controller: Intel Corporation Unknown device 2934 (rev 02)

00:1d.1 USB Controller: Intel Corporation Unknown device 2935 (rev 02)

00:1d.2 USB Controller: Intel Corporation Unknown device 2936 (rev 02)

00:1d.7 USB Controller: Intel Corporation Unknown device 293a (rev 02)

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)

00:1f.0 ISA bridge: Intel Corporation Unknown device 2916 (rev 02)

00:1f.2 IDE interface: Intel Corporation Unknown device 2920 (rev 02)

00:1f.3 SMBus: Intel Corporation Unknown device 2930 (rev 02)

00:1f.5 IDE interface: Intel Corporation Unknown device 2926 (rev 02)

01:00.0 VGA compatible controller: nVidia Corporation Unknown device 042f (rev a1)

04:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5754 Gigabit Ethernet PCI Express (rev 02)
 
Old 09-26-2008, 09:28 AM   #2
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
WOW that's a lot of unknowns.. your system must be fairly new. Have you considered running Debian Testing (Lenny) instead of Debian Stable (Etch) ?


First thing I would try would be to update the pci.ids looku-p table to see if the systerm can then recognize your hardware.

In Debian that can be done with the command : update-pciids

Code:
User@it-etch:~$ su - 
Password: 
it-etch:~# update-pciids
Downloaded daily snapshot dated Tue 2008-09-16 01:05:02
it-etch:~#
Give lspci another shot and see if it does a better job of detecting your hardware.


MMmmmm that;s a nice looking piece of hardware.. I see that it supports RHEL WS v5 (64) so you should be able to get Debian running on there. Debian Lenny has a newer kernel and is more up to date, which is why I suggested you might want to give it a try. It should be the new stable version in a couple months.. I think
 
Old 10-06-2008, 08:52 PM   #3
bluehaze
LQ Newbie
 
Registered: Sep 2008
Posts: 7

Original Poster
Rep: Reputation: 0
thank you so much for that post. It worked. my lspci has found everything. wow. maybe this means the sound card will work now.

here is the result. thank you so much again.
00:00.0 Host bridge: Intel Corporation 82X38/X48 Express DRAM Controller

00:01.0 PCI bridge: Intel Corporation 82X38/X48 Express Host-Primary PCI Express Bridge

00:06.0 PCI bridge: Intel Corporation 82X38/X48 Express Host-Secondary PCI Expre ss Bridge

00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controll er #4 (rev 02)

00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controll er #5 (rev 02)

00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controll er #6 (rev 02)

00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Control ler #2 (rev 02)

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)

00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (r ev 02)

00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (r ev 02)

00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controll er #1 (rev 02)

00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controll er #2 (rev 02)

00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controll er #3 (rev 02)

00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Control ler #1 (rev 02)

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)

00:1f.0 ISA bridge: Intel Corporation 82801IR (ICH9R) LPC Interface Controller ( rev 02)

00:1f.2 IDE interface: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA IDE Controller (rev 02)

00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)

00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA IDE Co ntroller (rev 02)

01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 290 (rev a1)

04:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5754 Gigabit Ethe rnet PCI Express (rev 02)
 
Old 10-06-2008, 10:24 PM   #4
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
ICH9..

I think you need a newer kernel, 2.6.26 or so..

you may have to upgrade to Lenny in order to get everything working properly
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache2 issue in Debian etch. Hammad101 Linux - Server 1 09-10-2008 09:15 AM
debian etch - samba issue wo2caisley Linux - Newbie 9 06-07-2008 04:15 AM
Debian Etch startup issue. kurianthayil Linux - Newbie 3 05-14-2008 02:01 PM
No sound in Debian ETCH with amd64 nvidia sound card pietruszewski Debian 20 04-27-2008 04:48 AM
Debian Etch poptop, cannot connect issue... kbutcher5 Linux - Networking 1 06-27-2006 11:07 AM


All times are GMT -5. The time now is 08:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration