LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-23-2008, 09:56 PM   #1
pietruszewski
Member
 
Registered: Jul 2007
Location: London, Ontario, Canada
Distribution: Debian
Posts: 79

Rep: Reputation: 15
No sound in Debian ETCH with amd64 nvidia sound card


I have a post in the linux n00bz section on this topic, but it was originally a question pertaining to compiz-fusion:
http://www.linuxquestions.org/questi...-stuff-635782/

I think maybe with a more definite subject I could find someone that could help me.

My Audio device is: nVidia Corporation MCP61 High Definition Audio (rev a2) (On-board)
I know for a fact it works because I dual boot with Windows XP and it works with that. Does anybody have any advice?
 
Old 04-24-2008, 11:39 AM   #2
thveillon
Member
 
Registered: Dec 2007
Posts: 59

Rep: Reputation: 16
To get the post rolling, Etch kernel is a bit old now, if your hardware is newer the audio chipset might not be supported by etch's alsa version. Your best bet would be to either look in Testing or Sid for newer versions or download sources and compile from the alsa website. Then an alsaconf as root should do the trick. You chip is most probably supported by the snd_hda_intel alsa module.

Maybe just running sudo /usr/share/alsa-base/snddevices and alsaconf as root would be enough to get your card identified and configured, worth a shot.
 
Old 04-24-2008, 12:39 PM   #3
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Rep: Reputation: 48
Quote:
Originally Posted by thveillon View Post
To get the post rolling, Etch kernel is a bit old now, if your hardware is newer the audio chipset might not be supported by etch's alsa version. Your best bet would be to either look in Testing or Sid for newer versions or download sources and compile from the alsa website. Then an alsaconf as root should do the trick. You chip is most probably supported by the snd_hda_intel alsa module.

Maybe just running sudo /usr/share/alsa-base/snddevices and alsaconf as root would be enough to get your card identified and configured, worth a shot.
That and also make sure that you uncheck the mute button under Volume properties.

Another thing you could try is to load pcm module:
Code:
modprobe snd_pcm_oss
you will require that to enable sound in GNOME.

Also install alsamixer.
 
Old 04-24-2008, 10:29 PM   #4
pietruszewski
Member
 
Registered: Jul 2007
Location: London, Ontario, Canada
Distribution: Debian
Posts: 79

Original Poster
Rep: Reputation: 15
thveillon, Would you suggest I start over and go with Lenny or Sid? I have no problem with reinstalling, but would Lenny recognize my sound card right off the bat?
 
Old 04-24-2008, 10:31 PM   #5
pietruszewski
Member
 
Registered: Jul 2007
Location: London, Ontario, Canada
Distribution: Debian
Posts: 79

Original Poster
Rep: Reputation: 15
PS: I just realized I was 'scrolling' down to the bottom to read the last post - Mouse scrolling was giving me some headaches and I'm very happy that all that tinkering around with my xorg.conf file actually worked! Yippeee!
 
Old 04-25-2008, 04:40 AM   #6
thveillon
Member
 
Registered: Dec 2007
Posts: 59

Rep: Reputation: 16
Quote:
Originally Posted by pietruszewski View Post
thveillon, Would you suggest I start over and go with Lenny or Sid? I have no problem with reinstalling, but would Lenny recognize my sound card right off the bat?
No, no, there's no need to reinstall in Debian to go up one level (just editing the sources.list), but anyway you can stay with Stable but just grab never alsa sources from either a Debian Testing or Unstable repository (just add one to your sources.list for that purpose and comment it out after, or just search for the package on http://www.debian.org/distrib/packages), or download it from alsa website and compile it yourself by following alsa's wiki how-to.

Alternatively you could install a never kernel which will give you access to the never modules that goes with it. (again add a Testing source to the sources.list and install "linux-image-whatever_fits_you.deb", or download from Debian along with never alsa package).

But before going ballistic, did you try a few of the commands given to you ? Or check on alsa's compatibility list what version is supporting your chipset ?
 
Old 04-25-2008, 08:49 AM   #7
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
Quote:
you can stay with Stable but just grab never alsa sources from either a Debian Testing or Unstable repository
That is very bad advice. Do not mix Testing or Unstable apps with Etch, the Stable release. It's OK to mix Testing and Unstable, in fact I recommend it, but Stable is just that ... stable. Don't mess with it.

It's 99% likely that you can get your sound card working in Etch, with the advice you have above.
 
Old 04-25-2008, 09:07 AM   #8
thveillon
Member
 
Registered: Dec 2007
Posts: 59

Rep: Reputation: 16
I completely agree with you rickh, but in a non-critical desktop environment having a piece of hardware such as the sound card not working might be a case for a small exception... But yes, first try the basic configuration steps, and then as a last resort consider breaking your system ;-)
 
Old 04-25-2008, 01:59 PM   #9
pietruszewski
Member
 
Registered: Jul 2007
Location: London, Ontario, Canada
Distribution: Debian
Posts: 79

Original Poster
Rep: Reputation: 15
alsaconf doesn't see my sound card (as it was the first thing I tried) but maybe I just don't have the right package installed... What should I be downloading from synaptic/aptitude?
 
Old 04-25-2008, 02:14 PM   #10
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
Try adding a line with "options snd-hda-intel position_fix=1 model=3stack" to the end of /etc/modprobe.d/alsa-base and, umm, reboot.
 
Old 04-25-2008, 02:51 PM   #11
pietruszewski
Member
 
Registered: Jul 2007
Location: London, Ontario, Canada
Distribution: Debian
Posts: 79

Original Poster
Rep: Reputation: 15
Code:
options snd-hda-intel position_fix=1 model=3stack
No luck with this.
 
Old 04-25-2008, 02:54 PM   #12
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65
What does an
Code:
$ lsmod | grep -i snd
return?
 
Old 04-25-2008, 03:11 PM   #13
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
I think you may have a problem if you're using Etch's stock kernel, 2.6.18 ...

Googling around a bit suggests that support for that chip requires ALSA 1.0.13 (which Etch has) and Kernel 2.6.19 or greater.

If you want to stick with Etch, familiarize yourself with www.backports.org. That is a quasi-official repository to get newer packages than normal into the Stable release. They have kernels up to 2.6.22. Find the "instructions" page first and get backports built correctly into your sources.list file.
 
Old 04-26-2008, 12:37 AM   #14
pietruszewski
Member
 
Registered: Jul 2007
Location: London, Ontario, Canada
Distribution: Debian
Posts: 79

Original Poster
Rep: Reputation: 15
Code:
lsmod | grep -i snd
Returns nothing. On a side note, what does the 'lsmod' command do?

Turns out I already have the backports repo in my sources.list, but synaptic only finds a linux-image 2.6.18

Last edited by pietruszewski; 04-26-2008 at 12:45 AM.
 
Old 04-26-2008, 04:28 AM   #15
thveillon
Member
 
Registered: Dec 2007
Posts: 59

Rep: Reputation: 16
Oups ! You've got a problem ! "lsmod" lists all loaded modules, and snd* are alsa sound related modules. Let's see if they are at least present but not loaded :

Code:
find /lib/modules/$(uname -r)/* -name snd*
 
  


Reply

Tags
debianhardware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No Sound. nvidia Corporation MCP61: Debian ETCH fof3 Linux - General 3 12-24-2007 07:39 AM
No Sound. nvidia Corporation MCP61: Debian ETCH fof3 Linux - Software 1 12-16-2007 08:10 PM
No Sound in Debian Etch gamewolf Debian 4 06-08-2007 10:30 PM
No Sound on Debian Etch eric_marsh Linux - General 7 02-10-2007 09:56 AM
debian etch sound help snuffy115 Debian 1 12-30-2006 01:11 PM


All times are GMT -5. The time now is 11:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration