LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 01-21-2004, 03:27 PM   #1
jogurt666
Member
 
Registered: Nov 2003
Location: Poland => Mazowieckie => Ok'a
Distribution: Gentoo
Posts: 176

Rep: Reputation: 30
ripping cd audio problem


i use Debian with KDE. i've installed KAudioCreator and KsCD. the second one plays CD audios, but it is so quiet, i can hardly hear anything. i know that Linux requires proper wires to connect cdrom with motherboard, and i've got them connected on the right place (well everything worked fine under RedHat). i've also set volume and CD volume in aumix.

The second problem is with ripping CDs. when i select tracks to rip, and want to rip them, i'm prompted the following warning:

The process cannot be run. io-slave cannot be created:
klauncher has returned the following communicate: Unknown protocol 'audiocd'.

(that's my own translation from polish, it may vary in original).
what is wrong, and what should i do?
 
Old 01-21-2004, 04:15 PM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
When you rip CD's you should be using ide-scsi emulation if you have an IDE CD-ROM. To enable it, just append something like this to your kernel command line: hdc=ide-scsi and add the "ide-scsi" module to /etc/modules so it will be loaded on boot. "hdc" should be the device which corresponds to your CD-ROM device (try dmesg | grep CD if you are unsure what your CD device is).

If you're using the default Debian /etc/lilo.conf you probably have an "append" line in there which you can un-comment (remove the "#" at the start of the line) and add hdc=ide-scsi there. When done you need to rerun /sbin/lilo for the changes to take effect (and if you don't you may end up not being able to boot from the HD!).

When using SCSI emulation you usually access the CD-ROM as /dev/scd0 or /dev/sg0 instead of /dev/hdc.


Håkan

Last edited by hw-tph; 01-21-2004 at 04:18 PM.
 
Old 01-22-2004, 12:35 AM   #3
witeshark
Member
 
Registered: Jan 2004
Location: Miami FL
Distribution: Mac OS X 10.4.11 Ubuntu 12.04 LTS
Posts: 429

Rep: Reputation: 30
hw-tph, Håkan: interesting! Would you (hows the weather by the way?) have any comments on my CD drive running audio CD, showing a time count and track numbers but playing no sound (-Red Hat 7.2 by the way), plays sound clearly during boot up I want to be careful in the command line (GOOD GOD am I happy to be winbloz free!) since I am now most familiar with the terminal in Mac.
 
Old 01-22-2004, 04:58 AM   #4
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
(It's freezing cold )

Does your CD-ROM play audio CD's very quietly or not at all? I'm getting a little confused when I read your inital post and then your reply.

Anyway, if the sound level is very low you should be able to increase the analog volume (aux in or CD level) and/or your master level using a software mixing application.

If your hardware worked with Redhat it is quite possible that you have a permissions problem. Try running the CD audio player program as root (su to root in a terminal and launch the program from there). If that works there definitely is a permissions problem somewhere. As yourself, not root, type groups in a terminal and you'll get a list of groups you belong to. If you have the group "cdrom" there you can skip the following step, but if you don't, do this:

As root open up /etc/group in your favourite text editor. Find the line that begins with cdrom, probably something like this:
Code:
cdrom::19:
Now add your regular user and any other users you want to have full cdrom access to that line. The list of names is comma separated, so if we were to add yourself and me the line would look something like this:
Code:
cdrom::19:witeshark,hw
Save the file and log out and log in again. Now type groups again as yourself. The cdrom group should appear there.

Now let's find out what your CD-ROM device is. It is common practice that the device /dev/cdrom is a symbolic link pointing to the actual device. Type ls -l /dev/cdrom and you'll see something like this:
Code:
lr-xr-xr-x    1 root     root           13 Jan 22 09:28 /dev/cdrom -> cdroms/cdrom0
...if you use devfs, and if you don't it will look something like this:
Code:
lr-xr-xr-x    1 root     root           13 Jan 22 09:28 /dev/cdrom -> hdc
Make note of what device the /dev/cdrom links to, in this case it is /dev/hdc, which is common (hdc is the master device on the secondary IDE channel). Now let's look at the permissions for this device. I will use hdc in my examples but you should use whatever you found out in the prior step (what /dev/cdrom links to): ls -l /dev/hdc
Code:
brw-------    1 root       disk     11,   0 Jan  1  1970 /dev/hdc
The output would look something like the above. It belongs to the user root and the group disk. We want to change the permissions so it is still owned by root but with the cdrom group and all users in the cdrom group should have all permissions for the device:
chown root.cdrom /dev/hdc - this changes the ownership to the root user and cdrom group
chmod g+rwx /dev/hdc - this gives the cdrom group members read, write and execute permissions on the device

Log out, log in again and try to play something, I recommend The Twilight Singers - Blackberry Belle.



Håkan
 
Old 01-22-2004, 02:00 PM   #5
witeshark
Member
 
Registered: Jan 2004
Location: Miami FL
Distribution: Mac OS X 10.4.11 Ubuntu 12.04 LTS
Posts: 429

Rep: Reputation: 30
hw-tph : thanks tons! I think I may get it running now!
 
Old 01-22-2004, 02:21 PM   #6
jogurt666
Member
 
Registered: Nov 2003
Location: Poland => Mazowieckie => Ok'a
Distribution: Gentoo
Posts: 176

Original Poster
Rep: Reputation: 30
pardon my poor English. i explain. it's definitely not a permission problem, since i've already set the groups (otherwise it wouldn't play at all). sound is very quiet, but it can be heared. i've got two CD-ROMs first one mounts as /dev/hdb second as /dev/hdc (well it atelast did). sound in the second one is (was) louder than in first one, but it's still not what i want. i've added the line you told me to /etc/lilo.conf, but now i cannot find my CD-ROM, it simply does not mount as /dev/scd0 or something like that.
 
Old 01-22-2004, 02:57 PM   #7
jogurt666
Member
 
Registered: Nov 2003
Location: Poland => Mazowieckie => Ok'a
Distribution: Gentoo
Posts: 176

Original Poster
Rep: Reputation: 30
could you tell me what should i exactly compile as a module in xconfig in SCSI session?
 
Old 01-23-2004, 12:38 PM   #8
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
Check your /etc/fstab. With SCSI emulation enabled you will have to change the entry for your CD-ROM from /dev/hdc (or whatever) to /dev/scd0.

If you're compiling your own kernel you will need SCSI support, support for generic SCSI devices and SCSI CD-ROMs. Also, under ATA/IDE devices make sure you have SCSI emulation as a module.

Håkan
 
Old 01-23-2004, 03:40 PM   #9
jogurt666
Member
 
Registered: Nov 2003
Location: Poland => Mazowieckie => Ok'a
Distribution: Gentoo
Posts: 176

Original Poster
Rep: Reputation: 30
now it works fine. the problem was that i didn't know what should i compile into kernel. sound is still to quiet while playing from audio cds, but now i can rip music, however i had to install grip

forgive me asking to many questions, but i'm still a newbie
 
Old 01-24-2004, 07:07 AM   #10
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
This place is called Linux Questions. You're supposed to ask questions.


Håkan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ripping audio CD in to mp3s nomass Mandriva 10 06-02-2006 01:12 PM
How to speed up ripping audio CDs. springshades Linux - Software 2 08-01-2005 02:37 AM
KDE 3.3.2 Audio Ripping kesara Linux - Software 9 01-01-2005 07:32 PM
cdda2wav audio ripping problem ugenn Linux - Software 4 06-26-2004 03:08 AM
ripping audio from dvds catzmiyow Linux - Software 2 05-10-2004 12:27 PM


All times are GMT -5. The time now is 01:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration