LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-02-2005, 09:38 AM   #1
angel115
Member
 
Registered: Jul 2005
Location: France / Ireland
Distribution: Debian mainly, and Ubuntu
Posts: 494

Rep: Reputation: 75
realtek RTL8169/8110 Gigabit Ethernet on fedora core 4


Hey there.

i've a realtek RTL8169/8110 Family Gigabit Ethernet on fedora core 4 (kernel 2.6.11-1.1369_FC4).

This card is detected and i can ping the 127.0.0.1 and my own IP (if i allow one manually) but i can't ping any IP out (like my router).

Config:
- Router IP: 192.168.123.254/24
- NIC IP: 192.168.123.100/24 (the NIC can't reseve an IP from the DHCP)

I check in the network card settings and it seems like FC4 doesn't allow any IRQ, IO range and Memory range automatically, so i've try to put the same as windows use on this same computer:
IRQ: 19
IO Range: 1000-10FF
Memory Range: D0008800-D000DFFF

But same result

The command lspci give me this:
00:08.0 Ethernet controler: Realtek Semiconductor Co., Ltd RTL-1869 gigabit Ethernet (Rev 10)

Any idea? for information this card is on a laptop Medion and this NIC was working under slakware 10.1 (kernel 2.4.29). Is it a Kerner problem? or some thing else!!!

Any help would be appreciated.
Thanks in advance.
Gael.
 
Old 08-02-2005, 11:38 AM   #2
angel115
Member
 
Registered: Jul 2005
Location: France / Ireland
Distribution: Debian mainly, and Ubuntu
Posts: 494

Original Poster
Rep: Reputation: 75
New update

I find the drivers on the realtek web site.

but when i try to install them by the command make install as root i get this:
make -C src/ install
make[1]: Entering directory `/home/angel115/temp/src'
install -m 644 -c r8169.ko /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/net/
make[1]: Leaving directory `/home/angel115/temp/src'
install: cannot stat r8169.ko'': No such file or directory
make[1]: *** [install] Error 1
make: *** [install] Error 2

in the directory /home/angel115/temp/src i have a file named: r8169_n.c but no r8169.ko

Do i have to compile the .c file? but even if i compile it i'll have r8169_n.???? and not r8169.ko i think...

If any information are missing, just ask.
Thanks,
Gael.

Last edited by angel115; 08-02-2005 at 12:19 PM.
 
Old 08-02-2005, 01:09 PM   #3
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,014

Rep: Reputation: 115Reputation: 115
try insmod r8169. The drivers are already in the kernel src. If it is a stock kernel, try insmod r8169. If not, recompile with that module compiled in.
 
Old 08-03-2005, 09:15 AM   #4
angel115
Member
 
Registered: Jul 2005
Location: France / Ireland
Distribution: Debian mainly, and Ubuntu
Posts: 494

Original Poster
Rep: Reputation: 75
Thanks Tuxdev for your answer, I really appreciate.

I try what you told me insmod r1869 but this command doesn't seems to exist under fedora. I try the slakware 10.1 (kernel 2.4.29) , it's the last available version (the one you maybe use) and my nic was working fine, but it wan't the same kernel. My actual kernel is 2.6.11-1.1369_FC4.

By the way, how do you do to know if the drivers are in the kernel src?
 
Old 08-03-2005, 02:19 PM   #5
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,014

Rep: Reputation: 115Reputation: 115
it may be modprobe, not insmod. insmod is for inserting modules while the kernel is running and everything else to, and modprobe is for boot-up. Of course I could be wrong and modprobe is for everything to do with inserting modules.

It is in the kernel src because the stock slackware kernel does not have anything in it that does not already comes withe the kernel src.

It seems to me that FC4 is a step back from slackware. What caused you to switch?
 
Old 08-04-2005, 10:25 AM   #6
angel115
Member
 
Registered: Jul 2005
Location: France / Ireland
Distribution: Debian mainly, and Ubuntu
Posts: 494

Original Poster
Rep: Reputation: 75
You're right i find the command modprobe in the sbin directory and the module r1869.ko in /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/net

but when i try to install it, it say that the module r1869.ko wasn't find... (same error as yesterday)
here what i've try under root terminal:
Code:
/sbin/./modprobe /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/net/r1869.ko
Do you know why i can see the file but the system doesn't seems to.

to answer your question, if i left slackware it's because i'm planning to pass my LPIC certification in about 2 mounth and a lot of questions are oriented Read Hat so i've try to choise the distribution who is the closest of RH.

Last edited by angel115; 08-04-2005 at 10:27 AM.
 
Old 08-04-2005, 11:37 AM   #7
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,014

Rep: Reputation: 115Reputation: 115
Yeah, that is a good reason to play around with it. Anyway, modprobe likes to try to look for the module, and telling the module file like that does not work (as you are very well know now). Try just
Code:
/sbin/modprobe r8169
 
Old 08-05-2005, 07:25 AM   #8
angel115
Member
 
Registered: Jul 2005
Location: France / Ireland
Distribution: Debian mainly, and Ubuntu
Posts: 494

Original Poster
Rep: Reputation: 75
Ok

I think i'll give up, because i steel have the error Module not found
I think i'll go back to slackeware.

Do you think the slackeware distrib is easy enough for ?
 
Old 08-05-2005, 12:36 PM   #9
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,014

Rep: Reputation: 115Reputation: 115
Slackware requires good use of the CLI. Since you already have that, you can probably do well with it. Configuration is usually the biggest problem. A few things to know:
"alsaconf" detects and configures your sound card.
"xorgsetup" detects your video hardware and configures the X Window System.
"xf86cfg -textmode" tunes your configuration or creates a new config.
localhost:631 in a web browser goes to the printer webmin.
Option ZAxisMapping "4 5" in the mouse section of the X config activates the scroll wheel.
This is just off the top of my head. You can always ask questions in the Slackware forum here at LQ if you have trouble.
 
Old 08-17-2005, 02:09 PM   #10
ibisis
LQ Newbie
 
Registered: Aug 2005
Posts: 1

Rep: Reputation: 0
another case

I installed fc4 i386 on a clevo D470K notebook (sager np4750) which has a realtek
rtl8110s-32 gigabit chip.

Similarly, 'ping' to a server on a private network results in "destination host
unreachable" messages.

Running tcpdump on the notebook shows repeated arp's for the mac of the server.
Running tcpdump on the server shows repeated replies to the notebook.

ifconfig shows all RX and TX values (packets, errors, dropped, ...) at 0 except
that "TX dropped" is non-zero. The fc4 r8169 driver is deaf?

To eliminate questions about firewall and selinux issues, I shut them off.

The network connection through the rtl8110s-32 works fine running Windows XP or
linux off the Knoppix bootable DVD.

lspci -vv shows:
0000:00:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
Subsystem: CLEVO/KAPOK Computer: Unknown device 4701
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 64 (8000ns min, 16000ns max), Cache Line Size: 0x10 (64 bytes)
Interrupt: pin A routed to IRQ 9
Region 0: I/O ports at 1000 [size=256]
Region 1: Memory at d0008800 (32-bit, non-prefetchable) [size=256]
Capabilities: [dc] Power Management version 2
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0-,D1+,D2+,D3hot+,D3cold+)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-

/proc/pci shows (note the different rev level from what lspci reports):
Bus 0, device 8, function 0:
Class 0200: PCI device 10ec:8169 (rev 16)
IRQ 9.
Master Capable. Latency=64. Min Gnt=32.Max Lat=64.
I/O at 0x1000 [0x10ff].
Non-prefetchable 32 bit memory at 0xd0008800 [0xd00088ff].

lsmod shows:
r8169 29645 0

dmesg shows:
r8169 Gigabit Ethernet driver 2.2LK loaded
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ9
PCI: setting IRQ 9 as level-triggered
ACPI: PCI Interrupt 0000:00:08.0[A} -> Link [LNKA] -> GSI 9 (level, low) -> IRQ 9
r8169: NAPI enabled
eth0: Identified chip type is 'RTL8169s/8110s'.
eth0: RTL8169 at 0xf8820800, 00:90:f5:xx:xx:xx, IRQ 9

in /var/log/messages there are lines like this:
Aug 17 xx:xx:xx hostname kernel: NETDEV WATCHDOG: eth0 transmit timed out

some strings out of r8169.ko:
parm=use_dac:Enable PCI DAC. Unsafe on 32 bit PCI slot.
version=2.2LK
vermagic=2.6.11-1.1369_FC4 686 REGPARM 4KSTACKS gcc-4.0

What's different in the ethernet configuration in knoppix (2.6.11) from fc4?
1) irq 19 is used
2) lsmod shows a size of 24844 for r8169
3) strings shows vermagic=2.6.11 SMP preempt 386 gcc-3.3 in r8169.ko
4) dmesg:
r8169 Gigabit Ethernet driver 2.2LK loaded
ACPI: PCI interrupt 0000:00:08.0[A] -> GSI 19 (level, low) -> IRQ 19
eth0: Identified chip type is 'RTL8169s/8110s'.
eth0: RTL8169 at 0xf8d28800, 00:90:f5:xx:xx:xx, IRQ 19

Anything here that points to the problem?

Bill
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Marvell Gigabit ethernet not recognized by Fedora Core 3 hari78 Linux - Hardware 7 07-26-2005 06:28 PM
Fedora Core 1 as router but realtek ethernet cards don't activate Agapito Linux - Networking 0 02-03-2005 06:22 AM
rtl8169 gigabit ethernet NIC problem on ipcop icga Linux - Networking 6 12-03-2004 03:26 AM
RealTek 8168/8110 with fedora zolorin Linux - Hardware 0 09-07-2004 07:55 PM
RTL8169 NIC and Fedora Core 2 putnampp Linux - Networking 0 08-25-2004 08:44 PM


All times are GMT -5. The time now is 10:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration