LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 08-04-2005, 09:14 AM   #1
intmail
LQ Newbie
 
Registered: Jul 2005
Posts: 24

Rep: Reputation: 15
Unhappy ATi RADEON 9600 3D crash with KDE


-- POWERCOLOR ATI9600 crash , HDD led blink

Hello,

I am writting here to note crash when I use KDE under FireGLX 3d
acceleration. The crash appears randomly, I can
not identify the origin of this. I nether did
more than 30 minutes works. All activities stop
(even glxgears) only the mouse cursor can be moved.

The app. tester "glxgears" works but "fgl_glxgears" shows
problems as memory allocation etc..

In addition to this the LED of my third HDD blink
I do not know why (I did not access on it). On TWM manager
this strange blink does not appear.

Installing/building of 8.14.13 ATi driver success without problem
and module "fglrx" have been loaded correctly.

My configuration:
------------------
-Pentium4 2Ghz-MSI PT8Neo, 512MB
-POWERCOLOR DualHead 9600 RADEON ATi, 128MB, 400MHZ RAMDAC, AGP8x
-Slackware 10.1
-kernel-2.6.11.10: internal agpgart used, DRM checked as module. Headers
and source installed.

-KDE-3.4.1 for Slackware downloaded
from KDE site (aRts,kdelibs,kdebase,kdeaddons)
-Xorg 6.8.1: i486, fonts

Last edited by intmail; 08-04-2005 at 10:38 AM.
 
Old 08-20-2005, 04:22 PM   #2
Eternal_Newbie
Member
 
Registered: Jun 2005
Location: The Pudding Isles
Distribution: Slackware 13.37
Posts: 573

Rep: Reputation: 59
if fglrxgears, or whatever it is called shows problems then the fglrx ati drivers have not been compiled or installed or configured properly. Perhaps if you posted the error messages it gives someone could help more.

PS what does
fglrxinfo
give as the opengl vendor? It should be ATI, not Mesa if everything is right

Last edited by Eternal_Newbie; 08-20-2005 at 05:44 PM.
 
Old 08-26-2005, 05:35 AM   #3
intmail
LQ Newbie
 
Registered: Jul 2005
Posts: 24

Original Poster
Rep: Reputation: 15
The glxgears works fine. I think the crash is due to DMA problems. May be the mother board I use is newest chipset VIA 880 and VIA 8237 and linux kernel can not manage many DMA at time (drive, opengl, etc...).

The problem appears randomly under GNOME.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Using keyboard LED for HDD activity DropSig Linux - General 5 12-11-2008 10:53 PM
HDD Led always on!!! ivanvart Mandriva 12 05-31-2006 11:38 AM
HDD Led always on!!! ivanvart Linux - Hardware 2 06-10-2005 07:06 AM
Post-install: machine won't boot w/ Vector ...blink blink blink goes the cursor nethbar VectorLinux 3 03-17-2004 03:32 PM
Is a symlink suppose to blink? angmaya Linux - Newbie 5 10-18-2003 01:12 AM


All times are GMT -5. The time now is 05:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration