LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 06-03-2009, 09:48 PM   #1
pdgessler
LQ Newbie
 
Registered: Jun 2009
Location: Milwaukee, WI
Distribution: Ubuntu 9.04, Slackware 12
Posts: 8

Rep: Reputation: 0
nVidia Driver Install and x-org Configuration for Toshiba LCD TV


Hi all,

I'm working on setting up my Ubuntu system (Ubuntu 9.04 Desktop) and I'm having major troubles getting the resolution set properly. I'm sure that the monitor isn't reporting the EDID correctly, because I have problems even setting up multiple displays in Window.

However, I think there may be a driver issue as well, because if I use the default install driver, the LCD will run at 800x600. As soon as I switch out to either of the nVidia drivers recommended by the System> Administration> Hardware Drivers dialog, the OS will only recognize an odd resolution like 480x320, and the nVidia software is locked on to this resolution as well.

Here is the relevant info, if anything else is needed please let me know:

nVidia GeForce FX 5200
lspci: 01:00.0 VGA Compatible Controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)

2.6.28-11-generic kernel, Ubuntu 9.04 Desktop w/ GNOME

Toshiba 19LV505 LCD TV w/ DVD player
--connected to FX 5200 via VGA
--manual says it can do 1360x768 @ 60 Hz in PC mode

I've tried using both drivers through Synaptic as well as manually installing the driver from nVidia. Both yield the same results.

Any help would be greatly appreciated!!
 
Old 06-04-2009, 01:11 AM   #2
pdgessler
LQ Newbie
 
Registered: Jun 2009
Location: Milwaukee, WI
Distribution: Ubuntu 9.04, Slackware 12
Posts: 8

Original Poster
Rep: Reputation: 0
for reference:

paul@MEDIA:~$ sudo ddcprobe
vbe: VESA 3.0 detected.
oem: NVIDIA
vendor: NVIDIA Corporation
product: NV34 Board - p162-1nz Chip Rev
memory: 131072kb
mode: 640x400x256
mode: 640x480x256
mode: 800x600x16
mode: 800x600x256
mode: 1024x768x16
mode: 1024x768x256
mode: 1280x1024x16
mode: 1280x1024x256
mode: 80x60 (text)
mode: 132x25 (text)
mode: 132x43 (text)
mode: 132x50 (text)
mode: 132x60 (text)
mode: 320x200x64k
mode: 320x200x16m
mode: 640x480x64k
mode: 640x480x16m
mode: 800x600x64k
mode: 800x600x16m
mode: 1024x768x64k
mode: 1024x768x16m
mode: 1280x1024x64k
mode: 1280x1024x16m
edid:
edidfail
paul@MEDIA:~$

I'm thinking the 'edidfail' line is an obvious giveaway of the problem, but I can't figure out how to fix it -- is there a way to trick the config utility into reading a canned EDID configuration instead of the actual screen's output?
 
Old 06-04-2009, 02:22 AM   #3
deep kumar
LQ Newbie
 
Registered: Aug 2008
Posts: 7

Rep: Reputation: 0
solution

I think this is the hardware issue and driver problem and your system driver is not comfortable according your system os.And the same problem when you use the windows Plz check your system hardware and driver.
 
Old 06-04-2009, 11:02 AM   #4
pdgessler
LQ Newbie
 
Registered: Jun 2009
Location: Milwaukee, WI
Distribution: Ubuntu 9.04, Slackware 12
Posts: 8

Original Poster
Rep: Reputation: 0
I don't think it's truly a hardware support issue, I just think the EDID information is not being sent or read correctly. In Windows 7 (extended display from my laptop, connected via HDMI or VGA) it would originally only detect 1024x768 through the OS. I used the Windows nVidia Control Panel software to set the resolution at 1280x720 (I have an NVIDIA Quadro FX 570M card in my laptop) and that seems to work, although the software cannot recognize the supported resolutions, it simply shows the full range (all the way out to 1920x1080) and I must pick the max resolution that works.

Now, back to the desktop (with geForce FX 5200) which is now running Ubuntu 9.04 Desktop. Previously I had XP Media Center (the earlier one) installed and had the same dilemma, but installing the nVidia software and using that to set the resolution again worked fine, except for the problem described above with the resolution choices given by nVidia control panel.

So now that I have installed Ubuntu, why will the nVidia software not give me the full spectrum of resolutions as it did before? In fact, once the drivers are installed the only two options I have are 320x240 and 640x480! What is the significance of 'edidfail' in the ddcprobe output? Does that mean the monitor is not sending any information or just the wrong kind? Thanks in advance for any help.
 
Old 06-04-2009, 02:59 PM   #5
pdgessler
LQ Newbie
 
Registered: Jun 2009
Location: Milwaukee, WI
Distribution: Ubuntu 9.04, Slackware 12
Posts: 8

Original Poster
Rep: Reputation: 0
OK . . . quick update, maybe this will help.

I basically wrote my own xorg.conf file from bits and pieces of previous machine's codes and stuff I found on the net.

Now I can get to the login screen at widescreen native resolution, but as soon as I log in, the screen scrambles and goes blank.

Is there any reason why the modeline I created (see below) works for the login manager but not for the session itself?

ModeLine "1360x768" 85.500 1360 1424 1536 1792 768 771 777 795 +Hsync +Vsync
 
Old 06-04-2009, 03:08 PM   #6
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
Try this. Make a backup of what you have, first, of course. If the twinview lines conflict, delete them, or I can get you a copy off my other machine. Sync and refresh rates may need to be changed to match your monitor. Mouse device might need changes.


Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder63)  Wed Oct  1 15:10:25 PDT 2008

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "PTW PL916s"
    HorizSync       30.0 - 80.0
    VertRefresh     60.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7050 PV / NVIDIA nForce 630a"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "1024x768_70 +0+0; 1024x768_75 +0+0; 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
 
Old 06-04-2009, 04:14 PM   #7
pdgessler
LQ Newbie
 
Registered: Jun 2009
Location: Milwaukee, WI
Distribution: Ubuntu 9.04, Slackware 12
Posts: 8

Original Poster
Rep: Reputation: 0
existing setup

@Quakeboy02: Thanks for the info, now I know that most of my xorg.conf file is working correctly. What exactly do those metamodes lines do? I'm wondering if I need those in there somewhere for some reason. I'm still baffled that the GDM login manager displays beautifully and everything dies when I login. Anyway, here's my xorg.conf as it stands:

Code:
Section "ServerLayout"
  Identifier    "Layout0"
  Screen   0    "Screen0"
  InputDevice   "Keyboard0" "CoreKeyboard"
  InputDevice   "Mouse0" "CorePointer"
  Option        "OffTime" "15"
EndSection

Section "Files"
EndSection

Section "Module"
  Load  "dbe"
  Load  "extmod"
  Load  "glx"
EndSection

Section "InputDevice"
  Identifier  "Mouse0"
  Driver      "mouse"
  Option      "Protocol" "auto"
  Option      "Device" "/dev/psaux"
  Option      "Emulate3Buttons" "no"
  Option      "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
  Identifier  "Keyboard0"
  Driver      "kbd"
EndSection

Section "Monitor"
  Identifier  "Monitor0"
  VendorName  "Toshiba"
  ModelName   "19LV505"
  HorizSync   30.0 - 83.0
  VertRefresh 60.0 - 75.0
  Modeline    "1360x768" 85.500 1360 1424 1536 1792 768 771 777 795 $+Hsync +Vsync
  Option      "DPMS"
EndSection

Section "Device"
  Identifier  "Device0"
  Driver      "nvidia"
  VendorName  "NVIDIA Corporation"
EndSection

Section "Screen"
  Identifier   "Screen0"
  Device       "Device0"
  Monitor      "Monitor0"
  DefaultDepth 24
  SubSection   "Display"
    Depth      24
    Modes      "1360x768"
  EndSubSection
EndSection
If anyone has any info regarding the sync and refresh rates required for this panel, I'm pretty sure those are the problems now. When I log in, the screen scrambles briefly and then goes blank (to protect the hardware, I'm assuming) But, on the other hand, why did those rates work for GDM?? That's why I'm so confused.

Thanks again.
 
Old 06-04-2009, 08:37 PM   #8
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
Someone may correct me, but I don't think you need a modeline with modern x-servers. They're too restrictive, and hard to get right, because every single thing has to be correct, or at least workable, in the line. A metamode line, on the other hand, has only the bare minimum needed to tell X which resolution, what offset, and optionally the refresh rate. It's left to X (or perhaps the driver, I dunno) to figure out the rest. Try it or not, as you wish, but I can't help you further with your xorg.conf file.
 
Old 06-06-2009, 12:12 AM   #9
pdgessler
LQ Newbie
 
Registered: Jun 2009
Location: Milwaukee, WI
Distribution: Ubuntu 9.04, Slackware 12
Posts: 8

Original Poster
Rep: Reputation: 0
problem solved

Well, thanks for the advice again Quakeboy02, but I have everything figured out now. Turns out my modeline was just slightly off (^^point taken ), but I fixed it and now everything works wonderfully.
 
Old 06-29-2009, 10:21 PM   #10
rcortez
LQ Newbie
 
Registered: Jun 2009
Posts: 2

Rep: Reputation: 0
Having the same problem

Can you post the contents of your working xorg.conf file? I'm having the same problem. Logon screen looks fine, but blank screen after that.

Thanks

RC
 
Old 06-30-2009, 04:02 AM   #11
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
One other thing you can try is the "UseEDID" "FALSE" option:
http://us.download.nvidia.com/XFree8...ppendix-b.html
 
Old 07-01-2009, 01:40 PM   #12
pdgessler
LQ Newbie
 
Registered: Jun 2009
Location: Milwaukee, WI
Distribution: Ubuntu 9.04, Slackware 12
Posts: 8

Original Poster
Rep: Reputation: 0
Here it is, but you will need to change a few things based on your hardware and also create proper modelines. You can do this using a modeline generator.

( http://xtiming.sourceforge.net/cgi-bin/xtiming.pl )

Code:
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option 	   "OffTime" "15"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync	   40.0 - 70.0
    VertRefresh	   60.0 - 65.0
    ModeLine    "1280x720@60" 73.78 1280 1312 1592 1624 720 735 742 757
    ModeLine    "1360x768@60" 84.50 1360 1392 1712 1744 768 783 791 807
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option 	   "NoLogo" "true"
    Option 	   "ConnectedMonitor" "CRT"
    Option	   "UseEDID" "false"
    SubSection     "Display"
        Depth       24
	Modes	   "1360x768@60" "1280x720@60"
    EndSubSection
EndSection
 
Old 07-01-2009, 02:41 PM   #13
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
pdgessler, the utility gtf helps to make modelines, so going to a site to make a modeline is useless. The utility gtf should be included in your setup.

Quote:
Originally Posted by Quakeboy02 View Post
Someone may correct me, but I don't think you need a modeline with modern x-servers. They're too restrictive, and hard to get right, because every single thing has to be correct, or at least workable, in the line. A metamode line, on the other hand, has only the bare minimum needed to tell X which resolution, what offset, and optionally the refresh rate. It's left to X (or perhaps the driver, I dunno) to figure out the rest. Try it or not, as you wish, but I can't help you further with your xorg.conf file.
Incorrect, modelines tells X Window System to use certain settings with out trying to figure out all supported resolutions which will take a long time. Adding modelines makes X Window System start up faster, but it does double check modelines to make sure it is supported by the monitor. nVidia's metamode lines adds additional control how multiple monitors should be setup. Specifying modelines is the only way to provide control.

For any setup, I recommend including minimum and maximum specs for horizontal and vertical sync in the monitor section. By doing this, X Window System will start up faster and your setup becomes more reliable.
 
Old 07-02-2009, 01:38 PM   #14
pdgessler
LQ Newbie
 
Registered: Jun 2009
Location: Milwaukee, WI
Distribution: Ubuntu 9.04, Slackware 12
Posts: 8

Original Poster
Rep: Reputation: 0
I had not heard of gtf before, thanks for the info Electro. I only have experience with xrandr, which didn't work in this case since the monitor wasn't reporting it's information correctly in the first place.

@rcortez: I know that my xorg.conf is not very compact or elegant, and is probably redundant at some points, but this is where I got it to work and decided to stop messing with it. You can probably condense it further once you get to a workable file, but remember to back the working one up so you can revert if your efforts fail.
 
Old 07-02-2009, 07:46 PM   #15
rcortez
LQ Newbie
 
Registered: Jun 2009
Posts: 2

Rep: Reputation: 0
Working perfectly after a little adjustment in the UI

All of your tips helped including the modeline generator.

Screen was being chopped at the top and left side, with the 1360x768 option. So in Display Preferences changed Refresh rate to highest number shown 53 hz.

Thanks for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
x.org doesn't work with nvidia driver nflenz Debian 14 10-05-2006 08:04 AM
DISCUSSION: LCD/TFT Monitor Configuration in X.Org cathectic LinuxAnswers Discussion 10 04-24-2006 01:13 PM
Nvidia FX 5200 driver trouble with x.org 6.8.2 and 2.6.13.2 somedude Linux - Software 9 10-06-2005 06:21 PM
DVI to LCD does not work without nvidia Driver flysideways Fedora 4 03-23-2005 11:06 AM
Need to install LCD Monitor driver RMBrown2 General 4 01-31-2003 09:12 AM


All times are GMT -5. The time now is 05:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration