LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General > LinuxAnswers Discussion
User Name
Password
LinuxAnswers Discussion This forum is to discuss articles posted to LinuxAnswers.

Notices

Reply
 
Search this Thread
Old 02-09-2005, 01:15 PM   #1
cathectic
Member
 
Registered: Sep 2004
Location: UK, Europe
Distribution: Slackware64
Posts: 761

Rep: Reputation: 34
Post DISCUSSION: LCD/TFT Monitor Configuration in X.Org


This thread is to discuss the article titled: LCD/TFT Monitor Configuration in X.Org
 
Old 02-09-2005, 09:24 PM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
cathectic

Thanks for the article! I'm short on time to tweak
at the moment, but want to make a comment on
the brief reading I've done so far. You mention
Quote:
Plug up your LCD. Where possible, use the DVI-D
(i.e. The digital, not analogue VGA) connector.
IMO this should be clarified. Some LCD monitors, such
as my Philips 150B4, are not digital monitors. They come
with a regular VGA plug. However, here in China, they
also will either come with, or the store may give you,
a VGA to DVI adapter plug. This is not recommended,
and I'm not going into the technical reasons at this point,
but suffice it to say that it makes no difference for this
monitor in Linux; and in Windoze the quality suffers by
using this adapter. When I discussed this with the local
Philips distributor store (where I buy all my parts), they
told me it should give you a performance increase while
playing DVDs -- which it doesn't, either.

What is your experience, or knowledge, about this?
(I would have emailed or PMed you but you haven't
authorized either of those. If you'd like to open up
personal dialog please email me.)
 
Old 02-13-2005, 04:50 AM   #3
cathectic
Member
 
Registered: Sep 2004
Location: UK, Europe
Distribution: Slackware64
Posts: 761

Original Poster
Rep: Reputation: 34
(3rd time lucky, I've managed to keep accidentally closing Firefox every time I've finished writing this)

1) As a quick aside, just playing with Fluxbox now, it doesn't want to play nice straight away with the .fonts.conf changes. To make it pay attention, I had to enable anti aliasing in Fluxbox: 'fluxbox menu --> Configure --> AntiAlias' and then it fixed the menu fonts (although not all of them were fixed until restarting it after that). I do apologise, I hadn't tested my solution with other WMs in Slackware (besides KDE which I use, and Gnome from before).

2) You're right, of course. What I mean is that if you have a DVI-D connector on your graphics card, and a DVI-D connector on your monitor, then you should use those to connect the monitor to your card (If they have both connectors, the theory from some is that more work will have been put into building the digital one than the analogue one. Who knows? But if you can, use the DVI-D connectors & cables if and only if *both* the card and monitor have them). If you only have an analogue VGA connector on your monitor, then obviously use the VGA cables and connections (with adaptors, I can't imagine how an adapter from VGA --> DVI-D would make an 'improvement'? As a rule of thumb, I try to avoid adapters where possible.)
 
Old 02-17-2005, 12:08 PM   #4
xunil-nubee
LQ Newbie
 
Registered: Feb 2005
Location: San Antonio, Texas
Distribution: SuSe 8.2
Posts: 2

Rep: Reputation: 0
Nice Article, but I still need help- too green I'm sure

I just bought a Sony SDM-HS73 ----17inch monitor and hooked it up to Suse 8.2, looks great and everything works, but left side is 4 inches too far into virtual resolution. When I call things up they are always too far to the left and I can't see that side, so I have to move everything over first. It is like my computer thinks I bought a bigger monitor.

I have tried to adjust the virtual resolution, and the resolution and have checked just about everything.

Anyone out there feel like helping a Green Horn??

Thanks
 
Old 02-17-2005, 02:33 PM   #5
cathectic
Member
 
Registered: Sep 2004
Location: UK, Europe
Distribution: Slackware64
Posts: 761

Original Poster
Rep: Reputation: 34
You would probably be better asking this question in Hardware, the Answers discussions are only frequented by those discussing an article. (I remember looking at this as a potential monitor, but for that money, it doesn't even come with a DVI-D connection! The newer SDM-HS74 corrects this fairly obvious flaw and comes with both analogue and digital inputs.)

Off the top of my head, you could try setting "DisplaySize" under your monitor settings in /etc/X11/xorg.conf or /etc/X11/XFree86 (not sure of the exac name of the config file in XFree86) depending on which X server your distro uses:

DisplaySize <height> <width>

Where height and width are the size of your monitor display in millimetres (not inches or any bizarre fraction of inches)
 
Old 02-19-2005, 02:44 AM   #6
Bobenz
LQ Newbie
 
Registered: Feb 2005
Location: NZ
Distribution: Suse 9.2
Posts: 3

Rep: Reputation: 0
HI, interesting article... .. the article itself does not word wrap for me like other pages from this site. I have a CRT screen. Is this linked to your changes to fonts too?

cheers
 
Old 02-22-2005, 07:22 AM   #7
cathectic
Member
 
Registered: Sep 2004
Location: UK, Europe
Distribution: Slackware64
Posts: 761

Original Poster
Rep: Reputation: 34
It doesn't wrap here either, maybe because of how I copied and pasted it from OOo, or the width of the text in the code tags is throwing it off? But I'm using a different configuration to the one I posted (the configuration I give here is the best for using the Bitstream fonts. I'm going to redo it at some point to make this clear.)

(If you're using the Microsoft fonts, you should lift the LCD specific only parts, and then follow the instructions given in other tutorials for installing the MS fonts and enabling the bytecode interpreter in FreeType.)

I wouldn't imagine that the changes in it are responsible for the incorrect word wrapping. All that the changes do is tell FreeType how to render the fonts, nothing to do with my poor text formatting.

Also, as you have a CRT, I don't reccommend using this configuration on it.
 
Old 05-22-2005, 09:24 AM   #8
Croaker
Member
 
Registered: Sep 2004
Location: Oklahoma City, OK
Distribution: Slackware 12.1
Posts: 41

Rep: Reputation: 15
I just copied and pasted the script into a OO .text file, then opened and saved it as .fonts.conf using mc. I left the script as is and it's made a pretty big difference. There were a few websites (Notably Yahoo.com) where the fonts didn't look quite right. Now it looks much better. Thanks.

The hardware I'm using is a ViewSonic VP201s LCD monitor attached to a nVidia GeForce 6800 GT with the DVI-D cable. Screen resolution is 1280x1024

Last edited by Croaker; 05-22-2005 at 09:27 AM.
 
Old 09-15-2005, 10:53 PM   #9
TheKougar
LQ Newbie
 
Registered: Sep 2005
Posts: 1

Rep: Reputation: 0
I've gone through this and tried a few other things as well. I cannot get the 'font substitution' to work.

I still had to go to the KDE control pannel and the settigns for each app to change from Helvitica to Sans Serif.

Does KDE over-ride the fonts subsystem somehow?
 
Old 09-25-2005, 06:44 AM   #10
cathectic
Member
 
Registered: Sep 2004
Location: UK, Europe
Distribution: Slackware64
Posts: 761

Original Poster
Rep: Reputation: 34
The Kougar
Yes, KDE seems to ignore font type related settings in .fonts.conf, you have to set its fonts manually in Control Centre (this doesn't apply to the other parts of the tutorial though) - although I found that once it was set in Control Centre, I didn't need to set the individual applications.

--

Due to not being able to update the LQ.org Answer page, I maintain a more up-to-date version of this tutorial at slackwiki.org

It also contains the alternative way to get better fonts, which is to use the MS fonts plus rebuilding FreeType to include the bytecode interpreter.
 
Old 04-24-2006, 01:13 PM   #11
bobbens
Member
 
Registered: Sep 2004
Location: Barcelona
Distribution: Debian, FreeBSD, Gentoo
Posts: 586

Rep: Reputation: 30
Is it me or does it seem like the code part is missing? did it get eaten in the html/php? Don't remember what it's supposed to look like exactly but i see the xml in the code...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.1 and TFT monitor ronronson Linux - Hardware 4 11-27-2004 07:12 PM
TFT Monitor Problem Paul Mon Linux - General 3 09-22-2003 11:19 AM
NEC LCD Monitor Configuration Issue kmjung Linux - Hardware 3 08-05-2003 10:14 AM
Driver for Sony SDM-S91 TFT LCD display pnosko Linux - Hardware 4 07-23-2003 12:08 AM
TFT Monitor - Cant See Anything tgonetwork Linux - Newbie 19 02-09-2002 06:14 AM


All times are GMT -5. The time now is 12:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration