LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 08-01-2004, 10:30 AM   #1
jrbiochem
Member
 
Registered: Apr 2004
Location: Dundee, Scotland
Distribution: Fedora Core 2
Posts: 57

Rep: Reputation: 15
Need to run system-config-sound after every boot too make sound work in FC2


Hi All,

Having just upgraded from FC1 to FC2 and worked through the many niggles it causes, I'm down to just one. To make my soundcard work, I have to run the system-config-soundcard utility at the beginning of every session. Can anyone suggest how to make the configuration permanent?

I've got an integrated soundcard on an NVidia nForce2 DDR socket A mainboard (NF24-ALH). The alsa drivers ARE installed, but I haven't done any manual configuration since the upgrade.

Appreciate any pointers,

Thanks,

Jon
 
Old 08-01-2004, 11:03 AM   #2
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix, 98,2000 + various
Posts: 3,171

Rep: Reputation: 51
add it to the end of /etc/rc.d/rc.local
if that file exists. that might do it.
 
Old 08-01-2004, 12:52 PM   #3
syd
LQ Newbie
 
Registered: Aug 2003
Distribution: Ubuntu 8.04
Posts: 7

Rep: Reputation: 0
Here's how I did it

Here are the relevant lines from my /etc/modprobe.conf:

Code:
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-sbawe
# module options can go here
                                                                                                            
# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
                                                                                                            
# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
                                                                                                            
install snd-sbawe /sbin/modprobe --ignore-install snd-sbawe && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-sbawe { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-sbawe
You would replace all instances of snd-sbawe (i have an old isa sb awe) with whatever the driver name is for your soundcard.

This allows the card to start up automatically and saves the settings (volume etc) during reboot. Seems to work ok for me.
 
Old 08-01-2004, 01:32 PM   #4
MobyTurbo
Member
 
Registered: May 2002
Location: Brooklyn, NY
Distribution: Slackware
Posts: 45

Rep: Reputation: 15
I don't use FC2, I use Slackware, but in slackware you can change the sound settings with alsamixer and save them (as root) with "alsactl store". If FC2 has alsactl you might want to try this.
 
Old 08-01-2004, 02:42 PM   #5
jrbiochem
Member
 
Registered: Apr 2004
Location: Dundee, Scotland
Distribution: Fedora Core 2
Posts: 57

Original Poster
Rep: Reputation: 15
Thanks to all for your replies,

MobyTurbo : Tried your idea, no change

Syd: Had a look at my version of the file:

# Note: for use under 2.4, changes must also be made to modules.conf!
alias usb-controller ohci-hcd
alias usb-controller1 ehci-hcd
alias eth0 nvnet
alias usb-interface usb-ohci
alias snd-card-0 snd-intel8x0
alias char-major-195-* nvidia
install sound-slot-0 /sbin/modprobe --first-time --ignore-install sound-slot-0 && { /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :; }
remove sound-slot-0 { /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :; } ; /sbin/modprobe -r --first-time --ignore-remove sound-slot-0
alias /dev/ttySHCF[0-9]* /dev/ttySHCF
alias /dev/modem /dev/ttySHCF
alias char-major-240 /dev/ttySHCF
alias char-major-240-* /dev/ttySHCF
options hcfpciserial serialmajor=240
alias /dev/hcfpcidiag hcfpciosspec
alias /dev/hcfpcidiag* /dev/hcfpcidiag
alias char-major-242 /dev/hcfpcidiag
alias char-major-242-* /dev/hcfpcidiag
options hcfpciosspec diagmajor=242
install /dev/ttySHCF /sbin/modprobe hcfpcihw

My sound driver is snd-intel8x0. So I should add your alias-soundservice lines?

Whansard: I think your option will just bring up the configuration dialog at every boot won't it?

Thanks again,

Jon
 
Old 08-01-2004, 02:56 PM   #6
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix, 98,2000 + various
Posts: 3,171

Rep: Reputation: 51
i didn't know it was a dialog config. sorry. i'll have some new distros on my computer soon, and i'll get caught up on the changes over the past few years.
 
Old 08-01-2004, 07:18 PM   #7
Fredde84
LQ Newbie
 
Registered: Jul 2004
Location: Bollnäs, Sweden
Distribution: Slacware 10
Posts: 3

Rep: Reputation: 0
I had a similar problem once. I don't think it's the drivers. What you need to do is to make an empty file called asound.state in /etc and then adjust your settings as you wish. Then run alsactl and reboot. worked for me. The problem is that for some strange reason asound.state doesn't exist so it has nowhere to store the settings
 
Old 08-01-2004, 08:16 PM   #8
jrbiochem
Member
 
Registered: Apr 2004
Location: Dundee, Scotland
Distribution: Fedora Core 2
Posts: 57

Original Poster
Rep: Reputation: 15
Hi Fredde,

Thanks for the reply- but no, the file does exist. Though maybe I'll try deleting it and replacing it with a blank- perhaps it's remembering some wrong settings or something.......

J
 
Old 08-01-2004, 09:35 PM   #9
syd
LQ Newbie
 
Registered: Aug 2003
Distribution: Ubuntu 8.04
Posts: 7

Rep: Reputation: 0
Quote:
Originally posted by jrbiochem
Thanks to all for your replies,

MobyTurbo : Tried your idea, no change

Syd: Had a look at my version of the file:

Jon
I think you should try adding the lines, yes. I think if you run into any trouble you could set the system to boot into runlevel 3 and do interactive bootup so that you can individually load modprobe.conf lines.

I think it will work, though. As long as you replace sb-awe with your driver.
 
Old 08-01-2004, 10:58 PM   #10
jsutton
Member
 
Registered: Nov 2003
Location: Greenville, SC, USA
Distribution: (K)ubuntu 5.04 / Fedora 4
Posts: 113

Rep: Reputation: 15
Quote:
Originally posted by whansard
add it to the end of /etc/rc.d/rc.local
if that file exists. that might do it.
whansard has a good idea. You need to use a different command though. Infact, I had the same problem when I first did the FC1->FC2 upgrade. At the time, I was using a CT5880 (aka, one of the later versions of the Sound Blaster 16 PCI). It used the snd-ens1371 driver. So, all I did was add 'modprobe snd-ens1371' to my /etc/rc.d/rc.local. Your card is obviously going to use a different driver, but the same idea may work; try adding 'modprobe [kernel sound module]' to your rc.local file and see if that takes care of it (making sure to replace '[kernel sound module]' with the kernel module appropriate for your sound card).
 
Old 08-02-2004, 11:25 AM   #11
linuxmankev
LQ Newbie
 
Registered: Jan 2004
Distribution: Debian,Red Hat,Fedora
Posts: 10

Rep: Reputation: 0
The preferred and proper way is the /etc/modprobe.conf way (assuming you are running FC2's 2.6 kernel).

alias snd-card-0 snd-ymfpci
install snd-ymfpci /sbin/modprobe --ignore-install snd-ymfpci && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-ymfpci { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-ymfpci

This is for my laptop sound card (Yamaha).

You'd do

alias snd-card-0 snd-intel8x0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0


The /etc/modprobe.conf isn't some hack - it's *the* way of doing this to tell you kernel what module to load for your soundcard.

After editing that file run

modprobe -a

And that should load the sound card for your session (the command isn't needed on subsequent reboots as the rc scripts do this for you).

Kev
 
Old 08-04-2004, 07:08 AM   #12
jrbiochem
Member
 
Registered: Apr 2004
Location: Dundee, Scotland
Distribution: Fedora Core 2
Posts: 57

Original Poster
Rep: Reputation: 15
Hi everyone,

Sorry for being slow getting back; writing my thesis!

Have tried all the suggestions, and there's no change in the situation- I have some more head- scratching to do!

Thanks anyway,

jon
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound card won't work unless I do a soundcard detection in FC2 jonlake Linux - Hardware 2 09-07-2005 10:07 AM
can't make sound work! bluetwist Debian 3 07-28-2005 01:45 AM
How to make sound work? lele Arch 10 11-25-2004 05:10 AM
No More Sound In FC2; Use to Work! 07mackenzie Fedora 4 10-17-2004 02:40 PM
sound quirk: work but only after config leiavoia Linux - Newbie 2 04-03-2002 07:48 PM


All times are GMT -5. The time now is 12:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration