LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-26-2007, 05:57 PM   #1
cdrom600
Member
 
Registered: Oct 2003
Location: MI, USA
Distribution: Fedora, Ubuntu, Debian
Posts: 63

Rep: Reputation: 15
Question Configuring Realtek ALC883 onboard audio?


I am running Debian etch, and I'm trying to get my onboard audio working. Specifically, I need to get the onboard digital S/PDIF output working (the onboard A/D converter is absolute crap, so I take the digital out and run it into a decent receiver).

The motherboard is an ECS nForce 570 SLIT-A (V5.1). It has a Realtek HD ALC883 onboard audio chipset. (I'm not sure if this has anything to do with digital output; I'm assuming it does.)

I've downloaded and installed the software from this Realtek page, but it hasn't worked. When I double-click the (disabled) volume control icon in my Gnome desktop, I get the error message "No volume control GStreamer plugins and/or devices found."

I don't know where to go from here or where to start. I'm not even sure how to tell for sure when it's installed and working properly.

Below, I've included the output from lspci and uname -r.

Thanks.

---
lspci:
Code:
00:00.0 Host bridge: nVidia Corporation Unknown device 0071 (rev a3)
00:00.1 RAM memory: nVidia Corporation Unknown device 007f (rev a1)
00:00.2 RAM memory: nVidia Corporation Unknown device 0075 (rev a1)
00:00.3 RAM memory: nVidia Corporation Unknown device 006f (rev a1)
00:00.4 RAM memory: nVidia Corporation Unknown device 00b4 (rev a1)
00:01.0 RAM memory: nVidia Corporation Unknown device 0076 (rev a1)
00:01.1 RAM memory: nVidia Corporation Unknown device 0078 (rev a1)
00:01.2 RAM memory: nVidia Corporation Unknown device 0079 (rev a1)
00:01.3 RAM memory: nVidia Corporation Unknown device 007a (rev a1)
00:01.4 RAM memory: nVidia Corporation Unknown device 007b (rev a1)
00:01.5 RAM memory: nVidia Corporation Unknown device 007c (rev a1)
00:01.6 RAM memory: nVidia Corporation Unknown device 007d (rev a1)
00:02.0 PCI bridge: nVidia Corporation Unknown device 007e (rev a2)
00:04.0 PCI bridge: nVidia Corporation Unknown device 007e (rev a2)
00:05.0 PCI bridge: nVidia Corporation Unknown device 007e (rev a2)
00:06.0 PCI bridge: nVidia Corporation Unknown device 007e (rev a2)
00:07.0 PCI bridge: nVidia Corporation Unknown device 007e (rev a2)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a2)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a2)
00:0a.2 RAM memory: nVidia Corporation MCP51 Memory Controller 0 (rev a2)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a2)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a2)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev a1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:0f.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a1)
01:00.0 VGA compatible controller: nVidia Corporation NV44 [GeForce 6200 TurboCache(TM)] (rev a1)
06:06.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller  (rev 61)
06:06.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller  (rev 61)
06:06.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 63)
06:07.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller ( rev 80)
uname -r
Code:
2.6.17-2-686
 
Old 01-27-2007, 03:25 PM   #2
cdrom600
Member
 
Registered: Oct 2003
Location: MI, USA
Distribution: Fedora, Ubuntu, Debian
Posts: 63

Original Poster
Rep: Reputation: 15
This issue has been resolved.

Last edited by cdrom600; 02-23-2007 at 07:10 PM.
 
Old 01-27-2007, 03:34 PM   #3
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
Did you get it fixed? If so, it would be nice for the next guy if you could post what you did.
 
Old 01-29-2007, 05:46 PM   #4
cdrom600
Member
 
Registered: Oct 2003
Location: MI, USA
Distribution: Fedora, Ubuntu, Debian
Posts: 63

Original Poster
Rep: Reputation: 15
It turned out to be mainly user error - I'd downloaded the wrong source archive from that Realtek page. I needed the 'others' archive. Once I got it to compile, everything worked.
 
Old 04-23-2007, 10:32 AM   #5
yiux
LQ Newbie
 
Registered: Jan 2007
Location: Mauritius
Distribution: Debian 4.0R0
Posts: 11

Rep: Reputation: 0
Am running Debian linux 4.0R0 (etch)
There was no problem with sound at start. As from today i don't get sound when i start my computer. I have to run esd as root for sound to be played!!

when i double click on the volume control on the top left of the screen this error message appears:

No volume control GStreamer plugins and/or devices found.

The output of lspci is as follows:
Quote:
00:00.0 Host bridge: Intel Corporation 82845 845 (Brookdale) Chipset Host Bridge (rev 11)
00:01.0 PCI bridge: Intel Corporation 82845 845 (Brookdale) Chipset AGP Bridge (rev 11)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 82)
00:1f.0 ISA bridge: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801DB (ICH4) IDE Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 02)
01:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
01:05.0 Communication controller: Conexant HSF 56k HSFi Modem (rev 01)
01:06.0 Communication controller: Motorola Wildcard X100P
02:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 PRO] (rev 01)
02:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200 PRO] (Secondary) (rev 01)
Can someone help me to restore my sound back without running esd each time i login or without reformating.

Last edited by yiux; 04-23-2007 at 10:33 AM.
 
Old 03-12-2010, 08:10 AM   #6
chaitanya.kodag
LQ Newbie
 
Registered: Feb 2010
Posts: 5

Rep: Reputation: 0
Question i also got same problem as u had for alc883

Quote:
Originally Posted by cdrom600 View Post
This issue has been resolved.
plz can u tell me what did u do to solve this prob...

i m usin red hat 9 shrike 2.4

have realtek sound on board chip..... what to do ?plz tell me url for driver download for same

thank u!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help needed: Configuring sound card: REALTEK AC97 Audio Estel Elessar Linux - Hardware 13 11-02-2014 12:12 AM
GA-7VAX Onboard Audio (Realtek ALC650) needs to be setup again each boot! philipm Linux - Hardware 5 01-30-2006 02:09 AM
Realtek ALC650 onboard sound Hertzsprung Linux - Hardware 3 10-21-2003 11:05 AM
Issues with onboard AC'97 Realtek audio Riley Linux - Hardware 2 02-16-2003 04:45 PM
Realtek Onboard and Soundcard trouble SirKalten Linux - Networking 0 02-14-2002 10:09 PM


All times are GMT -5. The time now is 12:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration