LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-03-2006, 12:35 PM   #1
UnrealX
Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Ubuntu, CentOS
Posts: 36

Rep: Reputation: 15
Can`t get ATI IXP soundcard to work


I`m using arch linux 0.71 pre1, everything -current.
Got laptop with integrated ATI IXP 400 soundcard, however I just can`t get it working.
I was googling/reading forums/asking ppl for help on IRC for past few days, did everything they said, but still no sound.
Recompiled kernel (2.6.14.5) with ALSA/OSS compiled in and compiled as modules, recompiled alsa following alsa manual page for atiixp soundcards, changed cables, speakers, tried switching outs, ran alsaconf and alsamixer millions of times.

# dmesg | grep -i ati
Quote:
ACPI: FADT (v001 ATI Piranha 0x06040000 ATI 0x000f4240) @ 0x1fea4e20
ACPI: DSDT (v001 ATI SB400 0x06040000 MSFT 0x0100000e) @ 0x00000000
Using ACPI for processor (LAPIC) configuration information
Intel MultiProcessor Specification v1.4
Virtual Wire compatibility mode.
Allocating PCI resources starting at 30000000 (gap: 20000000:c0000000)
Calibrating delay using timer specific routine.. 3587.76 BogoMIPS (lpj=7175533)
ATIIXP: IDE controller at PCI slot 0000:00:14.1
ATIIXP: chipset revision 0
ATIIXP: not 100% native mode: will probe irqs later
Failed initialization of WD-7000 SCSI card!
Copyright (c) 1999-2005 LSI Logic Corporation
fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
autonegotiation: yes
irq moderation: disabled
# less /var/log/messages.log | grep -i ati
returns the same output

# lsmod | grep -i ati
Quote:
rsrc_nonstatic 12544 1 yenta_socket
pcmcia_core 37912 2 yenta_socket,rsrc_nonstatic
snd_atiixp 18016 4
snd_ac97_codec 95868 1 snd_atiixp
snd_pcm 84868 4 snd_atiixp,snd_ac97_codec,snd_pcm_oss
snd_page_alloc 9096 2 snd_atiixp,snd_pcm
snd 49764 10 snd_atiixp,snd_ac97_codec,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
ati_agp 7692 0
agpgart 30416 2 ati_agp,fglrx
atiixp 5776 0 [permanent]
ide_core 119760 28 usb_storage,ide_floppy,ide_cd,ide_disk,via82cxxx,trm290,triflex,slc90e66,sis5513,siimage,serverworks ,sc1200,rz1000,piix,pdc202xx_old,pdc202xx_new,ns87415,it821x,hpt366,hpt34x,generic,cy82c693,cs5530,c md64x,atiixp,amd74xx,alim15x3,aec62xx
# lshwd | grep -i audio
Quote:
00:14.5 Multimedia audio controller: ATI Technologies Inc.|IXP400 AC'97 Audio Controller (snd-atiixp)
# lspci | grep -i audio
Quote:
00:14.5 Multimedia audio controller: ATI Technologies Inc: Unknown device 4370 (rev 02)
# cat /dev/urandom > /dev/dsp
Quote:
bash: /dev/dsp: Device or resource busy
# fuser /dev/dsp
Quote:
/dev/dsp:
# less /proc/asound/cards
Quote:
0 [IXP ]: ATIIXP - ATI IXP
ATI IXP rev 2 with AD1981B at 0xc0503400, irq 11
# less /proc/asound/version
Quote:
Advanced Linux Sound Architecture Driver Version 1.0.10rc1 (Mon Sep 12 08:13:09 2005 UTC).

ANY suggestions? Will try everything.

Last edited by UnrealX; 01-03-2006 at 01:40 PM.
 
Old 01-03-2006, 02:04 PM   #2
mimithebrain
Member
 
Registered: Nov 2003
Location: ~
Distribution: Ubuntu 10.04
Posts: 843
Blog Entries: 1

Rep: Reputation: 30
I have atiixp.

External amplifier needs to be turned on. I use modularized atiixp ALSA drivers (modprobe snd-atiixp)

Check if arts is blocking the sound by any chance, disable arts, (or esound, or whatever sound server is there) and try to play some music using aplay, in the console without having any other applications running.

I load only atiixp, and not that extra modules you are loading.

Try building in the alsa drivers, maybe I'll do a difference.
 
Old 01-03-2006, 02:32 PM   #3
UnrealX
Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Ubuntu, CentOS
Posts: 36

Original Poster
Rep: Reputation: 15
Quote:
External amplifier needs to be turned on.
What`s that?

Quote:
Check if arts is blocking the sound by any chance, disable arts, (or esound, or whatever sound server is there) and try to play some music using aplay, in the console without having any other applications running.
Tried using aplay without running X or anything. No result.

Quote:
I load only atiixp, and not that extra modules you are loading.
Um what extra modules? =/
 
Old 01-03-2006, 04:00 PM   #4
UnrealX
Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Ubuntu, CentOS
Posts: 36

Original Poster
Rep: Reputation: 15
Almost got it.
Accidently i went on this page:
sourceforge.net/mailarchive/forum.php?thread_id=8072079&forum_id=1752
(sorry for url)
It seems that my speakers also work, but super-silently. I had to increase volume to -OdB to hear something.
As I understand so far I have to somehow ,,send the magic string 7a 2090 into /proc/asound/card0/codec97#0/ac97#0-0+regs".
The question is: how. When I try to edit this file with any known editor I get an error complaining ,,There`s no such device" or whatever.
 
Old 01-03-2006, 05:58 PM   #5
UnrealX
Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Ubuntu, CentOS
Posts: 36

Original Poster
Rep: Reputation: 15
Recompiled kernel and alsa with full debug support, it seems now i can edit needed file.
I found this alsa bug:
https://bugtrack.alsa-project.org/al...ew.php?id=1274
There`s temporary solution there. However when I try to apply it i get all values `ffff`.
How come? Help me with this.
 
Old 01-03-2006, 06:47 PM   #6
mimithebrain
Member
 
Registered: Nov 2003
Location: ~
Distribution: Ubuntu 10.04
Posts: 843
Blog Entries: 1

Rep: Reputation: 30
snd_ac97_codec
snd_pcm
snd_pcm_oss
snd_page_alloc
snd_mixer_oss

I never needed that, I don't see what they are useful for. As far as dB goes... what? When my card starts up, the values are always the same (manually, without alsasound script in gentoo), master is muted, and at 0, PCM muted, at 0, mic's left side is 100, while the other is at 0. alsasound restores the mixer settings automatically.

External amplifier is a switch that you need to unmute like you would unmute master, and PCM, it's the last device shown in alsamixer actually.


Third, you can't edit a "magic" file with nano or emacs, you need to use the echo command and some bash. Your command translates into:

echo "7a 2090" > /proc/asound/card0/codec97#0/ac97#0-0+regs
(filenames with "#" sign, are you sure?)
 
Old 01-04-2006, 04:58 AM   #7
UnrealX
Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Ubuntu, CentOS
Posts: 36

Original Poster
Rep: Reputation: 15
It`s really not a problem with alsamixer, everything`s unmuted and on 100% here. It`s alsa bug.

Quote:
# echo "7a 2090" > /proc/asound/card0/codec97#0/ac97#0-0+regs
# less ac97#0-0+regs | grep 7a
0:7a = ffff
I`m lost.
 
Old 01-04-2006, 10:22 AM   #8
mimithebrain
Member
 
Registered: Nov 2003
Location: ~
Distribution: Ubuntu 10.04
Posts: 843
Blog Entries: 1

Rep: Reputation: 30
There is currently two threads on this subject, one here, and the other at the ALSA bug website.

I want to comment that I'm using 2.6.12-r10 and having no problems, sound works out of the box. But I'll be interested in finding how you boost the sound...
 
Old 01-06-2006, 06:29 AM   #9
UnrealX
Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Ubuntu, CentOS
Posts: 36

Original Poster
Rep: Reputation: 15
Could you post your /etc/asound.state and /proc/asound/card0/codec97#0/ac97#0-0+regs ?
 
Old 01-06-2006, 09:37 AM   #10
mimithebrain
Member
 
Registered: Nov 2003
Location: ~
Distribution: Ubuntu 10.04
Posts: 843
Blog Entries: 1

Rep: Reputation: 30
http://mimi.bcdynamic.com/linux/asound.state

regs:
0:00 = 0190
0:02 = 0e0e
0:04 = 8a0a
0:06 = 801f
0:08 = 0000
0:0a = 801e
0:0c = 801f
0:0e = 831f
0:10 = 9f1f
0:12 = 0303
0:14 = 0000
0:16 = 9f1f
0:18 = 0707
0:1a = 0000
0:1c = 0000
0:1e = 0000
0:20 = 0000
0:22 = 0000
0:24 = 0000
0:26 = 000f
0:28 = 0a07
0:2a = 0411
0:2c = bb80
0:2e = 0000
0:30 = 0000
0:32 = bb80
0:34 = bb80
0:36 = 0000
0:38 = 0000
0:3a = 2824
0:3c = 0000
0:3e = 0000
0:40 = 0000
0:42 = 0000
0:44 = 0000
0:46 = 0000
0:48 = 0000
0:4a = 0000
0:4c = 0000
0:4e = 0000
0:50 = 0000
0:52 = 0000
0:54 = 0000
0:56 = 0000
0:58 = 0000
0:5a = 0000
0:5c = 0000
0:5e = 0000
0:60 = 0000
0:62 = 0000
0:64 = 0000
0:66 = 0000
0:68 = 0aea
0:6a = 4400
0:6c = 4601
0:6e = 0015
0:70 = 0008
0:72 = 0000
0:74 = 0100
0:76 = 0304
0:78 = 0803
0:7a = 6000
0:7c = 414c
0:7e = 4752

This is a bit loud for values actually, you might want to adjust them.
 
Old 01-06-2006, 09:40 AM   #11
UnrealX
Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Ubuntu, CentOS
Posts: 36

Original Poster
Rep: Reputation: 15
Thanks, going to compare these with my values, will post how is it going.
 
Old 01-07-2006, 03:44 AM   #12
vitja
LQ Newbie
 
Registered: Jan 2006
Posts: 1

Rep: Reputation: 0
Hi! If the problem still exist, I could try to help you. vitja@jabber.ru
 
Old 01-07-2006, 12:03 PM   #13
mimithebrain
Member
 
Registered: Nov 2003
Location: ~
Distribution: Ubuntu 10.04
Posts: 843
Blog Entries: 1

Rep: Reputation: 30
even better vitja, if you can stick around to fix it so the others can know how you made it work, all the better...

The outside world doesn't have access to your mail/chat logs.
 
Old 01-07-2006, 01:40 PM   #14
UnrealX
Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Ubuntu, CentOS
Posts: 36

Original Poster
Rep: Reputation: 15
Thanks vitja, I will email you just after I post this post.

Mimithebrain > If I`ll fix my soundcard I`ll definetly post the solution here.

EDIT: vitja, it seems that your email provider is malfunctioning. Both my email addressess got rejected.
Please catch me on:
MSN: unrealx at gmail dot com
ICQ: 250868777
or on the worst case (I don`t check it very often)
IRC: chat.freenode.net (nick UnrealX)

Last edited by UnrealX; 01-07-2006 at 02:02 PM.
 
Old 01-08-2006, 09:54 AM   #15
UnrealX
Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Ubuntu, CentOS
Posts: 36

Original Poster
Rep: Reputation: 15
Huh, just ran alsaconf && alsamixer again, disabled external amplifier and everything is fine.
Just as i started getting into desperate mood.
Wierd.

Thanks for support everybody!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4 ALSA on SPDIF device w/Shuttle ATI IXP muppetmaster Fedora 1 11-01-2005 04:30 AM
Problem with ATI-IXP sound card and resolutions over 1024x768 in SUSE 9.1 Jessica9 Linux - Hardware 0 05-29-2005 06:12 AM
Serious problems with ATI IXP and SuSE 9.1 stuartnoble Linux - Hardware 11 10-08-2004 08:15 AM
ATI IXP: No sound since kernel 2.6.7 ? gundelgauk Linux - Hardware 2 09-19-2004 12:11 AM
Trouble with ATI IXP on HP/Compaq nx9110 dilandach Linux - Laptop and Netbook 1 08-18-2004 12:27 PM


All times are GMT -5. The time now is 03:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration