LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-08-2005, 04:08 PM   #1
Arturo007
LQ Newbie
 
Registered: Oct 2005
Location: Madrid-Spain
Posts: 3

Rep: Reputation: 0
Question Background noise while playing audio files


Hello everyone, i have a problem with mi soundcard. I have FC4 installed in a vaio vgn-fs570. When i play any audio file or cd or dvd, i hear a very anoing background noise. In windows xp works fine. I already tried the command "append=no-hlt", it helped but not enough. I read somwhere that diable the iec958 function fixes that problem but i cannot find that opton in gnome alsamixer. Here i show my /sbin/lspci file:

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:1b.0 Class 0403: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 04)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 04)00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 04)
06:03.0 CardBus bridge: Texas Instruments PCI7420 CardBus Controller
06:03.2 FireWire (IEEE 1394): Texas Instruments PCI7x20 1394a-2000 OHCI Two-Port PHY/Link-Layer Controller
06:03.3 Unknown mass storage controller: Texas Instruments PCI7420/PCI7620 Dual Socket CardBus and Smart Card Cont. w/ 1394a-2000 OHCI Two-Port PHY/Link-Layer Cont. an
06:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG (rev 05)
06:08.0 Ethernet controller: Intel Corporation 82562ET/EZ/GT/GZ - PRO/100 VE (LOM) Ethernet Controller Mobile (rev 04)

I hope somebody help me, thx in advance
 
Old 10-10-2005, 07:56 PM   #2
NomadX
Member
 
Registered: Jul 2005
Location: Portland, OR
Distribution: Debian Testing
Posts: 78

Rep: Reputation: 15
Don't know anything about it, but having suffered through the same problem with my completely different setup, I found that the line-in and mic inputs where on and that even tho they werent connected to anything, they caused noise... You might try something different instead of alsa too... esd, or even OSS if that card is supported.. tho Alsa works best for me and most people too that I've heard...

Good Luck,
DrS
 
Old 10-12-2005, 05:48 PM   #3
Arturo007
LQ Newbie
 
Registered: Oct 2005
Location: Madrid-Spain
Posts: 3

Original Poster
Rep: Reputation: 0
Finally is working well. Thanks for the replay, i am using oss mixer instead of alsa. What i did is that:
First, oss (not alsa emulation) is not supported by my soundcard in fc4 orginal kernel, so downloded the last version in http://www.opensound.com/ossapps.html.
Before installing the that version of ossmixer, i disable the alsa and oss support of the kernel, so i had to recompile it. Thats because i had conflicts problems while alsa and the last version of ossmixer when the both were installed at the same time.
Finally i installed the last version of ossmixer, reboot and the configure it with ossxmixer.
Well i hope it helps to anyone, cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Playing rm Real Audio files? phlyersphan Linux - Software 7 08-23-2004 02:12 PM
Playing Audio Files in Redhat 7.2 newbie2linux Linux - Newbie 2 12-04-2003 03:52 PM
Annoying background noise when playing mp3s kadaver Slackware 2 11-20-2003 04:15 PM
Playing 2 audio files simulatanously with Alsa dnar Linux - Software 5 05-26-2003 08:00 AM
playing real audio files gadhiraju Linux - General 2 09-04-2001 05:36 AM


All times are GMT -5. The time now is 03:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration