LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-17-2006, 08:53 PM   #1
timothee
LQ Newbie
 
Registered: Jan 2005
Location: Singapore
Distribution: Gentoo / Mepis
Posts: 10

Rep: Reputation: 0
ATI driver installs OK not working


Hi All,

I have installed the ATI drivers based on the how-to on gentoo-wiki. It seems the installation went fine but the openGL screensavers are not working (under kde-3.5.2). My system is gentoo 2006.0/kernel 2.6.16/X11-xorg-6.8.2

After install, the output of fglrxinfo looks good:
Code:
# /opt/ati/bin/fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X300/X550 Series Generic
OpenGL version string: 2.0.5755 (8.24.8)
There are however a few warnings in the X11 log but I don't know what to do with them:
Code:
# grep -e EE -e WW Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) The directory "/usr/share/fonts/CID/" does not exist.
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) Loading extension MIT-SCREEN-SAVER
(WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
(WW) fglrx(0): Specified desktop setup not supported: 8
(WW) fglrx(0): [drm] using DRM defaults (QS_ID=99000000)
I don't understand why the BusID shows 1:0:1 in the warnings because my xorg.conf only references 1:0:0. Below are some portions of xorg.conf :
Code:
Section "Device"
        Identifier  "ATI Graphics Adapter 0"
        Driver      "fglrx"
        VendorName  "ATI Technologies Inc"
        BusID       "PCI:1:0:0"
EndSection

Section "Module"
        Load  "extmod"
        Load  "dri"
        Load  "dbe"
        Load  "record"
        Load  "xtrap"
        Load  "glx"
        Load  "type1"
        Load  "freetype"
EndSection

Section "DRI"
        Mode         0666
EndSection
In case this is useful, lspci returns the following for the card:
Code:
# lspci
...
01:00.0 VGA compatible controller: ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)]
01:00.1 Display controller: ATI Technologies Inc RV370 [Radeon X300SE]
...
Oh and in the KDE Info center, if I try to access the openGL section, KInfocenter crashes .

What can I do from here to get openGL working properly?

Thanks in advance,
Tim.
 
Old 05-17-2006, 09:24 PM   #2
timothee
LQ Newbie
 
Registered: Jan 2005
Location: Singapore
Distribution: Gentoo / Mepis
Posts: 10

Original Poster
Rep: Reputation: 0
Never mind, I had forgotten to enable the xscreensaver use flag when emerging kdeartwork-kscreensaver. I've done that and now it works! Sweeeeet !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
trying to get ati driver working. DeltaFeegamma Debian 1 05-04-2006 08:36 AM
ATI Driver installed. Ubuntu 5.10. not working javb Ubuntu 3 01-22-2006 06:51 PM
Is this right for Working ATI driver MaTrIx709 Debian 2 08-02-2005 06:49 PM
ATI fglrx driver - can't get dri working SpruceMoose Linux - Hardware 1 06-20-2005 11:22 PM
Xorg ATI Driver (working, but not fully) chup Linux - General 1 03-20-2005 04:41 PM


All times are GMT -5. The time now is 01:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration