LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 12-03-2003, 11:45 PM   #1
sirra462
Member
 
Registered: Nov 2003
Posts: 58

Rep: Reputation: 15
ATI driver install - SuSE 9.0 answered!!


#updated 4-19-2004
#Suse now has working instructions for the current driver 3.7.6 go to their website here
#follow the readme and you should be set.
#This works if you simply want to update your current version of the driver as well.
#You can still refer to my tutorial if you wish to use the older drivers (before 3.7) but I recommend
#the newer ones. You guys have all been great to work with. I hope that the XT issues have been
#resolved!!

This should solve your 3D accel problems with SuSE 9.0/8.* and Radeon 9700/9800 and possibly more.

1. You must have the kernel-sources package installed on your system. This should come on your CD's if you have the Pro version, or you can get it from one of SuSE's ftp server.

You can check to see if you do by running

rpm -qa | grep kernel

This should output something like : kernel-sources-2.4.*** depending on your kernel.
If you have this package installed you need to download the fglrx.rpm and km_fglrx.rpm from SuSE's ftp server here:
Needed RPMS

read SuSE's README, but follow my directions, note that SuSE explicity states that:
-3D accleration is not selectable in sax2 using this method
-only 24-bit color depth is supported

2. Install these rpms and follow MY instructions, for SuSE has missed a small point

Go to a console, i.e. get out of xserver (better yet boot into init 3 if you know how to do this) by typing ctrl+alt+F1
This will bring you to a console login. Login as root. Now run
init 3
This will bring you to the needed runlevel.

Now cd to where the fglrx.rpm and km_fglrx.rpm are.

run these commmands in this order:
rpm -Uhv fglrx.rpm
rpm -Uhv km_fglrx.rpm

cd /usr/src/linux (or better to do: cd /usr/src/linux-2.4.**** if you have that option)
make cloneconfig
make dep
cd /usr/src/kernel-modules/fglrx
make -f Makefile.module
make -f Makefile.module install
sax2 -r -m 0=fglrx -b /usr/X11R6/lib/sax/profile/firegl

(the above 0=fglrx is a zero, not an o)

in sax2 just accept the settings, in my experience sax sux and you can edit it later. (If you are comfortable using sax, go ahead and adjust mouse, monitor etc, but leave videocard info alone!!!)

now use an editor to add
Load "dri"
to /etc/X11/XF86Config
(optional: add Load "GLcore")

under the section "Modules"

Now a lot of you have seen these previous steps before, but not in this order. You have to add the kernel module (km_fglrx) to the system before the kernel configuration (make cloneconfig make dep). This resolves the drm module error that I have seen all over the place.

ITS NOT OVER YET!

4. Go into X and type

lsmod

you should see that fglrx is running and is used by 0 if it is NOT working and some number if it IS working. Also check to see if agpgart is running. If these are both running and have processes that are using them, you may be lucky and have it working already, if not read on)

5. You need to use external agpgart module for this to work. If you compiled your kernel and have done it correctly, you can use the internal agpgart module. I will focus on the external method as it is the easiest to implement.
enter the following into a command line:

cd /etc/X11
fglrxconfig

Read the directions carefully and select your choices based on your system. If in doubt, just hit enter to select the default.
The important one to look out for is:

Do you want to use external AGPGart module? [y/n] [n]
This is defaulted to n, and you need to choose y.

6. Now

cd /etc/init.d

now edit the boot.local file by adding the following line:

/sbin/insmod agpgart

7. REBOOT! I know, I know, this is linux, but I think this is necesarry for this process. (Please correct me if I am wrong and you know a way to simply restart the Xserver)

When the system reloads it will load the agpgart module right away, and this needs to be loaded before the fglrx module. Now you can run glxgears and see that you have 2000-4000 fps if it is working. If you get 300 or so, something is wrong. Also you can type fglrxinfo and it should read something like this:

OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon 9800 (AIB) Athlon (3DNow!)
OpenGL version string: 1.3 (X4.3.0-3.2.8)

I found that you know it is working if in lsmod you see that fglrx and agpgart both have processes running.
This can be a frustrating process, and very testing, but trust me it works. If you find that you did not get it to work, I recommend undoing everything that you have done and starting over. A fresh install works best, and cleans up garbage that you have left behind.

My system information if you need it:
Nforce 2 mobo (all the same )
Radeon 9800 Pro
kernel: k_athlon-2.4.21-144

I hope that this helps!

Last edited by sirra462; 04-19-2004 at 09:52 PM.
 
Old 12-05-2003, 01:34 AM   #2
dhoff
LQ Newbie
 
Registered: Jul 2003
Distribution: Suse 8.2
Posts: 5

Rep: Reputation: 0
Restart the X-server from runlevel 3. Type this in at the prompt " telinit 5" . BTW to drop down to runlevel 3 from X ctl-alt-F1 (or just open an xterm) and type in "telinit 3" . To restart X while it is running,
(This is handy if X freezes up) ctl-alt-backspace. To start the system in runlevel three at boot time. Interupt the bootloader as soon as it shows up by tapping a key. and type in "linux 3"
 
Old 12-06-2003, 10:38 AM   #3
fernandoo
Member
 
Registered: Sep 2003
Posts: 37

Rep: Reputation: 15
Thank you very much for this!!! Really!! I had already spent hours and hours!


But there are some errors:

make -f Makefile.modules
make -f Makefile.modules install

THIS IS WRONG! There is a s too much! Its:

make -f Makefile.module
make -f Makefile.module install

Theres another thing!

When you say one has to put Load "dri" , you could also say under the Section "Module"


While configuring fglrxconfig you say the question is:

Use internal AGPGart module?

but it is

Do you want to use external AGPGart module?

and then the answer is yes!
 
Old 12-06-2003, 11:02 AM   #4
sirra462
Member
 
Registered: Nov 2003
Posts: 58

Original Poster
Rep: Reputation: 15
Thank you for the corrections I hope that they didn't lead people astray. I have made the changes that you requested.
 
Old 12-06-2003, 07:18 PM   #5
lightweave
LQ Newbie
 
Registered: Dec 2003
Posts: 18

Rep: Reputation: 0
I tried several hundered (not exactly but close) methods to activate 3D acceleration for my Radeon 9800XT. Your method was so far the best, because up till now I couldn't get X even running when I loaded agpgart with fglrx. With your method at least X works now AND is using the fglrx (This was really a surprise).

The annoying thing is that OpGL still renders via Mesa on my box and I don't know why.

When I look into /usr/lib I can see that the libs are the normal Mesa libs, so I wonder where you got the OpenGL libs from. Either something wnet wrong with my installation or you had to do something else which you forgot to mention.

What is the output when you do this?

ls -l /usr/lib/libGL*
and
ls -l /usr/X11R6/lib/libGL*

Could you post this please?

Maybe I can see then whats different with your installation then with mine.
 
Old 12-06-2003, 10:30 PM   #6
sirra462
Member
 
Registered: Nov 2003
Posts: 58

Original Poster
Rep: Reputation: 15
For the first part I get:

ls -l /usr/lib/libGL*
-rwxr-xr-x 1 root root 4209 2003-09-23 14:37 /usr/lib/libGLcore.s o.1
lrwxrwxrwx 1 root root 12 2003-12-03 18:59 /usr/lib/libGL.so.1 -> libGL.so.1.2
-rwxr-xr-x 1 root root 569145 2003-09-23 14:37 /usr/lib/libGL.so.1. 2
lrwxrwxrwx 1 root root 13 2003-12-03 18:59 /usr/lib/libGLU.so.1 -> libGLU.so.1.3
-rwxr-xr-x 1 root root 583449 2003-09-23 14:37 /usr/lib/libGLU.so.1
and for the second

-rw-r--r-- 1 root root 27946 2003-09-23 14:23 /usr/X11R6/lib/libGLw.a

I think that if you are using mesa instead of OpenGL you need to make sure that everything is uninstalled before going through my post. I said that this works best with a fresh installation. Obviously it is not needed, but I found that it works best. I hope you get to it, I can help you tomorrow if needed.
 
Old 12-07-2003, 04:35 AM   #7
lightweave
LQ Newbie
 
Registered: Dec 2003
Posts: 18

Rep: Reputation: 0
That's what I thought:

Yours:

-rwxr-xr-x 1 root root 569145 2003-09-23 14:37 /usr/lib/libGL.so.1. 2

Mine:

-rwxr-xr-x 1 root root 643191 Dec 7 01:33 libGL.so.1.2

As you can see the size differs. I wonder why.

I did a complete fresh install of Suse 8.2 Pro to see if this makes any difference. I don't know why your lib is different from mine, because I followed your steps exactly.

With your instructions I got at least X to use the agpgart/fglrx modules. In my installation I never got it running, but I think this is not the problem of the driver itself, but of the OpenGL subsystem. Something is crewed up there.

I really wonder where you got that lib from because I just looked into the two modules I downloaded from your link and it is not in there. As a maater of fact there absolutely no OpenGL lib in there. I'm not surprised about this because this is the closed part.

Could you maybe send my this library?

sparhawk@gmx.at
 
Old 12-07-2003, 12:18 PM   #8
sirra462
Member
 
Registered: Nov 2003
Posts: 58

Original Poster
Rep: Reputation: 15
I could send you the library, but it looks like mine is older than yours?! Yours says Dec. 7 and mine Sept. 27, so there must be some discrepency. What do you get when you run

lsmod

?

It sounds like you have everything that you need, it is just not running the agpgart module before the fglrx module. You can try the following to test this:

rmmod fglrx
insmod agpgart
insmod fglrx

Of course will get a warning that the kernel will be tainted by the fglrx module, ignore, it is supposed to be there.
Try adding
Load "GLcore" to your XF86Config file under "Modules" I know it's stupid, but maybe....

Last edited by sirra462; 12-07-2003 at 12:42 PM.
 
Old 12-07-2003, 02:15 PM   #9
lightweave
LQ Newbie
 
Registered: Dec 2003
Posts: 18

Rep: Reputation: 0
The problem is that I can load both modules and I also can see that X is using the driver because the usage mode of fglrx goes up (and agpart as well).

The problem is that, when I have to OpenGL lib installed from ATI I get an error when KDE starts up. It uses some OpenGL functionality to speed up the desktop as well. When I remove the OpenGL and switch it to Mesa then everything works.

Another issue is(I dected this only now) that wine also crashes X when I'm using the agpgart/fglrx modules, but that is another issue.

I just tried your libs, but that did't work either.

I don't know else what to do to get KDE running with 3D acceleration enabled. It's really frustrating. Paying about 500USD for that card and you can't use it.
 
Old 12-07-2003, 10:41 PM   #10
Quade2000
LQ Newbie
 
Registered: Dec 2003
Location: Toronto
Distribution: SuSE 9.0
Posts: 5

Rep: Reputation: 0
Question

OK, just wanna be sure. Total newbie here.

1. The instructions are complete and updated with all needed corrections?

2. When finished the 3D Acceleration will show Enabled?

3. I installed the kernel source(208mb?) through Yast from the CD, but how do I know what/if headers are installed? And is the source from the CD sufficient, as I have the k_athlon-2.4.21-144 patch from the update during install ? (just ran yast online update, and it wants to update my source package! cool!)

4. For the sections on editing.. what editor should a newbie use? (simple)

5. "ITS NOT OVER YET! 4. Go into X and type" how does one go into X ?

Thanx in advance!
 
Old 12-08-2003, 09:06 AM   #11
sirra462
Member
 
Registered: Nov 2003
Posts: 58

Original Poster
Rep: Reputation: 15
1. Yes I have updated them

2. No, YaST or Sax will not show 3d enabled. You can only infer this information by running the command fglrxinfo, or glxgears or some other test will suffice. See my post above to see what the ouput of each should entail.

3. Headers have been included with kernel-source packages for some time now. (I only recently learned this) So you have the headers already.

4. In this situation, preferably something non-graphical as I instruct you to be in runlevel 3. Some good editors are vi (not for newbies) and pico (easy to use). pico lists all commands needed at the bottom of the terminal. In order to invoke these commands in pico you must use control + (command). For example pico displays ^O (write out) at the bottom of the terminal, one would hit ctrl+O to save the current changes. To modify the boot.local file, you will be in a graphical mode so you can use any of these: gedit, kate, kedit as they all resemble "notepad" from windows and are easy to use.

5. I say go back into X because you are (should be) in runlevel 3 which is a non-graphical mode. X refers to X windows. When you get to the indicated step you can type startx to start the X windows system.

Good luck!

Last edited by sirra462; 12-08-2003 at 09:09 AM.
 
Old 12-08-2003, 12:59 PM   #12
lightweave
LQ Newbie
 
Registered: Dec 2003
Posts: 18

Rep: Reputation: 0
Are you running a 2.4 kernel? Or already 2.6? It's really frustrating! I followed your instructions to the letter, and even made a clean install to do this, and still it doesn't work.
 
Old 12-08-2003, 01:00 PM   #13
lightweave
LQ Newbie
 
Registered: Dec 2003
Posts: 18

Rep: Reputation: 0
Forgot this in my previous post.

If you have a 2.4 kernel which settings did you activate? Or are you running the normal installed one?
 
Old 12-08-2003, 01:50 PM   #14
Wolfgang67
Member
 
Registered: Dec 2003
Location: Cologne/Germany
Distribution: Slackware 9.1 / Suse 9.1
Posts: 56

Rep: Reputation: 15
I'm not completely sure about this, but sirra has an nforce board (which btw only works with the external agpgart according to the www.gmpf.de howto). If you have some other Chipset you might be out of luck (like me).

Have a VIA KT 400A and no matter what I try I can't get this ATI 9800 pro to work. I wont give up though as I WANT TO TAME THE BEAST
 
Old 12-08-2003, 01:59 PM   #15
Madrigar
LQ Newbie
 
Registered: Dec 2003
Distribution: SuSE 9.0
Posts: 11

Rep: Reputation: 0
The SuSE Admin Guide mentions that any user that wants to use 3D acceleration, needs to be a member of group video. I am checking that when I get home tonight...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Driver in SUSE 9.3?? luthfi Linux - Newbie 1 10-15-2005 01:37 AM
How install ATI driver on SuSE 9.1 Prof fireedo Linux - Newbie 2 02-23-2005 11:46 PM
ATI Driver prob: Black screen after driver install linuxboynz Linux - Laptop and Netbook 2 10-19-2004 03:52 AM
ATI Driver problem on SuSE 9 TheOtaku Linux - Software 3 04-22-2004 05:42 PM
No Screen Found on ATI driver install in SUSE scriptures4life Linux - Hardware 2 07-20-2003 10:37 AM


All times are GMT -5. The time now is 04:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration