LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-29-2007, 01:15 PM   #1
onlineapps
LQ Newbie
 
Registered: Aug 2006
Location: United States
Distribution: Kubuntu
Posts: 5

Rep: Reputation: 0
"Analog input cannot display this video mode" in full screen


I'm running Kubuntu Feisty on a Dell Dimension 4700 with a ATI Radeon X300 card and the fgrlx driver from the repos at 1280x1024. The monitor is (I think) a Dell 1704FPV. Recently, I messed around with fglrx from ATI.com, and then uninstalled that and reinstalled fglrx from the repos. Before, I couldn't get into 1280x1024 (max was 1024x76, but now I can. So that's what I'm in now. Unfortunately, anytime an app goes into full screen (like a game in WINE or VDrift), the screen goes black and displays:

Analog input cannot display this video mode

Dell claims "This means that the monitor cannot synchronize with the signal that it is receiving from the computer. Either the signal is too high or too low for the monitor to use. See Specifications for the Horizontal and Vertical frequency ranges addressable by this monitor. Recommended mode is 1280 X 1024 @ 60Hz."

But dpkg-reconfigure xserver-xorg had it at 60Hz (as did KControl). So, what's going on?
 
Old 09-29-2007, 01:15 PM   #2
onlineapps
LQ Newbie
 
Registered: Aug 2006
Location: United States
Distribution: Kubuntu
Posts: 5

Original Poster
Rep: Reputation: 0
Xorg.conf

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "v4l"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
Option "XkbOptions" "altwin:meta_win"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "ATI RADEON X300"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Extensions"
Option "Composite" "0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 30-65
VertRefresh 50-75
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI RADEON X300"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection
 
Old 09-29-2007, 03:13 PM   #3
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
A few ideas, since there's really nothing technically 'wrong' with your file;

1... After it gives you that error message about not being able to display, go check the logfile /var/log/xorg.0.log and see if there's any hints in there.

2... Try a colordepth of 16 instead of 24. Really, you won't notice any difference, and if it works, you'll be happy

3... Verify that the horizsync range you have specified it correct for the screen. if it is too narrow, the screen won't be able to sync. The vertrefresh for MOST laptop screens hovers right around 60 hz so you should be fine there. just check the horizontal numbers.


Any luck?
 
  


Reply

Tags
monitor


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dell 1905FP flatscreen error "Cannot display this video mode", under X Ford Prefect Linux - Hardware 5 09-30-2008 08:49 AM
Analog Input: Cannot Display This Video Mode gamewolf Linux - Newbie 29 06-09-2007 09:58 AM
Video Card Nvidia Driver Xlib: extension "GLX" missing on display ":0.0". HELP! badgerbox76 Linux - Newbie 35 03-08-2007 02:27 AM
"Cannot Display This Video Mode" Ap-Ion Suse/Novell 7 01-03-2006 09:58 PM


All times are GMT -5. The time now is 03:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration