LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 08-02-2004, 12:02 AM   #1
sendas4
Member
 
Registered: May 2004
Location: Tacoma, Wa
Distribution: Gentoo
Posts: 94

Rep: Reputation: 15
Why the hell is linux running so slow! plz help


Im running a Athlon Xp 2500+ 512MBs of Kingston ValueRam DDR400, Asus A7N8X-E Deluxe. MSI Nvidia 5200fx (i know it sucky card :P) and 40GB 7200 Western Digital HD. gentoo with 2.6.7.

I cant figure out why my computer bogs down so bad. When im emerging i can barely move the mouse. and games that ran perfect like neverwinternights in windows run pretty bad. I made sure DMA is enabled on my hd. And glx is on for my video card im using Fluxbox as my wm. glxgears gives me only 1000fps. im at a lose please does anyone have any ideas?
 
Old 08-02-2004, 01:34 AM   #2
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
try this command:

Code:
ps aux
That will show everything that is running in the background.

A trick I use when I plan to be using the computer and emerge something is this:

Code:
nice -n +10 emerge ****
That gives emerge a lower priority since most everything runs at 0. It tells it to give me priority over the emerge. It will emerge at about the same speed just keeps you from being able to tell it is running.

Hope that helps. Post back if it don't.

BUMP if anyone else has ideas.

 
Old 08-02-2004, 01:36 AM   #3
WMD
Member
 
Registered: Jul 2004
Location: Florida
Distribution: Slackware, Debian
Posts: 484

Rep: Reputation: 30
Does this only happen when you emerge? Emerge uses all your CPU time to compile, and makes stuff slow.

Easiest solution is to emerge stuff right as you're getting off the computer.
 
Old 08-02-2004, 01:46 AM   #4
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
I forgot to add this bit. You can change the nice level in make.conf too. Then it will do it for you.

Lster

 
Old 08-02-2004, 04:42 AM   #5
sendas4
Member
 
Registered: May 2004
Location: Tacoma, Wa
Distribution: Gentoo
Posts: 94

Original Poster
Rep: Reputation: 15
It also happens when I decompress rar or gz files. Do you guys think 1000 is normal Fps on glxgears for my setup?
And thanks that command did help for when im emerging and using the comp.
 
Old 08-02-2004, 05:26 AM   #6
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
Well this is what I get:

Code:
dale@smoker ~ $ glxgears
2782 frames in 5.0 seconds = 556.400 FPS
3191 frames in 5.0 seconds = 638.200 FPS
3619 frames in 5.0 seconds = 723.800 FPS
3586 frames in 5.0 seconds = 717.200 FPS

dale@smoker ~ $ cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 10
model name      : AMD Athlon(tm) XP 2500+
stepping        : 0
cpu MHz         : 1830.110
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow
bogomips        : 3612.67

dale@smoker ~ $
That is with the screen the size it pops up as, ya know, kind of small. I run 1280x1024 for my 19" monitor. We have a similiar rig.

I'd say that ain't to bad myself. I'm no gaming guru though.

Later

 
Old 08-02-2004, 12:37 PM   #7
sendas4
Member
 
Registered: May 2004
Location: Tacoma, Wa
Distribution: Gentoo
Posts: 94

Original Poster
Rep: Reputation: 15
Thanks for the help dalek.
this has helped out alot when i need to use the computer when Im emerging.
Code:
nice -n +10 emerge ****
 
Old 08-02-2004, 12:51 PM   #8
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
Don't forget you can set this in make.conf. Looks something like this:

Code:
# PORTAGE_NICENESS provides a default increment to emerge's niceness level.
#     Note: This is an increment. Running emerge in a niced environment will
#     reduce it further. Default is unset.
#PORTAGE_NICENESS=3
Note this also. The lower the number, the higher the priority. -10 has more priority than +10 for example. It is sort of the opisite of what you would think.

Glad that helps a bit.

Later

 
Old 08-02-2004, 02:17 PM   #9
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
going further
check for unecessary services running
also one of the best option
recopmile ur kernel
 
Old 08-02-2004, 09:00 PM   #10
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
Quote:
going further
check for unecessary services running
also one of the best option
recopmile ur kernel
He runs Gentoo. He did compile his own kernel. Since he runs Gentoo, the only services running are those he typed in to run through rc-update. There are very few that are installed and run without you knowing about it. It does updatedb, as a cron job, and the file system maintanence of course but that is required anyway. Gentoo is not like Mandrake or Redhat.

I have read where most people set the nice to a different level. It runs so well you can't even tell it is running.

NOTE: updatedb is set to run a 3:00AM. If you, like me, are up and about at that time, you may want to change the cron job for that. If for example you boot up at 8:00AM and the machine was off at 3:00AM when it was set to run, it will start shortly when cron does the next check. If you don't use locate, you can remove the updatedb process all together. This usually only takes a few minutes though.

If you want to see what services are set to run, type in rc-update show, that will list them.

Hope all this info helps.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
plz help. modem problem. im totally new to linux. im running mandrake 10.0. dhrumantgoradia Linux - Hardware 3 11-29-2004 03:14 PM
firefox running slow as hell ! (loading ppages slower than my 56k) qwijibow Linux - Software 6 08-24-2004 10:25 AM
Jboss hell with ejbs plz help juby Programming 0 12-15-2003 03:01 PM
Linux Running Slow frkstein Linux - General 10 08-06-2002 10:58 AM
Linux Running Very Slow... egh128 Linux - General 2 04-26-2002 09:17 AM


All times are GMT -5. The time now is 05:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration