LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-23-2004, 03:19 PM   #1
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
firefox running slow as hell ! (loading ppages slower than my 56k)


I have a 600kbit connection to the internet,
ive just re-installed gentoo.

im at a very minimal stage,, only X, twm, Firefox and thingerbird are installed.

wget downloads at a steady 70kbytes per second.

however webpages are loading very slowly, and in some case not at all. nomatter what website or server im viewing.

normally, my interconnection is so fast pages load seemingly instantly, but now, the forum posts on this site are loading line by line... taking minutes...

apart from a few changes, im using the same kernel ive always used...
i removed floppy disk support
and changed USB support from built in to module.
and added in built .config accessable by /proc

any ideas whats going wrong ?

im running firefox 0.9.3 kernel 2.6.8-1-gentoo-r1 and my internet connection is via the ethernet pci card (not usb)

gentoo has been emerged with the flags i always use "-O3 -pipe -march=athlon -fomit-frame-pointer"

thanks for any feed back....

i will probably be using konqueror web browser when kde 3.3 makes it into the emerge portage tree, but untill then, i only have firefox.
 
Old 08-23-2004, 03:35 PM   #2
AltF4
Member
 
Registered: Sep 2002
Location: .at
Distribution: SuSE, Knoppix
Posts: 532

Rep: Reputation: 31
Try turning off IPV6 support if you don't need it
There are known problems with FireFox and IPV6 in 2.6 kernels

in "/etc/modprobe.conf" find ipv6 and disable it:

# Turn off IPv6
alias net-pf-10 off
alias ipv6 off


then reboot and retry.
 
Old 08-23-2004, 03:39 PM   #3
AltF4
Member
 
Registered: Sep 2002
Location: .at
Distribution: SuSE, Knoppix
Posts: 532

Rep: Reputation: 31
If this does not help try reading this "Firefox Tweak Guide"
http://www.tweakfactor.com/articles/...oxtweak/4.html
 
Old 08-23-2004, 03:43 PM   #4
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
hey

why don't u try netscape and opera
they are working fine with me

regards
 
Old 08-23-2004, 06:33 PM   #5
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
Quote:
why don't u try netscape and opera
they are working fine with me
the probablility that our systems are identicle are very rare.

ive not compiled ipv6 support in my kernel....
but ill have a do at dissabling it anyways.

thanks for the tweak guide.
 
Old 08-24-2004, 07:51 AM   #6
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
hi
there i was telling about the above because i have seen them work fine on all the computers in my network
it is worth giving a try
regards
 
Old 08-24-2004, 09:25 AM   #7
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
okay.. but in the past, ive had great results with firefox....
ive finally compiled kdebase... and konqueror is suffering the same problem...

so this is either an ISP problem,, or a kernel problem.
and it think it is unlikely its the kernel... ive used this kernel before with no problems what so ever.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux Firefox Slower than Windows Firefox on same machine gherikill Linux - Software 17 02-21-2008 12:06 AM
Konqueror Slower than Firefox TigerLinux Linux - Software 3 11-24-2005 01:08 AM
DSL Slower than 56K SenakSquared Linux - Networking 2 10-09-2005 11:27 PM
Xandros and Firefox is slower then the second coming... coopns Linux - Newbie 6 03-31-2005 08:22 AM
Why the hell is linux running so slow! plz help sendas4 Linux - General 9 08-02-2004 08:00 PM


All times are GMT -5. The time now is 02:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration