LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-11-2004, 12:01 PM   #1
BarryM45
LQ Newbie
 
Registered: Jan 2004
Location: UK, South East
Distribution: slackware, SUSE
Posts: 24

Rep: Reputation: 15
wget 404 error


Hi,

I am running on suse 9.1 trying to perform an update with YOU this is giving me the error of "connect failed". Looking through the documentation i see that YOU uses wget to download the nessasary information for yast. I have investigated my /etc/wgetrc file and and manually added the HTTP and FTP sections as well as turned on the proxy settings. I have also tried passive and non passive modes of connection.

if i enter wget www.suse.com. wget downloads the index.html file from suse however if i place a subdirectory such as i386 or pub the 404 error occurs. i can surf the internet thorugh Konqueror and mozilla. kbear can also connect. My machine lives behind a bordermanager firewall. I am a little bit lost as to where to go next with this problem now any pointers would be appreciated.

Best
barry
 
Old 10-11-2004, 05:54 PM   #2
servnov
Member
 
Registered: Sep 2004
Distribution: Slackware 10.2
Posts: 276

Rep: Reputation: 30
are you using wget as root user? if so, do NOT! it probably won't even work under root as ftp usually blocks root.
 
Old 10-12-2004, 06:12 AM   #3
BarryM45
LQ Newbie
 
Registered: Jan 2004
Location: UK, South East
Distribution: slackware, SUSE
Posts: 24

Original Poster
Rep: Reputation: 15
Thanks for your reply sernov,
It turns out i had made an error in my proxy settings in yast. forgot to specify the ports at the end of the proxy servers ip address. Once i added http://xxx.xxx.xxx.xxx:8080 everything worked as expected.
Barry
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
why is apache giving me a 404 error linuxmandrake Linux - Software 4 06-17-2005 10:16 AM
odd Apache 404 error Seventh Linux - Software 1 03-27-2005 04:43 AM
wget gives me 404 when IE works just fine...? ivj Linux - Software 7 07-24-2004 11:13 PM
Xmms + Netjuke: 404 error when trying to play. Ctawp Linux - Software 1 11-21-2003 04:40 PM
(404)error johncla Linux - Networking 1 03-25-2001 07:09 PM


All times are GMT -5. The time now is 09:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration