LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-13-2007, 03:46 PM   #16
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130

Quote:
If I tried using a range it seemed to keep going to 50Hz and there wouldnt be any other options in the drop down list to select from.
That's what would happen if your xorg.conf hasn't got the DisableTwinView line; it's a bug in the nvidia driver (or is it? nvisia blames Gnome). Once it was inserted, I could choose from the full set of ranges again.

Quote:
can only assume that the buzzing sound is the screen, before you ask I am almost certain its not a fan or the HD or something like that.
I don't know, I've never had to deal with anything like that. I don't think a screen would make any sound, it's more likely the GPU or CPU that is getting stressed under certain conditions.

Quote:
The Modules section you mentioned...should I just copy yours or specific lines from it?
You can copy all ot them. Just make sure that you have a back-up and that you they are copied properly.
 
Old 08-14-2007, 03:49 PM   #17
woodpecka_04
Member
 
Registered: May 2007
Distribution: Fedora Core 6
Posts: 47

Rep: Reputation: 15
Okay I have tried what you suggested, I now find myself with the following xorg.conf

Quote:

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "Module"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
Load "glx"
Load "dbe"
Load "extmod"
Load "glx"
Load "dbe"
Load "extmod"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Monitor 1280x1024"
HorizSync 31.5 - 79.0
VertRefresh 50.0 - 85.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "NoLogo" "True"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "DynamicTwinView" "False"
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
When I access System - Preferences - Screen Resolution, the refresh rate is now stuck on 60Hz...there are no options to change to. Despite me resetting the VertRefresh to a range?

Interestingly enough the refreshing is slightly better, still not perfect though.

Any other suggestions?

Thanks for all your help so far btw.
 
Old 08-14-2007, 06:16 PM   #18
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Are there any warnings in Xorg.0.log?

cat /var/log/Xorg.0.log | grep WW

As for the refresh rates, have your been able to verify that those are the exact rates supported by your monitor? I find it weird that your vertical rates are somewhat higher than the horizontal ones. This is unusual considering that
- horizontal rates of LCDs as a rule are higher than their vertical rates
- vertical rates of CRTs as a rule are MUCH higher than their horizontal rates

Note that too modest rates will result in lower overall refresh rates. Note also that setting them higher than what is supported will result in a blank screen! Always try to find documentation first.

Last edited by jay73; 08-14-2007 at 06:18 PM.
 
Old 08-15-2007, 12:30 AM   #19
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Try if it helps if you add
Code:
Option "UseEdidFreqs" "FALSE"
to the device section.
 
Old 08-15-2007, 02:40 PM   #20
woodpecka_04
Member
 
Registered: May 2007
Distribution: Fedora Core 6
Posts: 47

Rep: Reputation: 15
Output from the log file does point to something interesting...

(WW) NVIDIA: No matching Device section for instance (BusID PCI:0:10:3) found
(WW) NVIDIA(0): No valid modes for "1152x864"; removing.
(WW) <default pointer>: No Device specified, looking for one...

I can't find out what screen I have...its a laptop so im presuming its LCD. I really know very little about screens. I just can't find any real techincal details for the laptop -- its an HP Pavillion dv6000.

I hope the warning messages above provide some sort of clue.

Cheers
 
Old 08-15-2007, 03:10 PM   #21
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
How did you install that driver? Did you use one from the nvidia site or did you use the oen from livna?
 
Old 08-16-2007, 01:51 PM   #22
woodpecka_04
Member
 
Registered: May 2007
Distribution: Fedora Core 6
Posts: 47

Rep: Reputation: 15
It was a while ago but from what I can remember I installed kmod-nvidia via Yum.
 
Old 08-17-2007, 09:40 AM   #23
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
What is the output of lspci? Just trying to verify whether the car is really on 0:10:3.
 
Old 08-17-2007, 09:54 AM   #24
woodpecka_04
Member
 
Registered: May 2007
Distribution: Fedora Core 6
Posts: 47

Rep: Reputation: 15
The lspci output is:

00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:02.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:04.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0a.3 Co-processor: nVidia Corporation MCP51 PMU (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev f1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev f1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address
Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Con
troller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscella
neous Control
03:00.0 Network controller: Broadcom Corporation BCM4310 UART (rev 01)
05:00.0 VGA compatible controller: nVidia Corporation GeForce Go 7200 (rev a1)
07:05.0 FireWire (IEEE 1394): Ricoh Co Ltd Unknown device 0832
07:05.1 Class 0805: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 1
9)
07:05.2 System peripheral: Ricoh Co Ltd Unknown device 0843 (rev 01)
07:05.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (re
v 0a)
07:05.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)


If my eyes aren't deceiving me there doesn't appear to be any instance of 00:10:3?
 
Old 08-17-2007, 11:02 AM   #25
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Exactly. Try using 0:10:0 instead - or simply put a hash in front of that line so that it gets skipped (the system will figure out where the card is; and also, not defining any BusID is always better than defining it incorrectly).
 
Old 08-17-2007, 02:37 PM   #26
woodpecka_04
Member
 
Registered: May 2007
Distribution: Fedora Core 6
Posts: 47

Rep: Reputation: 15
Yeah I see what your saying but I have never defined a BusID anywhere in my xorg.conf.

I don't see why it is coming up with that message. I know you can have BusID in the Device section but I don't have one in mine and I never have!?
 
Old 08-17-2007, 03:29 PM   #27
woodpecka_04
Member
 
Registered: May 2007
Distribution: Fedora Core 6
Posts: 47

Rep: Reputation: 15
Right, I have improved the refreshing business somewhat by inserting a modeline:

So in the Screen section I have:
Quote:
Modes "1280x800_60" "1024x768" "800x600" "640x480"
Where "1280x800_60" is the following Modeline in my Modes section:
Quote:
# 1280x800 @ 60.00 Hz (GTF) hsync: 49.68 kHz; pclk: 83.46 MHz
Modeline "1280x800_60" 83.46 1280 1344 1480 1680 800 801 804 828 -HSync +Vsync
As I said, the refreshing seems a bit better -- I am getting less horizontally distorted lines. Furthermore, one of the warnings I got from my Xorg.log has gone...the one that said a certain resolution wasn't available. That resolution is now available when I go to System -- Preferences -- Screen Resolution.

However, I still can't choose from a list of refresh rates

Oh and those stupid comments have stopped being automatically generated !
 
Old 08-17-2007, 04:56 PM   #28
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
That's great. As for the fixed rate, I still suspect this is related to the horizontal and vertical refresh rates. It happens to me as well when I set either (or both) incorrectly. Unfortunately, it seems impossible to find more details for your screen. You can start by gradually lowering the vertical rates since that is the least risky experiment. Raising the horizontal ones may work but it may just as well produce a blank screen. Make sure to have a back-up.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vertical refresh rate question for debian Dstruct0 Debian 2 09-18-2006 12:20 AM
X11-set the vertical refresh rate tramni1980 Slackware 14 08-12-2006 07:54 AM
Vertical refresh rate, horizontal sync rate. NomDeGuerre Linux - Newbie 7 10-07-2005 02:36 AM
refresh rate horizontal/vertical sync TV cjae Linux - Hardware 1 04-15-2005 10:41 PM
Horizontal and vertical refresh rate johannes Linux - Laptop and Netbook 3 10-31-2003 05:44 AM


All times are GMT -5. The time now is 02:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration