LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 08-02-2007, 02:57 PM   #1
shawniecas
LQ Newbie
 
Registered: May 2007
Posts: 24

Rep: Reputation: 15
Vertical Refresh Rate


This may be an easy question, but how do I change my Vertical Refresh Rate? If I go to System -> Preferences -> Screen Resolution it says my Resolution is 1280 x 1024 and my Refresh Rate is 50 Hz, but it won't let me change the Refresh Rate. Do I have to do something in xorg.conf?
 
Old 08-02-2007, 03:50 PM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 62
Quote:
Originally Posted by shawniecas
This may be an easy question, but how do I change my Vertical Refresh Rate? If I go to System -> Preferences -> Screen Resolution it says my Resolution is 1280 x 1024 and my Refresh Rate is 50 Hz, but it won't let me change the Refresh Rate. Do I have to do something in xorg.conf?
Don't know if I would actually believe that when I look in KDE it tells me my LCD is running at 50 but if I use the on-screen display it says 60 for my CRT it tells me again 50 but its on-screen display tells me it is running at 85. I get the same higher values using the nvidia-settings app as well so check your settings using the monitor display or if using nvidia driver use nvidia-settings to check.
 
Old 08-03-2007, 01:05 AM   #3
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
If above does not get you what you want:

The two lines below come from the monitor section in xorg.conf. Adjust both of them to the specs of your monitor (the given values are for my monitor).
Code:
HorizSync    31.0 - 92.0
VertRefresh  50.0 - 150.0
I've found that you're sometimes still limited to 75Hz (depending on videocard and/or driver); if your monitor can do better and if you want better, add the following line to the device section in your xorg.conf
Code:
Option "UseEdidFreqs" "FALSE"
 
Old 08-03-2007, 05:36 AM   #4
m4mach
Member
 
Registered: Jul 2007
Location: Poland
Distribution: Debian
Posts: 45

Rep: Reputation: 15
You can also force refresh rate instead of giving the rage:
Code:
VertRefresh	85
But you should use this carefully. Knowing monitor bandwidth (assuming you have CRT) you can calculate from this formula:
Bandwidth [MHz] = 1.35*width*height*VertRefresh

Last edited by m4mach; 08-03-2007 at 05:50 AM.
 
Old 08-03-2007, 12:22 PM   #5
shawniecas
LQ Newbie
 
Registered: May 2007
Posts: 24

Original Poster
Rep: Reputation: 15
Ok, I used this code: Option "UseEdidFreqs" "FALSE" in my xorg.conf and it works, but now I have a screen resolution of 640x480 and it won't let me change it. I mean, this is the modeline I have:

Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1024x768" "800x600" "640x480"

But again, it will only use the 640x480. I dunno if I should just take it out of the modeline or not
 
Old 08-03-2007, 02:26 PM   #6
m4mach
Member
 
Registered: Jul 2007
Location: Poland
Distribution: Debian
Posts: 45

Rep: Reputation: 15
Write your HorizSync and VertRefresh values. Do you have CRT or LCD monitor?
 
Old 08-03-2007, 05:44 PM   #7
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
The advice Wim Sturkenboom gave is the one that always works for me. Just have the two frequency ranges matching the manufacturer data and you can't go wrong, unless you video driver is way out of line.

The xorg.conf is always stored in /etc/X11 subdirectory. Some distros allow you to run it manually at terminal by command "xongconfig".

Last edited by saikee; 08-03-2007 at 05:46 PM.
 
Old 08-03-2007, 07:49 PM   #8
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 129Reputation: 129
Are you using the Nvidia drivers? Having only 50Hz is a common issue that can easily be solved by editing xorg.conf.
 
Old 08-11-2007, 02:52 PM   #9
woodpecka_04
Member
 
Registered: May 2007
Distribution: Fedora Core 6
Posts: 47

Rep: Reputation: 15
A very similar problem

Hi,

I'm having a very similar problem to the one described above. I am using the Nvidia drivers and the refresh rate seems stuck on 50Hz, despite my nvidia-settings claiming its 60Hz.

I have altered my xorg.conf as above...

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "NoLogo" "True"
Option "UseEdidFreqs" "FALSE"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
ModelName "Monitor 1280x1024"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 31.5 - 79.0
VertRefresh 60.0 - 60.0
Option "dpms"
EndSection


Those comments are automatically generated, and it seems to happen every time I'm on Linux -- I have had to delete hundreds of lines of them before.

I've not had this refreshing problem with previous releases. I find my laptop screen is making a buzzing sound -- which does not occur when im on Windows. When I'm using the internet I can see the screen refresh, lines of text start to overlap and become distorted and sometimes it will freeze completely and I need to hard boot.

Can someone help me with this PLEASE!?
 
Old 08-11-2007, 05:50 PM   #10
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 129Reputation: 129
Quote:
Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation G70 [GeForce 7600 GS]"
Monitor "Acer AL1951"
Option "DynamicTwinView" "False"
Option "DisableGLXRootClipping" "true" #required by Compiz
DefaultDepth 24
SubSection "Display"
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
You need the DynamicTwinView line.
 
Old 08-12-2007, 05:08 AM   #11
woodpecka_04
Member
 
Registered: May 2007
Distribution: Fedora Core 6
Posts: 47

Rep: Reputation: 15
Thanks, that appears to be slightly better, the lines of text still get distorted but now fix themselves much faster...

Just to check though, my xorg.conf now looks like this...

Section "Monitor"
Identifier "Monitor0"
ModelName "Monitor 1280x1024"
HorizSync 31.5 - 79.0
VertRefresh 60.0 - 60.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "NoLogo" "True"
Option "UseEdidFreqs" "False"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "DynamicTwinView" "False"
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

I presume the DynamicTwinView option goes in the Screen section, rather than the Device section?

Although the comments are not shown above:
### Comment all HorizSync and VertSync values to use DDC:
They are still being generated every time X starts, is there any way to stop this?

Thanks for your quick response btw!
 
Old 08-12-2007, 07:03 AM   #12
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 129Reputation: 129
Here is the full thing:

Code:
Section "Files"
EndSection

Section "Module"
    Load        "i2c"
    Load           "bitmap"
    Load       "dbe"
    Load           "ddc"
    Load           "extmod"
    Load       "evdev"
    Load           "freetype"
    Load           "glx"
    Load           "int10"
    Load       "record"
    Load       "type1"
    Load           "vbe"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "be"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"        "/dev/input/mice"
    Option        "Protocol"        "ImPS/2"
    Option        "Emulate3Buttons"    "true"
EndSection

Section "Device"
    Identifier    "nVidia Corporation G70 [GeForce 7600 GS]"
    Driver        "nvidia"
    BusID        "PCI:1:0:0"
    Option        "AddARGBVisuals"    "True"
    Option        "AddARGBGLXVisuals"    "True"
    Option          "RenderAccel" "true" #Compiz
    Option          "AllowGLXWithComposite" "true"    #Compiz
    Option        "UseFBDev"        "true"
EndSection

Section "Monitor"
    Identifier    "Acer AL1951"
    Option        "DPMS"
    HorizSync    30-83
    VertRefresh    55-75
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "nVidia Corporation G70 [GeForce 7600 GS]"
    Monitor        "Acer AL1951"
    Option        "DynamicTwinView" "False"
    Option          "DisableGLXRootClipping" "true" #required by Compiz
    DefaultDepth    24
    SubSection "Display"
        Modes        "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "DRI"
    Mode    0666
EndSection

Section "Extensions"
    Option "Composite" "Enable"
EndSection
Is the modules section missing? As you see, ddc is one of them.
 
Old 08-12-2007, 11:35 AM   #13
woodpecka_04
Member
 
Registered: May 2007
Distribution: Fedora Core 6
Posts: 47

Rep: Reputation: 15
Errr yeah youre quite right there...I don't have a Modules section as such although there is mention of a ModulePath...

This is my entire thing:

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Monitor 1280x1024"
HorizSync 31.5 - 79.0
VertRefresh 60.0 - 60.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "NoLogo" "True"
Option "UseEdidFreqs" "False"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "DynamicTwinView" "False"
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection


Why do I get the horrible feeling that it's all completely wrong lol?
 
Old 08-12-2007, 11:59 AM   #14
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 129Reputation: 129
ModelePath is something completely different (it sets fonts paths).

You can simply include the modules Section in your xorg.conf. Best to make a backup first though, and make sure that you know how to replace it (from the command line) just in case X starts acting weird.

By the way, which distro are you using? Suse?

Oh, and why have you got such rigid VertRefresh rates. Only 60? Are you sure this is the only one that is supported by your monitor?

Last edited by jay73; 08-12-2007 at 12:01 PM.
 
Old 08-13-2007, 01:14 PM   #15
woodpecka_04
Member
 
Registered: May 2007
Distribution: Fedora Core 6
Posts: 47

Rep: Reputation: 15
I'm using FC6.

I decided to set the vertical refresh to 60Hz as it seemed to be the only way to force the monitor to use it. If I tried using a range it seemed to keep going to 50Hz and there wouldnt be any other options in the drop down list to select from. I am only using 60Hz as that is what it appears to be on my Windows OS and I know that works fine (no overlapping of text, no buzzing sound). Although perhaps different OS's have different requirements.

I can only assume that the buzzing sound is the screen, before you ask I am almost certain its not a fan or the HD or something like that. It seems to go away for a few seconds if I'm doing something intense, but then if I just use Emacs or whatever it comes back. I'm not THAT bothered about the noise, more about the freezing and the overlapping text -- that's so frustrating.

The Modules section you mentioned...should I just copy yours or specific lines from it?

Last edited by woodpecka_04; 08-13-2007 at 01:15 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vertical refresh rate question for debian Dstruct0 Debian 2 09-18-2006 12:20 AM
X11-set the vertical refresh rate tramni1980 Slackware 14 08-12-2006 07:54 AM
Vertical refresh rate, horizontal sync rate. NomDeGuerre Linux - Newbie 7 10-07-2005 02:36 AM
refresh rate horizontal/vertical sync TV cjae Linux - Hardware 1 04-15-2005 10:41 PM
Horizontal and vertical refresh rate johannes Linux - Laptop and Netbook 3 10-31-2003 05:44 AM


All times are GMT -5. The time now is 07:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration