LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 05-24-2003, 07:19 PM   #1
ErnstVikenstein
LQ Newbie
 
Registered: May 2003
Posts: 8

Rep: Reputation: 0
Unmounting NFS filesystems: Cannot MOUNTPROG RPC: RPC


when I go to shutdown the PC , error message :
The OS is Maandrake 9.0

"Unmounting NFS filesystems: Cannot MOUNTPROG RPC: RPC: Program not
registered"
Next two lines have this:
"umount2: Device or resource busy"
"umount: /net: device is busy"

Than a cannot close it

So i do
/sbin/ fuser -mu /net (to vérify)
than
/sbin/ fuser -k /net (to kill)
than umount/net

How can i avois all this and fix it so it will shut down properly whit no
correction ?
 
Old 05-30-2003, 06:09 PM   #2
OSI-laya
LQ Newbie
 
Registered: May 2003
Posts: 22

Rep: Reputation: 15
I am also having the exact same problem with mandrake 9.0 on my system. Can't understand how it occured in the first place or how to correct it. Any help would be greatly appreciated.
 
Old 05-30-2003, 10:10 PM   #3
ErnstVikenstein
LQ Newbie
 
Registered: May 2003
Posts: 8

Original Poster
Rep: Reputation: 0
Here is my temporary manual solution

Open your Konsole just before you want to quit and stop the machine

Than first, type this


/sbin/fuser -k /net

and than

umount /net

As soon that i will find where to put it in a shutdown script to make it automatic,
i will tell you.
 
Old 05-30-2003, 10:38 PM   #4
OSI-laya
LQ Newbie
 
Registered: May 2003
Posts: 22

Rep: Reputation: 15
I found out that the problem may be caused by autofs, which is used to automatically mount file systems such as cds or nfs shares whenever they become available, as such, if you havn't started autofs intentially, you should stop it starting at boot to fix the problem, here's how ...

http://www.linux-consulting.com/Amd_AutoFS/autofs.html

Another solution is to kill NFS if you don't need it, this can be done in the mandrake control center,
> system > services , scroll down to nfs and uncheck "start at boot". However the first option of stopping autofs supposedly works so try that first.

I havn't had the chance to try these solutions out yet since i'm at work so if you want i can try them tonight and let you know how it goes or if you do try it out let me know how you go with it.

Goodluck.
 
Old 05-31-2003, 12:10 AM   #5
ErnstVikenstein
LQ Newbie
 
Registered: May 2003
Posts: 8

Original Poster
Rep: Reputation: 0
Your permanent solution works, i've tried it .
Good.
Thanks and
Bonsoir
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NFS RPC: Port mapper failure - RPC: Unable to receive KEJP Linux - Networking 6 12-18-2006 02:14 AM
mountd time out: "mount_nfs: bad MNT RPC: RPC: Timed out" on client brush Debian 1 10-15-2006 02:01 PM
rpc.lockd & rpc.statd twantrd Linux - General 1 05-21-2005 09:24 AM
NFS (RPC time out)rh 9 rinux Linux - Networking 3 09-24-2003 05:02 PM
another NFS question (rpc: progra....) lackluster Linux - Networking 5 03-20-2003 08:32 AM


All times are GMT -5. The time now is 03:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration