LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Unmounting NFS filesystems: Cannot MOUNTPROG RPC: RPC (http://www.linuxquestions.org/questions/linux-general-1/unmounting-nfs-filesystems-cannot-mountprog-rpc-rpc-61628/)

ErnstVikenstein 05-24-2003 07:19 PM

Unmounting NFS filesystems: Cannot MOUNTPROG RPC: RPC
 
when I go to shutdown the PC , error message :
The OS is Maandrake 9.0

"Unmounting NFS filesystems: Cannot MOUNTPROG RPC: RPC: Program not
registered"
Next two lines have this:
"umount2: Device or resource busy"
"umount: /net: device is busy"

Than a cannot close it

So i do
/sbin/ fuser -mu /net (to vérify)
than
/sbin/ fuser -k /net (to kill)
than umount/net

How can i avois all this and fix it so it will shut down properly whit no
correction ?

OSI-laya 05-30-2003 06:09 PM

I am also having the exact same problem with mandrake 9.0 on my system. Can't understand how it occured in the first place or how to correct it. Any help would be greatly appreciated.

ErnstVikenstein 05-30-2003 10:10 PM

Here is my temporary manual solution

Open your Konsole just before you want to quit and stop the machine

Than first, type this


/sbin/fuser -k /net

and than

umount /net

As soon that i will find where to put it in a shutdown script to make it automatic,
i will tell you.

OSI-laya 05-30-2003 10:38 PM

I found out that the problem may be caused by autofs, which is used to automatically mount file systems such as cds or nfs shares whenever they become available, as such, if you havn't started autofs intentially, you should stop it starting at boot to fix the problem, here's how ...

http://www.linux-consulting.com/Amd_AutoFS/autofs.html

Another solution is to kill NFS if you don't need it, this can be done in the mandrake control center,
> system > services , scroll down to nfs and uncheck "start at boot". However the first option of stopping autofs supposedly works so try that first.

I havn't had the chance to try these solutions out yet since i'm at work so if you want i can try them tonight and let you know how it goes or if you do try it out let me know how you go with it.

Goodluck.

ErnstVikenstein 05-31-2003 12:10 AM

Your permanent solution works, i've tried it .
Good.
Thanks and
Bonsoir


All times are GMT -5. The time now is 02:42 AM.