LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-30-2004, 12:49 AM   #1
Br. Nicholas
Member
 
Registered: Nov 2000
Location: Buena Vista, Colorado
Posts: 31

Rep: Reputation: 15
Trouble enabling kernel to load modules in Suse 9.1 Personal


Iím having an enormous amount of difficulty in getting the Broadcom 57xx (bcm5700) driver to load in Suse 9.1 Personal. My problem thus far stems from the Suse kernel not having module loading enabled. Iíve tried several times to rebuild the kernel with module loading enabled, but it just will not enable it.

I have to be missing something here. Iíve followed the instructions from the Suse manual, but it just wonít do it. I get the same kernel message on startup saying that module loading is not enabled. The installation of the bcm5700 driver requires module loading.

Would somebody please help me figure out what I am doing wrong here? Iíd really appreciate it.

Hereís what Iíve done:

Downloaded and installed:
kernel-source-2.6.4-52.i586.rpm
kernel-syms-2.6.4-52.i586.rpm

Made backup copy of the original kernel:
cp /boot/vmlinuz /boot/vmlinuz.old
cp /boot/initrd /boot/initrd.old

(From the Suse manual) The configuration of the current kernel is stored in the file /proc/config.gz. To modify this configuration, go to the directory /usr/src/linux as root and execute the following commands:

zcat /proc/config.gz > .config
make oldconfig

(Iíve tried it with and without make mrproper)

make menuconfig

The program said that module loading was already enabled. I exited, saving the changes. (I also tried make config, with the same results.)

(From the Suse manual) After customizing the kernel configuration, start compilation by entering (remember to change into the directory /usr/src/linux, first):

make clean
make bzImage

(From the Suse manual) If you have configured parts of your kernel to load as modules, launch the module compilation. Do this with

make modules

make modules_install

Then I made sure that Grub was pointed to the new kernel, and made an entry to give me access to the original kernel.

I reboot, using the new kernel, and I get the same message.

Again, any help will be greatly appreciated.
 
Old 08-30-2004, 01:24 AM   #2
Thoreau
Senior Member
 
Registered: May 2003
Location: /var/log/cabin
Distribution: All
Posts: 1,167

Rep: Reputation: 45
I can do one better

Actually, I've just got through upgrading my kernel for Suse 9.1. The personal version does not have nongpl drivers with it. But, don't be upset. The power of ftp will save you.

ftp://ftp.suse.com/pub/projects/kernel/kotd/i386/

Download:

kernel-default-2.6.8cvsblahblahwhothefuckcares.1586.rpm
kernel-default-nongpl-2.6.8cvsblahblahsuckmyass.i586.rpm
kernel-source-2.6.8cvsjesusmyasshurts.i586.rpm

Now install in this order:

kernel-default-2.6.8cvsblahblahwhothefuckcares.1586.rpm
kernel-source-2.6.8cvsjesusmyasshurts.i586.rpm
kernel-default-nongpl-2.6.8cvsblahblahsuckmyass.i586.rpm

modprobe -ae
/sbin/lilo or for grub- I dunno, it's to complex for my brain.. BRAAAIIINNN!!

Reboot, and poof... all that crap gets added to /usr/src/linux/extras to let you know. Isn't that Super! OK, bye.


Thor
 
Old 08-30-2004, 01:42 AM   #3
Thoreau
Senior Member
 
Registered: May 2003
Location: /var/log/cabin
Distribution: All
Posts: 1,167

Rep: Reputation: 45
Oops, I misspoke. The extras modules are in /lib/modules/2.6.8.sdfsad-default. Not in /usr/src/linux/. I need more coffee.
 
Old 08-30-2004, 01:49 AM   #4
Br. Nicholas
Member
 
Registered: Nov 2000
Location: Buena Vista, Colorado
Posts: 31

Original Poster
Rep: Reputation: 15
Wow, that was FAST!!!

I hope it works. -- Downloading it now.

Thank you very much, Thor.
 
Old 08-30-2004, 03:04 AM   #5
Br. Nicholas
Member
 
Registered: Nov 2000
Location: Buena Vista, Colorado
Posts: 31

Original Poster
Rep: Reputation: 15
Thanks for your help, but I still get "No module symbols loaded - kernel modules not enabled."

Was I supposed to recompile the kernel again?

Any other ideas?

I really like Suse, but I'm about ready to give up and try a different distro on this box.
 
Old 08-31-2004, 10:56 PM   #6
Thoreau
Senior Member
 
Registered: May 2003
Location: /var/log/cabin
Distribution: All
Posts: 1,167

Rep: Reputation: 45
No, you were supposed to rm the crap in /lib/modules before you reinstalled the kernel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Load Kernel Modules? binarybob0001 Linux - General 5 11-16-2005 11:15 AM
Extreme Beginner Having Monitor Trouble With Suse 9.1 Personal ajwoodier Suse/Novell 3 04-22-2005 11:47 AM
SuSE 9.1 Personal - having trouble installing kernel source sfmusicman Linux - Distributions 4 12-29-2004 07:57 PM
Trouble installing SuSE 9.1 Personal -- No boot disk images Glorp Linux - Newbie 3 10-23-2004 05:25 AM
new kernel 2.6.7 cant load modules short101 Debian 8 08-21-2004 10:59 PM


All times are GMT -5. The time now is 06:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration