LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-20-2004, 10:40 PM   #1
short101
Member
 
Registered: May 2004
Location: Aust.
Distribution: Debian
Posts: 424

Rep: Reputation: 30
Unhappy new kernel 2.6.7 cant load modules


I've just compiled a custom 2.6.7 kernel, and eventually it worked after installing libqt and about a dozen other things to get xconfig to work. The only problem is that when the kernel was installed using debian:~# dpkg -r kernel-image-2.6.72.6.7_10.00.Custom_i386.deb it all installs except I get this message
Setting up kernel-image-2.6.72.6.7 (10.00.Custom) ...
cpio: /etc/modprobe.conf: No such file or directory
cpio: /lib/modules/modprobe.conf: No such file or directory
I've looked and its right, I dont have a modprobe file in either spot. I do however have a modules.conf and a modules file in /etc and nothing in /lib/modules, except for two folders for my kernels. I'm also getting this error from the kernel log when it starts.
Aug 21 11:09:42 debian kernel: klogd 1.4.1#15, log source = /proc/kmsg started.
Aug 21 11:09:42 debian kernel: Inspecting /boot/System.map-2.6.72.6.7
Aug 21 11:09:43 debian kernel: Symbol table has incorrect version number.
Aug 21 11:09:43 debian kernel: Cannot find map file.
Aug 21 11:09:43 debian kernel: No module symbols loaded - kernel modules not enabled.
Aug 21 11:09:43 debian kernel: Linux version 2.6.72.6.7 (root@debian.example.com) (gcc version 3.3.4 (Debian 1:3.3.4-6sarge1)) #1 Sat Aug 21 10:08:13 WST 2004
Aug 21 11:09:43 debian kernel: BIOS-provided physical RAM map:
I've googled about the system map thing and couldnt seem to actually find any answers. So here I am asking for help again.
By the way, I made the .deb file with this command
debian:/usr/src# make-kpkg --initrd --append-to-version=2.6.7 kernel-image,
which I read about in a post somewhere, because I wasnt getting an initrd image when I was just using the make-kpkg command without the initrd bit.
 
Old 08-20-2004, 11:52 PM   #2
short101
Member
 
Registered: May 2004
Location: Aust.
Distribution: Debian
Posts: 424

Original Poster
Rep: Reputation: 30
recompiled

O.K. I deleted the custom kernel and recompiled it with
ebian:~# make-kpkg --revision=786:MyKernel2.6.7 kernel_image
Then when I ran
debian:~# dpkg -i kernel-image-2.6.7_MyKernel2.6.7_i386.deb
It installed it and didnt say anything about the modprobe files. So then I rebooted with crossed fingers and had less errors but I still dont get modules loaded. Heres the error now
Aug 21 12:16:22 debian kernel: klogd 1.4.1#15, log source = /proc/kmsg started.
Aug 21 12:16:22 debian kernel: Inspecting /boot/System.map-2.6.7
Aug 21 12:16:23 debian kernel: Loaded 22439 symbols from /boot/System.map-2.6.7.
Aug 21 12:16:23 debian kernel: Symbols match kernel version 2.6.7.
Aug 21 12:16:23 debian kernel: No module symbols loaded - kernel modules not enabled.
Aug 21 12:16:23 debian kernel: Linux version 2.6.7 (root@debian.example.com) (gcc version 3.3.4 (Debian 1:3.3.4-6sarge1)) #1 Sat Aug 21 12:01:13 WST 2004
Getting better, the system map and symbols are ok, but still no modules.

Any ideas?
 
Old 08-21-2004, 12:50 AM   #3
atheist
Member
 
Registered: Sep 2003
Location: Iceland
Distribution: Debian Lenny - Kernel 2.6.22.8
Posts: 331

Rep: Reputation: 30
I really thought dpkg took care of the System.map for you... Try this, since --revision doesn't prevent conflicts between kernels of same version.
Code:
#make-kpkg clean && make-kpkg --append-to-version="blah" && dpkg -i kernel-image-2.6.7."blah"_i386.deb
I'm not sure about this, though, since I prefer the old manual method:
Code:
#ln -s /usr/src/linux-2.6.7 /usr/src/linux && cd /usr/src/linux/ && make menuconfig && make && make modules && make modules_install && make bzImage && cp arch/i386/boot/bzImage /boot/vmlinuz-2.6.7 && nano /etc/lilo.conf && lilo && reboot
This method hasn't failed me yet... Perhaps you should give it a try.

Hope this helps.
 
Old 08-21-2004, 03:29 AM   #4
short101
Member
 
Registered: May 2004
Location: Aust.
Distribution: Debian
Posts: 424

Original Poster
Rep: Reputation: 30
Thanks atheist, I tried option one, kernel compiled and I got it installed, rebooted into it, and no modules. Got the same error about no module symbols, and therefore no modules. I went back to make xconfig and rechecked everything there and couldnt see anything that I could have missed, but I wouldnt be surprised if it was something to do with that. Didint try option two, I've got grub and didnt know what command to pass to it. Any one else? Hoping to get this thing going, mostly for tha apci support. I know its in the 2.4 kernel, but as long as I have to change kernels, I may as well have the latest, compiled for my machine. (Which is why I dont want to just get a kernel image)
 
Old 08-21-2004, 04:46 AM   #5
powadha
Member
 
Registered: Nov 2003
Distribution: Debian SID
Posts: 649

Rep: Reputation: 31
Did you install module-init-tools? It's a must for 2.6.x

apt-get install module-init-tools

Btw revision only changes the name of the .deb file not the kernel itself. A safe (and clear) way to use append-to-version is to use the date you're compiling on.

Like today you could use:

make-kpkg --append-to-version=-210804 kernel_image

if you use initrd that would be:

make-kpkg --initrd --append-to-version=-210804 kernel_image

This way you keep all your modules the way they should in their own dir in lib/modules/

Cheers

Last edited by powadha; 08-21-2004 at 04:48 AM.
 
Old 08-21-2004, 06:37 AM   #6
short101
Member
 
Registered: May 2004
Location: Aust.
Distribution: Debian
Posts: 424

Original Poster
Rep: Reputation: 30
Yep, got module-init-tools.
 
Old 08-21-2004, 08:08 AM   #7
powadha
Member
 
Registered: Nov 2003
Distribution: Debian SID
Posts: 649

Rep: Reputation: 31
Did you enable the right settings in your kernel? Might look like a stupid question but a wrong click can screw a lot up....
 
Old 08-21-2004, 09:05 AM   #8
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
Make sure that you have enabled the kmod choice if IIRC it seems that you may have missed it.
Code:
>$ grep -i kmod /boot/config-2.6.8.1-ck3
CONFIG_KMOD=y
 
Old 08-21-2004, 09:59 PM   #9
short101
Member
 
Registered: May 2004
Location: Aust.
Distribution: Debian
Posts: 424

Original Poster
Rep: Reputation: 30
Thumbs up Solved - sort of

Well, dunno what is actually going on here, but I am getting modules loaded at start up. I thought I wasnt, because my sound and mouse werent loading when I first compiled. So I made them into the kernel instead of modules, and then my vfat partition wouldnt load (due to something else) Then I put vfat into the kernel instead of as a module and it still wouldnt work, so then upon delving into that, found the cause (no 8859-1 iocharset support) So, once that was fixed, have gone and loaded new kernel and with ,lsmod have found loaded modules. Just to make sure, I compiled my modem driver, which should load as a module, and upon reboot, found it there, and am now writing this with my shiny new 2.6.7 kernel I had read in a post somewhere about 2.6 saying about no modules loaded in the logs, but that the really do, so I ignored that with the problems that I was having and kept looking for an answer that wouldnt be found. So thanks to everyone that helped, I think I will try and compile again with sound and mouse support as modules and see if will work this time around. Just on a last note (hopefully) does anyone else ouy there with 2.6 kernels get the same message in there kernel logs about not loading modules. Just be interested to know.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Load Kernel Modules? binarybob0001 Linux - General 5 11-16-2005 10:15 AM
Custom kernel does not load modules Ankardo Linux - Newbie 2 06-10-2005 06:30 AM
Unused kernel modules : How to NOT load? _UnPrEdictAbLe_ Linux - Software 0 08-19-2004 01:19 AM
Can't load modules because I'm using an old kernel with everything else updated... leeman_s Slackware 1 05-22-2004 03:30 AM
modules dont load after kernel patched malix Slackware 4 09-23-2002 09:03 PM


All times are GMT -5. The time now is 12:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration